Table of Contents

Introduction ................................................................................................................................. 11
Specifications .............................................................................................................................. 13
Getting Started.......................................................................................................................... 15
  What’s in the box? ..................................................................................................................... 15
  USB driver and software installation ...................................................................................... 15
  Support .................................................................................................................................. 15
  Installing TimeLab™ ................................................................................................................ 17
  Performance notes ................................................................................................................... 19
Front panel features .................................................................................................................. 21
Rear panel features ................................................................................................................... 23
Guidelines for input signal connections ................................................................................... 24
Choosing reference sources ..................................................................................................... 24
Working with dual reference sources ....................................................................................... 26
Making your first measurements .............................................................................................. 29
Tips for new users ..................................................................................................................... 32
Next steps .................................................................................................................................. 33
Block diagram .......................................................................................................................... 35
A brief architectural note .......................................................................................................... 37
Making Measurements .............................................................................................................. 39
  “What’s all this ADEV stuff, anyhow?” .................................................................................. 41
    Allan Deviation (a) .................................................................................................................. 42
    Modified Allan Deviation (m) ............................................................................................... 43
    Hadamard Deviation (h) ....................................................................................................... 43
    Time Deviation (t) ................................................................................................................. 44
    Examining changes in stability over time .......................................................................... 45
    Common artifacts in ADEV and related measurements ...................................................... 46
    Hints for xDEV measurements ............................................................................................ 51
    Working with phase- and frequency-difference traces ......................................................... 53
    Phase difference (Original) (w) ......................................................................................... 53
Phase difference (Unwrapped) (p) ................................................................. 53
Frequency difference (f) ........................................................................... 54
How does TimeLab measure frequency? ...................................................... 55
Phase/frequency measurements with the PhaseStation .................................... 55
Examining traces in detail ........................................................................... 56
Navigating zoomed graphs ......................................................................... 57
Hints for phase/frequency stability measurements ........................................ 59
Phase noise, AM noise, and jitter ................................................................. 61
Integrated noise and jitter measurement ....................................................... 63
The spur table ............................................................................................... 64
Show or hide known spurs .......................................................................... 64
Spur measurement options ......................................................................... 65
Is it a spur, or isn’t it? .................................................................................. 66
Understanding instrument spurs ................................................................. 67
Using noise markers .................................................................................... 69
Hints for noise measurements .................................................................... 70
TimeLab Command Reference .................................................................... 71
File menu....................................................................................................... 73
Load .TIM file (l) ......................................................................................... 73
Save image or .TIM file (s) ......................................................................... 73
Copy image to clipboard (Ctrl-c) ................................................................. 74
Import .RES or .PNP phase noise data (N) .................................................... 74
Import ASCII phase or frequency data (L) ................................................... 74
Export ASCII phase data (x) ....................................................................... 75
Export ASCII frequency data (X) ................................................................. 75
Export binary phase data ............................................................................ 76
Export phase data to Stable32 (Ctrl-x) ......................................................... 76
Export ASCII xDEV trace ........................................................................... 77
Export ASCII AM/PM noise trace ............................................................... 77
Export AM/PM spur table ............................................................................ 77
Exported ASCII files include headers for Microsemi TimeMonitor ............... 78
Print image .................................................................................................. 78
Scale file dialogs by window size

Confirmation prompts default to Yes

Warn before exiting with unsaved plots

Warn before retriggering measurement in progress

Reset all parameters, options, and settings at next startup

Close selected plot (Del)

Close all visible plots (Home)

Delete selected plot's .TIM file (Ctrl-Del)

Quit (q or Esc)

**Edit Menu**

Trace properties (e)

Flatten selected or zoomed phase data (Ctrl-f)

Remove selected or zoomed phase data (F4)

Subtract global linear phase trend (frequency offset) (Ctrl-o)

Subtract global linear frequency trend (drift line) (Ctrl-l)

Subtract quadratic linear frequency trend (drift curve) (Ctrl-q)

Apply notch filter to phase data (Ctrl-n)

Undo last flatten or subtract operation (Ctrl-z)

**Trace Menu**

Phase/frequency traces begin at zero (z)

Show linear phase/frequency residual (r)

Show linear phase/frequency trend (Ctrl-t)

Phase/frequency Y axis unlocked in zoom mode (y)

Averaging window for phase/frequency traces (g)

Increase averaging window (Ctrl +)

Decrease averaging window (Ctrl -)

Draw xDEV traces with spline interpolation (i)

Show xDEV error bars (Ctrl-e)

Clip xDEV traces by noise bandwidth (Ctrl-b)

Clip xDEV traces by confidence (Ctrl-v)

Show separated xDEV variances (N-cornered hat) (Ctrl-h)

Show original traces in N-cornered hat display (F6)
Show correlation gain for selected noise trace (Ctrl-g) ................................................................. 96
Show FFT segment filter slopes (Ctrl-i) ............................................................................................... 96
Show imaginary part of cross spectrum (Ctrl-F3) .................................................................................. 97
Show estimated instrument noise (F2) ................................................................................................. 97
Mark spurs in noise traces (Ctrl-m) ................................................................................................. 98
Suppress spurs in noise traces (Ctrl-s) ............................................................................................. 98
Smooth noise traces (Ctrl-w) ............................................................................................................. 98
Show raw noise trace(s) (Ctrl-r) ......................................................................................................... 98
Show AM noise in PN view (F8) .......................................................................................................... 99
Tick marks (k) .................................................................................................................................. 100
Toggle trace thickness for current measurement (T) ............................................................................ 100

**Display Menu** ................................................................................................................................. 101
Edit colors.......................................................................................................................................... 101
Restore default colors......................................................................................................................... 101
High contrast (C) ............................................................................................................................... 101
Numeric table (Ctrl-n).......................................................................................................................... 102
Clear noise markers (F3) .................................................................................................................... 102
Show cursor time (Ss) ......................................................................................................................... 102
Show cursor time (Hh:Mm:Ss) ............................................................................................................ 102
Show cursor time/datesstamp.............................................................................................................. 102
Do not show cursor values.................................................................................................................. 102
Browse plots one at a time (b) ............................................................................................................. 103
Overlay all loaded plots (a) ................................................................................................................ 103
Toggle visibility of selected plot (v) .................................................................................................... 103
Select next plot in chart (+ or down arrow) .......................................................................................... 103
Select previous plot in chart (- or up arrow) ........................................................................................ 103
Move selected plot up (Ctrl-up arrow) ............................................................................................... 103
Move selected plot down (Ctrl-down arrow) ..................................................................................... 103
X zoom in ( ] ) ................................................................................................................................... 104
X zoom out ( [ ) .................................................................................................................................. 104
Y zoom in ( } ) ................................................................................................................................... 104
Y zoom out ( { ) .................................................................................................................................. 104
Decrease font size (± or Ctrl-mouse wheel) ................................................................. 104
Increase font size ( ) or Ctrl-mouse wheel ................................................................. 104
Refresh deviation traces ( F5 ) .................................................................................. 104

Legend Menu ............................................................................................................... 105
Measurement Menu ..................................................................................................... 109
Masks Menu ................................................................................................................. 111
  Clear mask selection ................................................................................................. 111
  User-defined mask entries ...................................................................................... 111
  Edit mask definitions .............................................................................................. 112
Scripts Menu ................................................................................................................. 113
  Creating a new test script ....................................................................................... 113
  Run script ................................................................................................................ 114
  Edit script ............................................................................................................... 114
  Delete script .......................................................................................................... 114
  Run last-executed script (Shift-Space) ................................................................. 114
  Toggle script console for selected plot (F11) ....................................................... 115
  Stop all running scripts (F12) .............................................................................. 115
Acquire Menu .............................................................................................................. 117
  Jackson Labs PhaseStation ...................................................................................... 117
  Miles Design TimePod ............................................................................................ 117
  Acquire from counter in Talk-Only mode .............................................................. 117
  Acquire from live ASCII file ................................................................................... 118
  HP 53131A/53132A/53181A and 53220A/53230A ....................................................... 118
  HP 5335A and 5370A/B .......................................................................................... 118
  HP 5371A/5372A ..................................................................................................... 118
  Philips/Fluke PM6680 ............................................................................................. 118
  Picotest/Array U6200A series ................................................................................. 118
  Stanford Research SR620 ....................................................................................... 118
  Wavecrest DTS-2050/2070 series ......................................................................... 118
  Symmetricom 5115A / 5120A / 5125A (Frequency stability) ............................... 119
  Symmetricom 5115A / 5120A / 5125A (Phase noise) ............................................ 119
  Stop/repeat acquisition (Space) ............................................................................ 119
Abort and retrigger selected acquisition (Ctrl-a)................................................................. 120
Keep and retrigger selected acquisition (Ctrl-k)................................................................. 120
Enable deferred acquisition (Ctrl-d) .................................................................................. 121
Trigger deferred acquisition(s) (Enter) .............................................................................. 121
Configure deferred acquisition.......................................................................................... 121
Help Menu.......................................................................................................................... 123
User guide (F1) .................................................................................................................. 123
About TimeLab .................................................................................................................. 123
Debug mode ...................................................................................................................... 123
Check for updates (Ctrl-u)............................................................................................... 123
PhaseStation 53100A Measurement Roles......................................................................... 125
Measure single DUT with single external reference .......................................................... 125
Measure single DUT with dual internal references ......................................................... 126
Measure single DUT with dual external references ......................................................... 126
Measure two DUTs with single external reference ........................................................... 127
Measure three DUTs with single external reference ......................................................... 127
Measure three independent DUTs (three-cornered hat) ................................................. 129
Manual configuration ....................................................................................................... 130
Two-Port Residual Measurements ................................................................................... 131
JavaScript API Function Reference .................................................................................. 135
The STREAM.EXE Phase/Frequency Data Server ............................................................. 157
Launching STREAM.EXE ................................................................................................. 159
Using STREAM.EXE .......................................................................................................... 160
/serial:<sernum> ................................................................................................................ 160
/file:<filename> ................................................................................................................ 160
/logfile:<filename> ........................................................................................................... 161
/port:<portnum> ............................................................................................................... 161
/msglvl:<0-5> ..................................................................................................................... 162
/format:<P, F, TSC> .......................................................................................................... 162
/window:<samples> ........................................................................................................... 163
/rate:<1, 10, 100, 1000> ..................................................................................................... 165
/timestamp:<s, MJD> ......................................................................................................... 165
Introduction

The PhaseStation™ 53100A Phase Noise Test Set measures the amplitude, phase and frequency stability of high-performance RF sources and two-port devices. Carrier frequencies from 1 MHz to 200 MHz are supported, with baseband analysis scheduled for support in future software releases. The 53100A tells you everything you need to know about the stability characteristics of your devices, at timescales ranging from femtoseconds to days.

Measurements made by the PhaseStation 53100A include the following:

- Real-time ‘strip charts’ of phase and frequency differences at subpicosecond precision
- Absolute frequency counts at 13+ digits per second, 17 digits maximum
- Allan deviation (ADEV) typically less than 5E-14 at t=1s
- Modified Allan deviation (MDEV), Hadamard deviation (HDEV), and time deviation (TDEV)
- Phase noise and AM noise at offsets from 0.001 Hz to 1 MHz and levels below -175 dBC/Hz
- RMS-integrated time jitter with less than 50 fs residual jitter from 0.1 Hz to 1 MHz
- RMS-integrated phase noise, residual FM, and SSB carrier/noise ratio

Using high performance host-based DSP techniques on a Windows® PC, all of these measurements can be made simultaneously. Results appear as you watch – and you can save, view, compare, export, or print them at any time. Accuracy and stability are inherited from a user-supplied external reference which can run at any frequency within the supported range, with no calibration required by the instrument itself.
## Specifications

<table>
<thead>
<tr>
<th>Specification</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input frequency and level (RF)</td>
<td>1 MHz – 200 MHz, 0 dBm - +15 dBm, 50 ohm N-F</td>
</tr>
<tr>
<td>Reference frequency and level</td>
<td>1 MHz – 200 MHz, 0 dBm - +15 dBm, 50 ohm N-F</td>
</tr>
<tr>
<td>Input/reference VSWR (&lt;= 100 MHz)</td>
<td>1.5:1 or better</td>
</tr>
<tr>
<td>Input/reference port isolation (10 MHz)</td>
<td>130 dB or better</td>
</tr>
<tr>
<td>Maximum DC voltage at any input</td>
<td>+/- 24V</td>
</tr>
<tr>
<td>Allan deviation (5 MHz-100 MHz, t=1s)</td>
<td>7E-14 minimum, 5E-14 typical (5 Hz ENBW)</td>
</tr>
<tr>
<td>Allan deviation (5 MHz-100 MHz, t=1000s)</td>
<td>5E-16 minimum, 2E-16 typical</td>
</tr>
<tr>
<td>Phase stability (5 MHz)</td>
<td>Less than 10 ps/hour after 2 hour warmup</td>
</tr>
<tr>
<td></td>
<td>Typically below 2 ps/hour</td>
</tr>
<tr>
<td>Residual phase noise floor (5 MHz, 1 Hz)</td>
<td>-135 dBC/Hz minimum, &lt; -142 dBC/Hz typical</td>
</tr>
<tr>
<td>Residual phase noise floor (100 MHz, 1 Hz)</td>
<td>-120 dBC/Hz minimum, &lt; -122 dBC/Hz typical</td>
</tr>
<tr>
<td>Residual phase noise floor (5 MHz, 10 kHz)</td>
<td>-170 dBC/Hz minimum, &lt; -175 dBC/Hz typical</td>
</tr>
<tr>
<td>Residual phase noise floor (100 MHz, 10 kHz)</td>
<td>-170 dBC/Hz minimum, &lt; -172 dBC/Hz typical</td>
</tr>
<tr>
<td>Residual AM noise floor (5 MHz, 10 kHz)</td>
<td>-160 dBC/Hz minimum, &lt; -165 dBC/Hz typical</td>
</tr>
<tr>
<td>Spurious responses (5 MHz-100 MHz)</td>
<td>Less than -100 dBC (phase noise) or -90 dBC (AM noise) Typically below -120 dBC</td>
</tr>
<tr>
<td>Physical dimensions</td>
<td>380 mm x 230 mm x 100 mm, 3.2 kg</td>
</tr>
<tr>
<td></td>
<td>15” x 9” x 4”, 7 pounds</td>
</tr>
<tr>
<td>Power requirements</td>
<td>90-264 VAC, 47-63 Hz, &lt; 40W</td>
</tr>
<tr>
<td></td>
<td>3-pole AC inlet IEC320-C14</td>
</tr>
<tr>
<td>Ambient temperature</td>
<td>15C to 35C operating, -20C to +50C storage</td>
</tr>
<tr>
<td></td>
<td>60F to 95F operating, 0F to 125F storage</td>
</tr>
</tbody>
</table>

Note: Due to the use of cross correlation to cancel instrument noise, the phase noise and AM noise floors depend strongly on the measurement time and available signal levels. Residual specifications assume that measurements are made after a two-hour warmup period in a temperature-stable environment with +15 dBm at both INPUT and REF IN jacks and Trace Smooth noise traces enabled. Under these conditions, 5-10 MHz signals are typically measurable to better than -175 dBC/Hz at offsets > 10 kHz after less than 5 minutes when overlapped acquisition is enabled. Lower-amplitude signals, signals near the frequency-coverage limits, and measurements of very low close-in noise may require more time to converge.
Getting Started

What’s in the box?

Please check the contents of your package carefully upon arrival. Each PhaseStation 53100A unit should be accompanied by the following items:

- (1) USB 2.0 cable, A Male / B Male
- (1) Power supply
- (2) N-M / BNC-F coax adapters
- (5) 1” (25.4 mm) SMA-M / SMA-M coax jumpers (preinstalled)

Additionally, each 53100A delivered to North American customers includes a standard IEC320 / NEMA 5-15P power cord for 120V service. For operation in other countries, the 53100A’s power supply accepts 50/60 Hz AC power at all standard line voltages from 100V to 240V, and is compatible with IEC320-C14 power cords available locally.

USB driver and software installation

The current TimeLab release may be downloaded from http://www.miles.io/timelab/readme.htm. Please install the most recent version of TimeLab before using your new 53100A!

The PhaseStation 53100A user manual also serves as the primary software documentation for TimeLab. The latest version of the 53100A user manual is available at http://www.miles.io/PhaseStation_53100A_user_manual.pdf.

Support

For prompt assistance with software issues, contact Miles Design LLC at john@miles.io.

For hardware and warranty-support issues, contact Jackson Labs Technologies, Inc. at http://www.jackson-labs.com/index.php/support.
Installing TimeLab™

TimeLab is a compact Windows application designed for general-purpose phase/frequency stability and noise measurement. It runs on Intel® or AMD® x86-based PCs equipped with Microsoft Windows® 7 SP1 or later versions. TimeLab supports a wide variety of time and frequency measurement instrumentation in addition to the PhaseStation 53100A, including the TimePod 5330A cross-spectrum analyzer and the 5115A/5120A/5125A phase noise test sets from Microsemi.

Minimum system requirements are 100 MB of disk space, 1 GB RAM and a CPU with SSE2 support. For use with the PhaseStation 53100A, a processor with four or more physical cores is recommended.

By default, TimeLab will automatically check the Miles Design web site on a weekly basis and inform you if a newer version is available for download. Updates are always free of charge. To configure or disable automatic update notifications, select Help→Check for updates.

For best results, TimeLab should be installed prior to connecting the 53100A to your PC's USB port for the first time. Before exiting from the install program, make sure that the box labeled Install PhaseStation 53100A USB Driver is checked. This will help Windows locate the USB driver without further intervention when the 53100A is connected. After the driver has been successfully installed on your system, a confirmation message will appear.
Performance notes

Measurements made with the 53100A rely on multithreaded signal processing operations that can place significant performance demands on the host PC. Referring to the benchmarks at http://www.cpubenchmark.net/common_cpus.html, the minimum PassMark score for reliable acquisition falls in the 1,600 to 2,000 range. In practice, this means that a 2.0 GHz Intel Core 2 Duo or faster processor is required. Additional CPU cores are often more helpful than higher clock speeds.

Use of a system with inadequate CPU performance may result in acquisition errors, often accompanied by a flashing red fault indication on the 53100A’s status LED. It may be necessary to disable one or more measurement types to achieve reliable operation in such cases. For example, if you are interested only in phase/frequency stability measurement, uncheck the Measure phase noise and Measure AM noise boxes in the acquisition dialog, as shown at right. By default, the 53100A will measure phase noise, AM noise, and phase/frequency stability simultaneously.

When noise measurements on slower PCs are required, another strategy to improve reliability is to uncheck the Overlapped acquisition box in the Additional options page of the acquisition dialog. Doing so will increase the averaging time required to achieve extremely low noise floors, but will have little effect on most measurements. Note that overlapped acquisition is turned off by default.

For improved performance, a 64-bit version of TimeLab will automatically be installed on x64-based systems. If you need to record long phase records with the 53100A (or any other equipment supported by TimeLab), an x64 system with several GB of RAM is recommended.
Front panel features

The 53100A’s front panel includes the following features, located as shown in the color-keyed image above:

- Two AC-coupled N-F input jacks that correspond to the primary REFERENCE and DUT signal inputs. Measurements of RF signals from a single DUT and a single reference source will normally use these two jacks as inputs.

- Each of the N-F input jacks is connected to an internal power splitter with two output ports, which in turn are routed to a pair of SMA-F output jacks below.

It’s important to note that the jacks associated with the power splitters are unconnected to anything else internally. They are provided for operational convenience. Each splitter presents a nominal 50-ohm load at its input port¹, where the signal is fed to two independent, identical amplifiers whose outputs are also source-terminated at 50 ohms. Net gain from each N input jack to its corresponding SMA output jacks is 0 dB nominal. These active splitters offer advantages over traditional resistive or Wilkinson implementations in cross-correlated noise measurement applications, including high isolation and well-defined port impedances with minimal differential-mode noise.

- Four AC- or DC-coupled SMA-F input jacks that drive the individual ADC channels.

¹ Specifically, both the DUT and REFERENCE ‘N’ jacks are coupled to their respective input splitters via ‘L’ networks consisting of 6.8 nF 100V capacitors and 22 µH inductors. The four SMA input jacks are capacitively coupled as well when the instrument is configured for RF carrier measurement. At power-up time, the 53100A will momentarily switch the SMA inputs to the alternate signal path for DC-10 MHz baseband analysis, which presents a resistive load of approximately 10K ohms. Both the RF and DC paths can tolerate DC voltages up to +/- 24V.
By default, each of these input jacks is strapped to the **output jack** directly beneath it. This effectively divides the four-input 53100A into two independent two-channel “instruments” for cross-correlated phase noise and AM noise measurements. By sending identical copies of the reference signal to channels 1 and 2 and the DUT signal to channels 3 and 4, uncorrelated noise in all four channels will average out over time. In principle, only the noise at the splitter input terminations is common to the two “instruments,” corresponding to -177 dBc/Hz with a 0-dBm input.

Note that the above describes only one of several possible measurement configurations. A number of other measurement roles, including multichannel stability measurements, are also possible. These are discussed in the *PhaseStation 53100A Measurement Roles* section on page 125.

- Units equipped with the dual internal reference option are provided with two **SMA-F output jacks** for these 100 MHz sinewave reference signals. Typical output level is +12 dBm.

- The **STATUS** indicator is a high-brightness RGB LED that reveals the instrument status at a glance:
  
  **Blue**  
  Present for the first few minutes while the 53100A’s internal clock oscillator warms up.

  **White**  
  The 53100A is ready to acquire data. Stability measurements at 50 Hz and higher bandwidths may be performed as soon as the LED turns from blue to white, although a 30-minute warmup period is recommended. Input/reference drift warnings may occur with shorter warmup periods.

  **Green**  
  A measurement is either pending or in progress. No fatal errors have occurred.

  **Flashing purple**  
  Excessive power is present at either the **REFERENCE** or **DUT** inputs or at one or more of the channel input jacks, causing signal clipping in one or more ADC channels. An unexpected increase in signal level after measurement has begun can cause this indication. The acquired data is questionable.

  While the inputs are protected against DC potentials up to 24 volts, the maximum recommended RF power at any front-panel input jack is +15 dBm. Damage may occur at RF input levels greater than +20 dBm.

  **Flashing red**  
  A USB data overrun has occurred. This is a fatal error. Insufficient CPU power (or disconnection of the USB cable during a measurement) is typically responsible. You may be able to run the measurement successfully if you uncheck one or more of the noise or stability measurement options in the acquisition dialog.
USB 2.0 High Speed support is required for all 53100A acquisitions. In most cases the use of passive or active USB hubs with the 53100A is acceptable, but if connection problems occur, you may find it helpful to connect the supplied USB cable directly to the host PC, or try a different USB port.

In general, measurement errors are much more likely to be caused by insufficient CPU resources than by USB connectivity problems.
Guidelines for input signal connections

Although the N-F and SMA-F input jacks offer superior mechanical stability, BNC-N coax adapters are also supplied with the PhaseStation for operator convenience. Regardless of your choice of coax fittings, double-shielded cables such as RG223 or RG400 are recommended for low-level measurements that may be affected by crosstalk and environmental interference. Use of RG58, RG174 and other common single-shielded cables can cause artifacts in stability and noise plots, particularly with longer cables.

Input signals should be greater than 0 dBm for best performance -- +5 to +15 dBm is recommended. While the PhaseStation is intended for use with sinewave oscillators, it’s possible to measure logic-level clocks as well if you equip them with suitable matching networks. It’s a good practice to measure the oscillator with a load that’s similar to what it will encounter in its ultimate application, keeping in mind that most logic-level sources are not specified to drive 50-ohm loads at all. Overloading of the source, the PhaseStation, or both can occur if these devices are connected directly to the instrument’s input jacks. Consult the manufacturer’s data for the source in question to determine its output impedance and/or current drive capability.

The required matching network can be as simple as a resistive series termination or voltage divider, but the PhaseStation’s own spur performance and broadband noise floor will likely be degraded when measuring non-sinusoidal sources unless you provide additional bandpass filtering. Careful shielding of matching networks, buffers, and other interfacing elements is also necessary, since isolation of DUT and reference signals from stray RF signals (and from each other) is a prerequisite for clean measurements. Experimentation will likely be required to achieve the desired results with non-sinusoidal signals.

Choosing reference sources

In addition to the host PC and an appropriate power source, measurements made with the 53100A require either one reference signal to be supplied at the REFERENCE jack or two reference signals supplied at the CH 1 IN and CH 2 IN jacks. Virtually all aspects of measurement performance – accuracy, repeatability, noise floor, spurious responses – depend on your ability to provide the best reference signal(s) possible.

But what does the “best reference possible” mean? It depends on the goals of your measurement. Very few reference sources are ideal for both short- and long-term measurements. Typical “house clocks” that distribute 5 or 10 MHz signals at levels between +5 and +15 dBm often work well for ADEV and other time/frequency measurements, but atomic and GPS standards that are often used as sources for centralized clock distribution may exhibit more short-term phase noise than an undisciplined crystal oscillator. Distribution amplifiers can also add substantial noise of their own, as well as phase drift at longer timescales due to temperature sensitivity.

Furthermore, even when using the best standards, distribution amps and double-shielded cables, it’s almost impossible to build a large clock distribution network that’s free of environmental spurs. As a
result, you should consider using a standalone low-noise OCXO – or even better, two of them -- for phase noise and AM noise measurements.

Unlike most other stability and noise analyzers, the 53100A can work with any reference whose frequency lies within its specified RF carrier range (1-200 MHz), regardless of the input frequency from the device under test (DUT). Frequency readings and phase noise levels are always referred to the frequency at the INPUT jack.

For example, if your 10 MHz DUT’s phase noise when measured with a 5 MHz reference is -160 dBc/Hz at 10 kHz and its Allan deviation is 3E-12 at t=10s, you will still measure -160 dBc/Hz and ADEV=3E-12 if you switch to a 10 MHz reference, or one at any other frequency.

One complication, however, is the need to handicap the reference’s phase noise and FM/PM spur amplitudes by 20*log10(FDUT/FREF) dB when the DUT and reference frequencies differ. This is the same effect that classically applies when a signal undergoes frequency multiplication or division. The effective phase noise and spur performance of the reference source would be 6 dB worse in the example above where a 5 MHz reference is used to characterize a 10 MHz device. Likewise, the reference’s long-term stability characteristics (e.g., Allan deviation) would be degraded by a factor of 2. Ideally, the phase noise of your reference after any applicable 20*log10(FDUT/FREF) correction should be at least 8-10 dB lower than the expected performance of the DUT at the offsets of interest. The reference’s phase noise will not affect the measurement to any great extent as long as this margin is maintained.

Bear in mind that lower-frequency crystal oscillators will usually exhibit better close-in noise than those at higher frequencies, even when the 20*log(N) rule is taken into consideration. This is a consequence of the physical properties of the crystals themselves. For example, the highest-quality 5 and 10 MHz OCXOs on the market can perform at levels below -130 dBc/Hz at 1 Hz from the carrier. These oscillators make superior references for HF frequency stability and close-in noise measurement, easily outperforming the best VHF oscillators. But at the same time, they will be less effective than low-noise VHF oscillators as references for broadband noise measurement of VHF sources. Low-frequency reference oscillators have no inherent advantages at offsets beyond a few kHz where crystal Q no longer dominates, and the 20*log(N) principle will work against them when measuring higher-frequency DUTs.

An additional consideration when specifying reference oscillators is that industry-standard frequencies such as 5, 10, and 100 MHz benefit from a larger selection of crystals at the factory. Within a given product line, oscillators at unusual frequencies will rarely outperform units manufactured at standard frequencies.

---

2 This being said, it’s sometimes useful to measure the phase noise or stability of a DUT by using an identical device as the reference. In such a case, where the phase noise of the reference and DUT is presumed to be identical but uncorrelated, the resulting PN graph will be 3 dB too high, while Allan deviation and related measurements will be artificially elevated by a factor of sqrt(2). You can use the Rescale Phase field in TimeLab’s Edit → Trace properties dialog to correct the ADEV of two identical devices by scaling the phase data by 0.707. Similarly, the phase noise may be corrected by entering -3 in the PN Gain field to lower the trace by 3 dB.
Working with dual reference sources

The use of dual references carries significant advantages in noise measurement due to the instrument’s use of cross spectrum averaging to remove the influence of uncorrelated reference sources over time. Multiple references can be helpful in stability measurement as well, since the PhaseStation can easily acquire the multichannel data necessary for so-called “three-cornered hat” processing.

For a detailed “case study” featuring the use of dual reference sources in both stability and noise measurement roles, please refer to Application Note 53100A-2, Dual Reference Noise and Stability Measurements with the PhaseStation™ 53100A.

The use of dual independent references relaxes some of the constraints on the stability and/or noise performance of the reference signal sources, but the advantages come with a new requirement: the references must be truly independent and uncorrelated. Otherwise, cross-correlated phase noise and AM noise measurements will not converge at the DUT’s true noise level, and three-cornered hat measurements will not benefit from the statistical independence required to separate the frequency variances at the individual channels.

Two OCXOs running from the same power supply, for instance, may not be as independent as they look. They may even injection-lock to each other through their power supply connections if decoupling isn’t adequate. When working with dual references, consider enclosing each of them in its own RF-tight box or other sealed metal container. Use high-quality DC feedthrough capacitors rather than conventional power jacks or connectors. These precautions are always a good idea, but they’re absolutely mandatory with OCXOs whose output signals are obtained from discrete pins or SMT pads rather than coaxial outputs.

PhaseStation instruments equipped with optional dual internal references are particularly easy to set up since reference channel isolation isn’t a concern. There are no inherent performance differences associated with the choice of external and internal reference, but the internal reference option offers the practical advantage of allowing the PhaseStation to measure high-performance sources with no connections other than USB, power, and the DUT itself.

Internal and external reference jack configurations are shown in the PhaseStation 53100A Measurement Roles section (page 125.) When reviewing the dual-reference measurement role descriptions, note that the REFERENCE, CH 1 OUT, and CH 2 OUT jacks remain unconnected when dual references are used, whether internal or external. As with the DUT, CH 3 OUT, and CH 4 OUT connectors on the right side of the front panel, these jacks correspond to the input and output ports of an internal RF splitter. The REFERENCE and DUT channel splitters are provided for user convenience, and have no other internal connections.

Dual-channel references used with the PhaseStation do not have to operate at the same frequency. That being said, when working with external dual-channel sources it can sometimes be helpful to either phase-lock them together with a loop bandwidth well below the narrowest noise offset of interest, or
separate them by several dozen hertz or more. If the oscillators are only a few hertz apart, it may be
difficult to spot crosstalk problems in the external RF or power connections.

Finally, note that basic frequency stability measurements on a single channel pair don’t use the second
(CH 2) reference or the second DUT input (CH 4) at all. The Ch 2 reference may be powered down or left
unconnected if noise measurements are disabled in the acquisition dialog and no DUT channels are
using Ch 2 as a stability reference.
Making your first measurements

To paraphrase Kernighan and Ritchie\(^3\), TimeLab is not a large program, and it's not well served by a large manual. Likewise, the PhaseStation hardware is easy to work with after some basic measurement concepts are understood. As an introductory exercise – or a quick operational check – you may wish to perform a measurement using the default acquisition parameters in TimeLab.

Getting started with the PhaseStation is as easy as connecting the 53100A’s USB cable to your PC and launching TimeLab. Once TimeLab is running, select the \textit{Acquire} \rightarrow \textit{Jackson Labs PhaseStation} menu option. The dialog box that pops up should contain a list of available PhaseStation device(s) in a dropdown box at upper right, just below the instrument photo.

Assuming the appropriate PhaseStation 53100A instrument is selected, the acquisition parameters are all valid, you’ve connected stable reference and DUT input sources to the 53100A, and you’ve allowed at least a few minutes’ warmup time, all you need to do is press the \textit{Start measurement} button. The acquisition dialog will disappear and the \textbf{STATUS} indicator on the 53100A should change from white to green. Over the next ten seconds or so, various informational messages will appear in the TimeLab status bar at the bottom of the program’s main window as the software characterizes the applied DUT and reference input signals.

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{figure4.png}
\caption{The PhaseStation acquisition dialog}
\end{figure}

\textsuperscript{3} The \textit{C Programming Language}, Second Edition (1988), Bell Telephone Laboratories
If all is well, the status bar message should soon change to “Acquisition in progress.” Measurement data will now begin to appear in graphical form. Unless you’ve selected a different view from the Measurement menu, you will see an Allan deviation (ADEV) plot for your DUT, rendered in real time at 100 points per second.

Unless you changed the Duration value, the measurement will run for three minutes. This will be long enough to allow the ADEV trace to reach $\tau$ one minute, and for the phase noise trace to reach 1 Hz. You can try any of these suggested actions at any time, either during the measurement or after it finishes:

- Left-click on the ADEV graph or any other log-log plot. Observe that the red spot cursor can be placed at any vertical column. The graph’s Y value at the spot cursor will be displayed in the legend table beneath the graph area, updated in real time to reflect the latest reading. At the same time, ADEV values at assorted tau periods should be displayed in a chart on the right side of the graph.

- Left-click and drag a box anywhere on the plot. When you release the left mouse button, the view should zoom in to magnify the specified area. You can drag an edge (or a corner) of the box slightly outside of the graph area to expand the plot in that direction. Right-click to return to the unzoomed view.

- Try selecting a few of the different graph types in the Measurement menu. Assuming you didn’t uncheck any of the measurement options in the acquisition dialog, all of the different graph types should be accessible, updating continuously in a “live” fashion as long as the measurement is still in progress.

- Now is a good time to start picking up the keyboard shortcuts. Instead of selecting Measurement→Frequency difference, try the f key. To return to the Allan deviation plot, use a. Uppercase A selects AM noise, while uppercase P selects phase noise. (In some cases, the TimeLab features and commands described in this manual will be referenced by their hotkeys rather than their menu entry names, after the menu entries have been introduced.)

- Save the measurement data to a .TIM file with File→Save image or .TIM file (s). A .TIM file is an ASCII text file that contains the data needed to recreate all of the available graphs associated with a given measurement. This data includes the entire phase record, as well as the FFT bins from the phase noise and AM noise plots. You don’t have to wait for the measurement to end; at any time during a measurement, you can save the available data to a .TIM file or load another .TIM file for display alongside the existing plot(s) that have been loaded or acquired.

- Use File→Load .TIM file to read the .TIM file you just saved. Now you should have two copies of the same plot in memory. At the left edge of the legend table entry for the most
recently-initiated or loaded plot, you’ll see a black triangular cursor, indicating the plot that’s currently selected for editing, browsing, or other forms of control interaction in TimeLab. In the table below, the most-recently loaded plot has been automatically selected:

<table>
<thead>
<tr>
<th>Trace</th>
<th>Nota</th>
<th>Input Freq</th>
<th>ADEV at 1s</th>
<th>Duration</th>
<th>Elapsed</th>
<th>Acquired</th>
<th>Instrument</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example (Unsaved)</td>
<td>5.9 MHz</td>
<td>7.12E-14</td>
<td>3 m</td>
<td>20 s</td>
<td>1913 pm</td>
<td>534 pts</td>
<td>PhaseStation 53100A</td>
</tr>
<tr>
<td>Example</td>
<td>5.9 MHz</td>
<td>6.61E-14</td>
<td>3 m</td>
<td>5 s</td>
<td>0 pts</td>
<td>0 pts</td>
<td>PhaseStation 53100A</td>
</tr>
</tbody>
</table>

**Figure 5: Selection cursor**

If the measurement is still in progress, you can press the **Up arrow** key to re-select the original plot, then switch to the **p)hase or f)requency difference** views to watch its phase record continue to grow while the saved copy remains unaffected.

For “power users,” three of the most common commands in TimeLab are **Display→Browse plots one at a time (b)**, **Display→Overlay all loaded plots (o)**, and **Display→Toggle visibility of selected plot (v)**. Like many other commands, the **b**, **o**, and **v** commands operate on the so-called “selected” plot as described above. If you’ve followed along with the suggested command demonstrations above, then you should have two (or more) plots loaded, and you can experiment with these concepts.

- First, select any desired **Measurement** view and press the **b** key to enter Browse mode. Observe that only one of your plots is now visible.

- Furthermore, notice that two things happen when you press the **Up- or Down-arrow keys** (**Display→Select next plot in chart / Display→Select previous plot in chart**). The small black triangular cursor at the leftmost edge of the legend table moves up and down... and the plot that it points to is also the one that becomes visible. In **Display→Browse** mode, entries in the legend table corresponding to all of the unselected plot(s) are grayed out, and those plots aren’t shown in the graph.

- You can put things back to normal by pressing **o** to return to **Display→Overlay** mode. The idea of a “selected” plot still exists in **Display→Overlay** mode, but it no longer determines which plots are visible in the legend table and graph areas. In **Display→Overlay** mode, all of the loaded plots are visible, all of the time, unless individually hidden with the **Display→Toggle visibility of selected plot (v)** function.

- To avoid confusion the **Display→Toggle visibility of selected plot (v)** function doesn’t do anything in **Display→Browse** mode. But in **Display→Overlay** mode it does just what it sounds like – it toggles the visibility of the selected plot in both the graph area and the legend table. This panoply of options may seem confusing at first, but it’s nothing compared to the jumble of line segments and shaded areas that can appear on the graph when all nine available slots in the legend table are populated with visible plots!
Regardless of the choice of Display→Browse or Display→Overlay mode or the visibility status of any given plot, the “selected plot” concept is still useful for indicating which plot should contribute to the frequency-count chart in the Measurement→Frequency Difference (f) view, the sigma-tau charts in the various xDEV measurement views, and the noise marker and spur tables in the noise measurement views. The selected plot is also the only one that’s saved, exported, modified, edited, or moved up and down in the legend table when the corresponding commands are issued.

The last point above is an important one – many users new to TimeLab are surprised to discover that a single .TIM file doesn’t represent an entire screen full of plots. Each plot must be saved, loaded, and otherwise processed individually. None of the commands on the File or Edit menus in TimeLab operate on more than one plot at a time, except for File→Close all plots (Home) and the various image-based operations like File→Print image (Ctrl-p), File→Copy image to clipboard (Ctrl-c), and File→Save image or .TIM file (s) when the latter command is used to save a .png, .bmp, .tga, .gif, or .pcx image of the entire screen.

**Tips for new users**

- In TimeLab, almost everything you can do from the menus has a keyboard equivalent, in many cases a single key. **Time spent becoming familiar with the keyboard shortcuts will be rewarded!**

- Use the 53100A in an environment with good ambient temperature control for best results. Avoid placing the hardware near HVAC vents or other sources of drafts when making sensitive measurements.

- Also for best results, avoid placing the 53100A immediately next to equipment that may operate at high temperatures, as well as equipment that should not be exposed to heat. Normal case temperatures may reach 35°C to 40°C after several hours’ operation.

- **Do not disturb the measurement setup mechanically, move cables around, or otherwise interact with the environment unnecessarily during acquisition.** After the measurement ends, you can use TimeLab’s phase-record editing features to get rid of known glitches, but nothing can be done to restore a corrupted noise plot. Any glitches that affect the phase noise or AM noise plots will require a retake.

- At startup time, TimeLab will open any .TIM file(s) specified on the timelab[64].exe command line. Alternatively, a JavaScript program filename ending in .JS may be specified for execution.

- **Every measurement in TimeLab runs in its own background thread, so you can load, save, and manipulate plots or even launch additional acquisitions with other**
instruments while an acquisition is running. This is subject to available memory and CPU resources, of course. A typical PhaseStation 53100A acquisition takes about 16 MB/sec of USB bandwidth and two cores’ worth of CPU horsepower.

- When equipped with multiple USB host controllers, the fastest available PCs can acquire data from up to four PhaseStation devices concurrently. Most PCs will be limited to two concurrent acquisitions at most.

- The acquisition dialogs in TimeLab all have large “mouseover” help windows. The mouseover help text serves as the primary hardware-specific documentation for the various analyzers and counters supported by TimeLab. Read it carefully before changing any fields from their default values.

- Attempting to run stability measurements with large phase records and high data rates may result in “Couldn’t allocate phase record” or similar messages indicating a lack of available RAM. Running on an x64 system can help avoid memory problems, as they can access much more RAM than legacy 32-bit Windows systems.

- When contacting Miles Design for technical support, it’s a good idea to attach .TIM file(s) associated with the issue, rather than image files. .TIM files greater than 3 MB in size should be zipped or otherwise compressed. If you don’t receive a reply within 48 hours, please email again (without the attachment) to confirm delivery.

Next steps

Two application notes are provided to illustrate specific measurement techniques and applications that almost all PhaseStation users will find helpful. These are AN 53100A-1 (Oscillator Measurement and Calibration with the PhaseStation 53100A) and AN 53100A-2 (Dual Reference Noise and Stability Measurements with the PhaseStation 53100A).

The latest editions of these application notes can be downloaded from the Jackson Labs Technologies, Inc. web site at the following URLs:


http://www.jackson-labs.com/assets/uploads/main/PhaseStation_53100A_AN_53100A_2.pdf
The diagram above provides an overview of the signal and data pathways that lie between the DUT and reference signals supplied to the PhaseStation and the results that ultimately appear on the screen. Although the block diagram may appear complex at first, the features most likely to be of interest are the signal connections available to the user, all of which are shown at left. Front-panel jacks typically connected to the device(s) under test are highlighted in blue, while those associated with internal or external reference signals are shown in red.
Other notable aspects of the block diagram include the following points.

- The four SMA M-M jumpers shown in the DUT and reference input areas are depicted in their factory-default configuration. With these connections, signals applied to the two N-female connectors on the front panel are split into two identical paths in the classical topology for cross-correlated noise measurements. Many other connection possibilities are available, however, since all four ADC channel inputs are accessible to the user. These will be discussed later.

- Active splitters are used at the two N-F input jacks rather than typical resistive or Wilkinson types. The active splitters present a well-defined load to the input signals as well as a consistent source impedance to filters and other components in the analog front end. Reverse isolation is approximately 70 dB at 100 MHz, which helps to minimize load-impedance fluctuations caused by attenuator and filter selection when a measurement begins. These load variations can affect the stability of devices being measured, and they can also interfere with other equipment connected to the DUT or reference sources.

  Additionally, the active splitters do not present a differential-mode source of Johnson noise at their outputs, which may help prevent certain artifacts in measurements at extremely low noise levels near the thermal floor of -177 dBm/Hz. The shared load resistors do act as a common-mode noise source at the thermal floor, however. It’s uncommon for real-world measurements with the 53100A to reach this limit, but the SMA jumpers may be used to connect other types of splitters supplied by the user if required. The use of the internal splitters is always optional.

- On instruments equipped with the dual independent internal reference option, the reference channel jumpers may be moved to connect the two internal 100 MHz OCXOs directly to the input jacks. In this configuration the reference-channel splitter is unused, and no connections are made to the CH 1 OUT, CH 2 OUT, and REFERENCE input jacks.

- The CLK IN and CLK OUT jacks on the rear panel are also depicted on the left side of the block diagram. These jacks are intended to provide access to the internal ADC clock signal path for future applications.

- The SMA-F jacks labeled CH 1 IN, CH 2 IN, CH 3 IN, and CH 4 IN are connected to identical banks of switched filters and attenuators that condition the input signals and pass them to the individual ADCs. While the active splitter inputs at the N-F jacks are AC-coupled, the filter banks associated with the four SMA-F input jacks include lowpass elements that permit coverage down to DC. These DC paths are intended to support baseband analysis applications currently under development.
A brief architectural note

It can be helpful to understand some basic details about the PhaseStation’s DSP topology, especially when measurements may be constrained by available memory and CPU resources. A key observation is that the two basic measurement categories corresponding to the Measure stability and Measure phase noise / Measure AM noise options in the TimeLab acquisition dialog use completely separate data records and internal processing pipelines.

The “phase record” mentioned in the documentation and help text has nothing to do with Phase noise measurements, for example. Instead, the phase record is a block of low-bandwidth phase difference samples from a single DUT/reference channel pair. It is used only for Stability measurements, which include ADEV, MDEV, TDEV, and HDEV as well as the frequency- and phase-difference plots.

The diagram above represents a more detailed view of the right half of the block diagram from the preceding section. While TimeLab allows phase records from multiple channel pairs to be recorded during a single measurement, the most common measurements yield a single phase record created from two parallel streams of complex data samples arriving from one DUT input channel (Q3,I3) and one reference input channel (Q1,I1). Channels 2 and 4 do not participate in stability measurements in these cases. The two streams from channels 1 and 3 are decimated to accommodate the requested measurement bandwidth (ENBW) – typically 5 Hz to 500 Hz, with rates up to 50 kHz supported through the use of additional decimation. The phase differences between corresponding samples in the two
decimated streams are then calculated and used to construct the various xDEV plots as well as the phase- and frequency-difference plots.

So, when you save a measurement to a .TIM file that was made with the Measure stability option checked, you’re actually saving these low-bandwidth phase differences. If you use Edit→Remove selected or zoomed phase data (F4) or the various flattening or trend-removal functions to edit parts of the phase record after acquisition, the xDEV and frequency/phase-difference plots will be recalculated, but nothing will happen to the phase noise or AM noise plots. The noise traces are normally based on the phase and/or amplitude differences for all four baseband streams – Q1,I1, Q2,I2, Q3,I3, and Q4,I4 – which are processed at the full baseband data rate exceeding 200 kS/s. The resulting data is then passed to the FFT and cross-spectrum averaging routines.

Because it would be impractical to retain the original high-bandwidth complex baseband data or any phase or amplitude information derived from it, only the averaged FFT output bins are written to the .TIM file when saving the phase noise or AM noise portion of a measurement.
Making Measurements

Three views of the same PhaseStation 53100A measurement appear at left, revealing the performance secrets of some of the industry's highest-quality crystal oscillators.

The Allan Deviation plot displays frequency stability at intervals from milliseconds to days, while the Phase Noise plot renders the signal’s spectral signature at offsets ranging from 0.001 Hz to 1 MHz. In this example, dual references help the PhaseStation’s noise measurement floor approach -150 dBc/Hz at 1 Hz from the carrier.

Meanwhile, a mixture of short-term and long-term stability trends can be examined in the Frequency Difference display. The 53100A’s frequency-count chart offers over 13 digits per second of usable precision at “gate times” from 0.1 second to 3000 seconds.
“What’s all this ADEV stuff, anyhow?”

With apologies to the late Bob Pease and his editors at *Electronic Design*, here are a few tips to help you understand what Allan deviation (ADEV) graphs really tell you, and how to get the most out of the statistical deviation measurements made by TimeLab.

Allan deviation is defined as the *two-sample deviation of fractional frequency differences at a given time interval*. While technically correct, such definitions may be unenlightening to new users. Often, the first question asked is something like, “Why did my plot stop at 1000 seconds? It took an hour to run!”

![Allan Deviation Graph](image)

**Figure 8: Examples of ADEV measurements**

The answer is that these plots are not simply linear depictions of frequency drift over time. (In TimeLab, that’s the purpose of the Measurement→Frequency Difference (f) view.) Nor are they depictions of a single Allan deviation measurement that describes the clock’s stability from one interval of a given duration to the next. Instead, ADEV and similar statistical graphs usually portray an entire collection of deviation measurements, each based on a list of phase or frequency data points spaced at an interval unique to that measurement.

Imagine that you own a watch that exhibits a certain accuracy in parts per million from one minute to the next. To arrive at this figure, you’ve checked your watch against a better clock several times, waiting one minute between each trial, and then calculated the Allan deviation of the resulting list of phase errors. (You might have used conventional standard deviation, but in this case you’ve heard, correctly, that STDEV has major drawbacks for timekeeping work.)
You’re fairly certain you’ll get a different result if you calculate the Allan deviation for a set of readings taken one week apart, and still another result for a series of readings taken annually. So you record at least a few data points at these intervals as well.

Now you’d like to draw a graph that shows off your watch’s performance, perhaps for bragging rights at the neighborhood pub. What sort of plot would be needed to portray everything you’ve learned about the watch? The X axis obviously needs to be logarithmic, given that your timescales of interest range from minutes to years. The deviation figures will need to be plotted on a log axis as well, because they might be thousands of times worse at one-year intervals than they are at one-minute intervals. Finally, even though you recorded several years’ worth of annual readings, your graph will need to end at the one-year point. There’s simply not enough data to describe the watch’s behavior at longer timescales.

If you keep these guidelines in mind as you graph your data, you’ll end up with a legitimate ADEV plot. It will have three data points, each containing the result (sigma) of an independent calculation based on at least a few samples of the clock’s frequency that were taken at a specific interval (tau). Lines or curves can be fitted to this collection of discrete points, and the result will be a plot like those drawn by TimeLab and other ADEV applications.

TimeLab’s statistical capabilities aren’t limited to Allan deviation -- the Measurement menu allows you to view any of four types of deviation plots, during or after acquisition. Formulas exist4 to calculate Allan deviation and other statistics on the basis of both phase and frequency samples. TimeLab always works with phase data internally, using incremental calculations for fast processing and overlapped algorithms for high statistical quality. As with other measurements made by TimeLab, the statistical plots are updated simultaneously in real time.

**Allan Deviation (a)**

Allan deviation, or ADEV, is the square root of the Allan variance, \( \sigma^2(\tau) \). Like its related statistics MDEV and HDEV, ADEV describes the fractional frequency deviation (sigma, or sigma) of a set of samples taken at an interval \( \tau \) (tau).

ADEV has a few disadvantages that are addressed by other deviation types, such as inability to distinguish white PM and flicker PM noise. It also exhibits relatively low confidence in the presence of smaller sample sizes, compared to some newer statistics. Still, ADEV is among the most commonly-used performance metrics for high-performance clocks and frequency standards.

Modified Allan Deviation (m)

MDEV, or Mod $\sigma_y(\tau)$, is a slight variation on ADEV that can discriminate between white PM and flicker PM noise. Both ADEV and MDEV render flicker PM noise at a slope of $\tau^{-1}$. White PM noise is also rendered by ADEV at $\tau^{-1}$, but it appears as a steeper downward slope of $\tau^{-3/2}$ in MDEV. Consequently an ADEV plot may appear artificially elevated when either of these two noise types is present. Switching to Measurement→Modified Allan Deviation (m) will render the two noise types separately at the intervals where they belong.

As an example, here are ADEV and MDEV plots showing the residual noise of an HP 5370B time interval counter. For this test, the counter’s START input was fed with a 1-pps divider, which was driven by a 10 MHz clock that was also connected to the STOP input using an RF splitter. The counter’s noise floor consists almost entirely of white PM and flicker PM noise.

![Figure 9: Contrasting the HP 5370B’s ADEV and MDEV floors](image)

The ADEV plot shows a consistent $\tau^{-1}$ slope to 10000 seconds, which could be indicative of either white PM or flicker PM noise. The MDEV plot renders the white PM noise at a slope of $\tau^{-3/2}$, transitioning to flicker PM near $\tau=400s$ or so. Limited sample availability beyond $\tau=2000s$ makes it difficult to draw further conclusions, but it’s clear that MDEV reveals more about the counter’s noise characteristics than ADEV.

Hadamard Deviation (h)

HDEV, expressed as $H\sigma_y(\tau)$, can be thought of as a 3-sample alternative to ADEV. HDEV plots of drift-free sources will generally appear similar to ADEV, but while ADEV fails to converge in the presence of linear drift, HDEV is unaffected by it. This means that switching from ADEV to HDEV will yield results similar to viewing ADEV after an Edit→Subtract global linear frequency trend (drift line) (Ctrl-l) operation. (The results will not be identical because HDEV also responds to some high-divergence noise types.)

One interesting use for HDEV is predicting the ADEV performance of crystal oscillators that have not yet fully warmed up. Unless the oscillator is exhibiting frequency jumps or
inconsistent drift characteristics, its short-term ADEV will eventually resemble the HDEV performance that was observed only a few minutes after power-up.

**Time Deviation (t)**

TDEV, or $\sigma_x(\tau)$, expresses the time stability of phase at the specified tau, in units of seconds. Numerically, TDEV is equal to $(\text{MDEV} \times \tau) / \sqrt{3}$. It’s similar to the TIE (Time Interval Error) statistic used by the telecommunications sector.
Examing changes in stability over time

To make basic “dynamic ADEV” measurements\(^5\), refer to the help text for the **Duration** and **Run Until** fields in the acquisition dialog, as well as the **Trace History** field shown at right.

Specifying a **Trace History** value greater than 1 causes TimeLab to divide the phase record into the given number of regions. Subsequent displays of xDEV measurements will assign each region its own trace. As the measurement runs, more recently-acquired regions towards the end of the phase record are drawn in darker colors, revealing how the stability of a given device changes over time. (If **Trace→Toggle trace thickness (T)** is enabled, only the most recent region will be displayed with a heavy trace.)

You can specify a new Trace History value at any time after acquisition in the **Edit→Trace properties (e)** dialog. In the example below, eight minutes of frequency readings were taken from an OCXO shortly after power-up, and later rendered with Trace History set to 20. Consequently, each ADEV trace represents about 24 seconds of phase data. As the oscillator warms up, the later traces exhibit better stability. Values displayed on the **\(\text{Sigma}(\text{Tau})\)** chart apply to the most recent trace.

For more advanced displays of dynamic AVAR/ADEV and related metrics as described in the literature, consider using the **File→Export phase data to Stable32 (Ctrl-x)** command described on page 76 for offline analysis.

---

Common artifacts in ADEV and related measurements

High-resolution plots captured by the PhaseStation 53100A can reveal artifacts that don’t seem to be present when the same measurement is made by other instruments. For example, spurs due to AC power coupling or ground loops, discussed below, appear very different when acquired at high sample rates and rendered with 20 or more ADEV bins per decade. Line-related spurs may not have been resolvable before, but that doesn’t mean they weren’t present!

Measurement bandwidth and $\tau_0$

One artifact that does originate in the PhaseStation driver software is shown in the plot at right. Four successive ADEV acquisitions are shown, each conducted at a different noise-equivalent measurement bandwidth (ENBW) setting. Near the beginning of each trace, some “droop” is present that doesn’t accurately reflect the behavior of the DUT.

What causes this artifact? Stein\textsuperscript{6} has shown that the optimum ENBW for a given ADEV $\tau_0$\textsuperscript{7} is simply the $1/(2 \times \tau_0)$ Hz Nyquist rate. This bandwidth is unachievable with a non-ideal antialiasing filter, so the PhaseStation driver internally acquires oversampled phase data that corresponds to an artificially short $\tau_0$ interval relative to the selected ENBW. If allowed to appear on an ADEV plot, the antialiasing filter’s response is easy to mistake for a real effect.

TimeLab supports two different ways to avoid displaying invalid data near $\tau_0$. First, Trace→Clip xDEV traces by noise bandwidth (Ctrl-b) is enabled by default. (This option was turned off to demonstrate the issue above.) With noise bandwidth clipping enabled, as seen in the figure at left, TimeLab does not render any portion of an xDEV trace at taus shorter than $1/(2 \times \text{ENBW})$ seconds.

---

\textsuperscript{6} The Allan Variance – Challenges and Opportunities, Samuel R Stein, Symmetricom, Inc., Boulder, Colorado USA

\textsuperscript{7} $\tau_0$ refers to the very first tau at the left end of an xDEV trace, which typically corresponds to the period of the phase or frequency samples being analyzed.
Additionally, the PhaseStation driver can decimate the phase-difference data it acquires. Readings are collected by sampling the internal phase-difference data stream at a rate determined by the Output Decimation field in the Additional options page of the acquisition dialog. This feature is primarily for convenience. It can be used to reduce the size of phase records generated by very long acquisitions, for example, or when high data rates must be used in order to track drifting sources.

Decimation factors of 2:1 or greater also have the effect of satisfying the previous $\tau_0 \geq 1/(2 \cdot \text{ENBW})$ criterion. With the default Output Decimation value of 2:1 or any higher ratio, phase-difference data that’s affected by lowpass attenuation will be kept out of the measurement, even if Trace→Clip xDEV traces by noise bandwidth (Ctrl-b) is turned off.

Note that Trace→Clip xDEV traces by noise bandwidth (Ctrl-b) will have no effect on plots rendered with data captured from counters and other instruments that don’t report their measurement bandwidth. It should be left enabled in most cases.

![Phase Noise $\mathcal{X}(f)$ in dBC/Hz](image1)

**Figure 14:** AC line interference responsible for ripple in ADEV plots

**Line-related spurs**

The most conspicuous artifact in the ADEV plots above is the “ripple” in the blue and magenta traces. This is caused by AC line interference, primarily a single 120-Hz spur:

Note that 1/120 Hz = 0.008s, which corresponds to the first (genuine) trough in the ADEV traces above. Depending on how they’re introduced to the measurement, AC line spurs commonly appear at either the fundamental power-line frequency or its second harmonic. Users in the EU and other locales with 50 Hz power will see similar effects near $\tau=0.010$ and 0.020s. In all of these cases, the device’s “true” ADEV is close to an imaginary line drawn through all of the lowest points in the trace.

Getting rid of AC line spurs can be a challenge. Shielding at 50/60 Hz is usually impractical; if the interference is magnetically coupled into the measurement, there is probably no cure besides identifying the offending source(s) and moving sensitive equipment and cables away.
Ground loops are a more likely offender, since all ports on the 53100A have ground pins or shields that are bonded to the instrument’s metal enclosure. If you can identify the offending loop, you may be able to break its RF path with a coaxial balun\(^8\).

You can also attack the source of the loop by bonding all equipment to a common ground that’s connected to the building’s power distribution network in only one place. To do this, ensure that all devices participating in the measurement – DUT, reference, instrument, computer, and everything connected to them – are all part of the same AC circuit, preferably a power strip that allows all equipment to be plugged into a single outlet.

Using battery power can help, but batteries shouldn’t be your first resort. Less drastic solutions can usually be found that will let you use the available AC power. (Try switching to MDEV, for instance.) If you are measuring stable sources with sufficient warmup time, you can attenuate line spurs by selecting the 5 Hz Measurement BW option in the acquisition dialog. As another alternative, consider the Edit → Apply notch filter to phase data (n) command, described on page 86.

### Other environmental hazards

Above, a measurement of two 10 MHz sources was interrupted by bursts of apparently-random noise at roughly 50-second intervals. The culprit turned out to be a cellular phone sitting on a nearby bench. In another instance, a breadboarded RF amplifier

---

undergoing residual noise testing was affected by a WiFi access point, with interference appearing as an intermittent train of low-level impulses near 10 Hz. Try to keep all RF radiation sources – intentional and otherwise! – well away from your testing area.

Crosstalk

Finally, don’t confuse power-line spurs or other sources of low-frequency interference with *crosstalk*. This is an insidious artifact that may be observed in high-performance measurements – or worse, may go unnoticed.

When working with direct-digital analyzers such as the PhaseStation and TimePod, crosstalk tends to appear when the signal frequencies at the input ports are nearly the same, but not precisely. As the two signals’ phases slowly approach, coincide, and separate, any coupling between them creates a spurious response at the difference frequency. Appearing at a similar magnitude in both AM and phase noise plots, these spurs also cause peaks and nulls in ADEV and related measurements.

![Figure 16: Interference from external 10 MHz source](image)

<table>
<thead>
<tr>
<th>Trace</th>
<th>Input Freq</th>
<th>Ref Freq</th>
<th>Sample Interval</th>
<th>ENBW</th>
<th>Instrument</th>
</tr>
</thead>
<tbody>
<tr>
<td>Marion MVR9A, Tm RG58, house clock on</td>
<td>10.000003 MHz</td>
<td>10 MHz</td>
<td>0.004 s</td>
<td>52.7 Hz</td>
<td>TimePod 5330A</td>
</tr>
<tr>
<td>Marion MVR9A, Tm RG58, house clock off</td>
<td>10.000003 MHz</td>
<td>10 MHz</td>
<td>0.004 s</td>
<td>52.7 Hz</td>
<td>TimePod 5330A</td>
</tr>
<tr>
<td>Marion MVR9A, Tm RG400, house clock on</td>
<td>10.000003 MHz</td>
<td>10 MHz</td>
<td>0.004 s</td>
<td>52.7 Hz</td>
<td>TimePod 5330A</td>
</tr>
</tbody>
</table>

Crosstalk can also occur when a *third* signal, incidental to the measurement environment, causes beatnote effects that are asynchronous to both test inputs. This case is illustrated in the plot above, where a TimePod 5330A was used to measure a high-stability OCXO against another one of similar quality.

In this case, while the OCXO driving *REF IN* was very close to 10 MHz, the OCXO driving the TimePod’s *INPUT* port was set approximately 3 Hz higher for demonstration purposes. Also present in the room (but not participating in the measurement) was a...
GPS-disciplined frequency standard and distribution amplifier supplying 10 MHz to various instruments through long cables.

The 5330A’s reference source was connected with a double-shielded RG400 cable in all three trials. The blue trace and magenta traces were taken with the input source connected with a 3m length of RG58. A significant MDEV peak was visible in the blue trace… but when the GPSDO was powered down for the magenta trace, the spurious response vanished.

Likewise, as the green trace shows, replacing the RG58 input cable with an equal length of RG400 also eliminated the interference from the house standard.

As can be seen, the recommendation to use double-shielded cables with these instruments is not born of excessive caution. Even plots acquired by conventional frequency and TI counters are vulnerable to crosstalk! With the widespread availability of GPSDOs and other inexpensive frequency standards, many facilities from international physics laboratories to ham shacks are equipped with 5- and 10-MHz distribution networks. Don’t use low-quality cables with high-performance instrumentation.
Hints for xDEV measurements

- The PhaseStation does not display its own measurement floor in the ADEV, MDEV, HDEV, or TDEV views. Instead, you can (and should) make residual plots for measurements that may approach the instrument floor, using similar frequencies and signal levels. These residual plots can be saved, loaded and shown with Display→Overlay all loaded plots (o) next to your actual measurement traces.

- There's a direct relationship between measurement bandwidth and the instrument noise floor in ADEV and other phase/frequency measurements. You may find it helpful to observe drift-prone sources or oscillator startup characteristics at 5 kHz or 50 kHz ENBW, but be aware that the stability noise floor will be somewhat higher. Again, a separate residual plot at the frequencies and signal levels of concern can tell you exactly where the limits are.

- The measurement bandwidth also influences the size of the phase record that must be allocated before a measurement of a given duration can begin. As a result, you may experience out-of-memory errors if you tell TimeLab to record several hours' worth of phase data at 500 Hz ENBW/1K points per second. Increasing the Output decimation value in the Additional Options dialog is a great way to reduce acquisition memory requirements, but it will not improve the xDEV noise floor. The only way to lower the xDEV floor is to select a narrower measurement bandwidth.

- Fewer samples are available to contribute to bins near the right end of an xDEV trace. As a result, measurement confidence decreases at longer tau intervals. To increase the minimum number of samples that must contribute to a given xDEV bin in order for that bin to be displayed, you can change the Bin Threshold parameter in the acquisition dialog, or use Edit→Trace properties (e) to specify a new value for the same field at any time after acquisition.

However, because TimeLab employs overlapped xDEV algorithms, small changes to Bin Threshold may have no effect. Once the phase record grows long enough to provide data at a given tau interval, each additional sample adds another data point to the corresponding xDEV bin. If this is an issue, try setting the Bin Threshold to a large fraction of the total phase record size. The idea is to force TimeLab to render the xDEV trace as if much less data were available.
In the example at left, two copies of the same 3600-sample .TIM file have been loaded. The blue trace was rendered with the default Bin Threshold of 4, while the shorter magenta trace was rendered with Bin Threshold set to 2000. Enabling Trace→Show xDEV error bars (Ctrl-e) reveals the blue trace’s low confidence at its longest tau.

Generally, as long as Trace→Clip xDEV traces by confidence (Ctrl-v) is enabled, it will not be necessary to alter the Bin Threshold value to display xDEV trace data of good statistical quality. The default bin threshold and clipping options will suffice for almost all measurements, particularly those made at high data rates by instruments such as the PhaseStation.
Working with phase- and frequency-difference traces

Phase and frequency stability data acquired by TimeLab is represented internally as an array of phase-difference samples. This is true regardless of whether the data came from a frequency counter, a time-interval counter, or a direct-digital timing analyzer. (Frequency readings are converted to phase-difference samples on the basis of their deviation from the first frequency reading acquired.)

In addition to the statistical measurements such as Allan deviation that TimeLab provides, “strip chart” views are available to give you a closer look at the raw phase-difference data. These views correspond to the Phase difference (Unwrapped) \((p)\), Phase difference (Original) \((w)\), and Frequency-difference \((f)\) options on the Measurement menu.

Phase difference (Original) \((w)\)

Phase difference (Unwrapped) \((p)\)

The distinction between these two measurement types is relevant when receiving time-interval data from a traditional counter. The Phase difference (Original) \((w)\) measurement shows the original TI samples as they arrive from the hardware. When acquired from a TI counter, these readings are subject to “wraparound” when they exceed the period of the signal that determines the START-to-STOP channel interval. For instance, if an oscillator near 10 MHz is measured against a drift-free source at exactly 10 MHz, the TI readings from the counter will increase or decrease from one trigger interval to the next. When the START-to-STOP interval exceeds 100 nanoseconds or falls below 0 nanoseconds, the TI readings will necessarily wrap back around to the opposite “rail.” This phenomenon gives rise to the sawtooth-shaped phase trace familiar to users of vector network analyzers. As seen in the measurement example above, the phase-wrapping effect is visible in the Phase difference (Original) \((w)\) measurement view in TimeLab.

Figure 18: Original phase data received from TIC \((w)\) compared with unwrapped view \((p)\)
Conversely, TimeLab’s Measurement→Phase difference (Unwrapped) (p) view displays the TI samples in the form of phase data that’s been “unwrapped.” The sawtooth discontinuities are removed by adding or subtracting the input signal’s period whenever the sample-to-sample time difference exceeds half of that period.

It’s seldom necessary to refer to the original phase-difference graph except when troubleshooting configuration problems with live TI counter measurements. In most cases you should select the Measurement→Phase difference (Unwrapped) (p) view when you wish to inspect the principal phase record for your acquisition. Additionally, all of the flattening, detrending, and data-removal commands on the Edit menu work by replacing the original phase data with modified data based on the unwrapped record. After executing any of these commands, the p and u views will always be identical, just as if the data had been acquired from a frequency counter or direct-digital analyzer.

Further references to the phase-difference view in this manual will appear simply as Measurement→Phase difference (p), omitting the distinction between wrapped and original phase data. When working with the PhaseStation and TimePod analyzers, the original and unwrapped phase difference displays are equivalent.

**Frequency difference (f)**

![Frequency Difference (Zero-based)](image)

**Figure 19: Frequency difference measurement view with count chart**

Shown above is a third way to view the phase data from the earlier example. Each point on the Measurement→Frequency difference (f) trace is calculated by dividing the difference between successive pairs of phase-difference samples by the sample rate. Taking the time derivative of \( n \) adjacent phase-difference points in this manner yields a stream of \( n-1 \) frequency-difference points. Because of this differentiation process, the Measurement→Frequency difference (f) view of the phase record is often better at
revealing glitches and other short-lived artifacts in the phase record than the actual phase-difference trace is. Long-term oscillator drift and temperature-dependent effects are also easily spotted.

When the optional chart to the right of the trace area is enabled with Display→Numeric table (Ctrl-n), TimeLab can be used to emulate a frequency counter with impressive performance. The chart can be viewed at any time during or after acquisition. Its entries are computed in real time by integrating the frequency-difference values in the currently visible trace at successively longer intervals. The integration process moves from right to left, starting with the newest sample points and moving farther back in history as more data becomes available.

**How does TimeLab measure frequency?**

It’s important to understand that the “frequency differences” shown on the graph are actually fractional deviations from a value known as the input frequency. (Under most conditions this is the same value as the DUT frequency in the Display→Select menu.) If the measurement’s DUT input frequency is exactly 10,000,000 Hz, then a frequency-difference reading of +1E-7 would mean that the absolute frequency is 10,000,001 Hz at that moment in time.

But what exactly is this “input frequency?” Where does it come from, and how accurate is it? When acquiring data with a frequency counter, it’s easy enough to determine the nominal input frequency for the measurement: we simply use the first reading. All subsequent data points in the phase record are computed using the difference between the incoming frequency readings and the first one recorded... and all of these readings can be assumed to carry the same accuracy and precision.

When a time-interval counter (TIC) is used, however, TimeLab sees only a series of START-to-STOP interval times. It’s impossible to infer the input frequency automatically. Instead, you must enter it into the appropriate field of the acquisition dialog, specifying at least as much precision as you expect to obtain when viewing the frequency count chart.

**Phase/frequency measurements with the PhaseStation**

On the 53100A, the process of determining the input frequency can be thought of as a choice between the frequency-counter and TIC methods. Options in the Acquire→Jackson Labs PhaseStation acquisition dialog allow you to specify the anticipated DUT and reference frequencies directly or measure them at a specified rounding precision. For more details, please see the PhaseStation 53100A Measurement Roles section on page 125.
Examining traces in detail

In the example below, a crystal oscillator was measured over a 12-hour period. The Measurement→Phase difference (p) and Measurement→Frequency difference (f) views appear side-by-side for comparison.

Not much detail is visible in either trace. Some sporadic frequency jumps are present, but they’re not easily examined since their height is such a small fraction of the plot’s overall magnitude. Subtract global linear phase trend (frequency offset) (Ctrl-o) command expands the phase-difference trace somewhat by removing its linear trend, but it only moves the frequency-difference trace down a bit:

In fact, we could have achieved a similar effect without altering the phase record by viewing the phase-difference trace with Trace→Show linear phase/frequency residual (r), or by viewing the frequency-difference trace with Trace→Phase/frequency traces begin at zero (z).⁹

---

⁹ The Trace→Phase/frequency traces begin at zero (z) option can actually be more useful – not only can it be toggled on and off without altering the phase data, but it also forces the beginning of the frequency-difference trace to midscale. See page 66.
For these reasons, subtract global linear phase trend (frequency offset) (Ctrl-o) is not a commonly-needed command. At first glance, subtract global linear frequency trend (drift line) (Ctrl-l) seems more useful:

![Phase Difference and Frequency Difference plots](image)

**Figure 22: Removal of linear frequency drift**

Essentially, subtract global linear frequency trend (drift line) (Ctrl-l) removes the quadratic trend from the phase record, which has the effect of removing the linear trend from the frequency-difference plot. But there’s still an arbitrary offset in the frequency-difference view that’s forcing the Y-axis scale to +/- 1E-9, and the artifacts we’d like to examine are much smaller than this.

**Navigating zoomed graphs**

One strategy is to unlock the Y-axis with Trace → Phase/frequency Y axis unlocked in zoom mode (y), and then use the left mouse button to drag a box around the trace. When the button is released in the view at left, the result is the zoomed view at right:

![Zoomed Frequency Difference plots](image)

**Figure 23: Zooming in**

**TimeLab** is designed to take full advantage of a PC mouse with three buttons and a scroll wheel. All of the graph types are “zoomable,” and you can always return to the unmagnified view by right-clicking anywhere on the plot. Unlike the xDEV and noise measurement displays, though, the phase- and frequency-difference measurement views support additional navigation options. You can expand and contract the zoomed area with the mouse wheel, or surf through the data by dragging with the middle button.
Unlocking the Y axis with **Trace→Phase/frequency Y axis unlocked in zoom mode (y)** keeps TimeLab from constantly adjusting the Y axis to accommodate the graph’s vertical range. With the Y axis unlocked, you can expand and scroll the graph in both directions with the mouse, rather than being limited to side-to-side navigation.

In this case, though, unlocking the Y axis and drawing a box requires a lot of user interaction. Worse, you’ll end up with an “unfriendly” Y-axis scale whose random-looking values make the graph difficult to interpret. **Trace→Phase/frequency traces begin at zero (z)** offers a better alternative with a single keystroke:

![Frequency Difference (Zero-based)](image)

**Figure 24: The 'z' zero baseline mode**

To sum up, selecting **Measurement→Frequency difference (f)**, applying **Subtract global linear frequency trend (drift line) (Ctrl-l)**, and enabling **Trace→Phase/frequency traces begin at zero (z)** can reveal details which are impossible to spot in the raw phase-difference trace. All of this being said, in order to get the same detailed view, we **really** only needed to enable **Trace→Show linear phase/frequency residual (r)** while viewing the frequency difference trace!

![Frequency Difference (Linear residual, zero-based)](image)

**Figure 25: The linear residual display**
The Trace→Phase/frequency traces begin at zero (z) and Trace→Show linear phase/frequency residual (r) commands are both extremely useful. Enabling one or both of these features can give you a detailed view of most phase- or frequency-difference traces without altering the phase data itself\(^{10}\). Keep the r and z keys in mind while working with these traces, and experiment with them frequently.

**Hints for phase/frequency stability measurements**

- Due to slight variations in FPGA/USB interface temperature that occur when acquisition begins, the 53100A’s own impact on critical residual-phase measurements can be minimized if you use Acquire→Enable deferred acquisition (ctrl-d) to force the acquisition to throw away incoming data until you press Enter to ‘trigger’ it. This feature is normally used to improve synchronization in multiple acquisitions, but you can also use it to force a single instrument to reach its equilibrium temperature before the software saves any data.

  You can accomplish the same thing by selecting the Measurement→Phase difference (p) view, using the left mouse button to select the first few minutes of data where the phase slope may be artificially degraded. When you release the button it will zoom to the selected area of the plot. You can then hit F4 to delete that chunk of data from the phase record. The ADEV and other phase-derived graphs will be recalculated. (This will not affect the phase or AM noise plots; as mentioned elsewhere, they are acquired with a completely different "signal path" than the one that decimates and records the phase-difference data.)

- Pressing Scroll Lock will latch the current Y-axis limits, preventing them from changing regardless of the zoom status or Trace→Phase/frequency Y axis unlocked in zoom mode (v) option. This feature can be useful when you want to keep the view from being rescaled after removing, detrending, or flattening trace data, such as when similar modifications are being applied to multiple traces in an unzoomed view. Turning Scroll Lock off will restore the previous Y-axis control state.

  Most users will not need to latch the Y axis limits. Scroll Lock is one of the few operations in TimeLab with no menu-based equivalent.

---

\(^{10}\) Note that the Subtract quadratic linear frequency trend (drift curve) (Ctrl-q) operation has no “view-only” equivalent. It operates in a manner similar to the Subtract global linear phase trend (frequency offset) (Ctrl-o) and Subtract global linear frequency trend (drift line) (Ctrl-l) commands, and can be even better at revealing details in plots like this one.
To invert the phase slope, you can use the Edit→Trace properties… (e) dialog to specify a Rescale Phase value of -1. This will invert both the slope and the origin of the phase data, but you can still use Trace→Phase/frequency traces begin at zero (z) to display the inverted trace at a fixed origin of zero.

Figure 26: Phase inversion
Phase noise, AM noise, and jitter

Thanks to the magic of cross-spectrum averaging, the PhaseStation 53100A can measure exceptionally low levels of phase noise and AM noise on HF and VHF signals. Below are some guidelines to help you make the most of this capability.
Integrated noise and jitter measurement

You can display various measures of integrated phase noise between two arbitrary offsets by enabling any or all of the following fields in the Legend→Select menu:

- Residual FM
- RMS Integrated Noise (Degs)
- RMS Integrated Noise (Rads)
- RMS Time Jitter
- SSB Carrier/Noise

When one or more of these parameters is enabled for display in the legend table, two “spot cursors” will appear in blue, as shown at right. You can move these lower and upper limit cursors with Ctrl-left click and Ctrl-right click, respectively.

TimeLab does not make a distinction between random and deterministic jitter, so any spurs in phase noise plots are “integrated” as if they contained only random noise. Consequently, when viewing any of the RMS integrated noise values, you should use either Trace→Smooth noise traces (Ctrl-w) or Trace→Suppress spurs (Ctrl-s) to remove as much coherent energy as possible from the phase noise trace. Otherwise, time jitter and integrated-noise readings may be artificially exaggerated.

Along with many other sources, HP Application Note AN270-2 provides a concise summary of the math behind phase-noise integration.
The spur table

The spur table is a list of all coherent amplitude- or phase-modulated spectral components detected by the instrument in the course of measuring AM noise or phase noise, respectively. Each plot acquired from an instrument that supports spur detection has its own spur table. Spur levels are reported as CW power levels relative to the carrier, each at a given offset from the carrier frequency.

![Phase Noise \( \xi(f) \) in dBC/Hz](image)

<table>
<thead>
<tr>
<th>PM Spur Offset (Hz)</th>
<th>dBC</th>
</tr>
</thead>
<tbody>
<tr>
<td>120.3</td>
<td>-115.3</td>
</tr>
<tr>
<td>241.6</td>
<td>-130.4</td>
</tr>
<tr>
<td>360.9</td>
<td>-135.8</td>
</tr>
<tr>
<td>480.2</td>
<td>-135.3</td>
</tr>
<tr>
<td>768.9</td>
<td>-125.2</td>
</tr>
<tr>
<td>1544.6</td>
<td>-125.8</td>
</tr>
<tr>
<td>2314.5</td>
<td>-126.1</td>
</tr>
<tr>
<td>3089.2</td>
<td>-127.3</td>
</tr>
<tr>
<td>8459.3</td>
<td>-125.3</td>
</tr>
<tr>
<td>9228.2</td>
<td>-123.0</td>
</tr>
</tbody>
</table>

Figure 28: Typical phase noise measurement with accompanying spur table

The default Spur Threshold value of 6 dB, specified in the Additional options page of the PhaseStation acquisition dialog, ensures that artifacts of lower amplitude relative to neighboring areas of the trace are not classified as spurs. To illustrate the difference between coherent spur amplitudes and their apparent levels on the 1-Hz normalized noise trace in the figure above, Trace→Suppress spurs in noise traces (Ctrl-s) is disabled, and Trace→Mark spurs in noise traces (Ctrl-m) is turned on.

Show or hide known spurs

Several commands in TimeLab determine how spurs are handled in phase noise and AM noise graphs:

- Trace→Mark spurs in noise traces (Ctrl-m) draws shaded or dashed lines, depending on the Trace→Toggle trace thickness for current measurement (T) setting, for each detected spur on the AM or phase noise graphs. These lines reflect the amplitude of each spur as reported in the spur table, which will not be the same as the level of any corresponding bumps or spikes in the noise trace itself. Because phase noise and AM noise traces undergo normalization to 1 Hz bandwidth, the Y-
axial labels don’t reflect the true amplitude of any coherent trace features. They must be recognized as spurs, and their amplitudes indicated separately.

- **Trace→Suppress spurs in noise traces (Ctrl-s)** attempts to remove known spurs from phase noise and AM noise traces. As noted above, spurs that appear as artifacts in noise traces are not rendered at their true amplitude levels due to the use of FFT noise-bandwidth normalization. If you are concerned with spur amplitudes in a given measurement, you should use **Trace→Suppress spurs in noise traces (Ctrl-s)** to erase each detected spur from the graph and **Trace→Mark spurs in noise traces (Ctrl-m)** to replace them with vertical lines showing their true CW amplitude levels relative to the carrier.

- **Trace→Smooth noise traces (w)** always implies **Trace→Suppress spurs in noise traces (Ctrl-s)**. For better visual quality, TimeLab will attempt to erase any known spurs prior to smoothing the trace.

- **Display→Numeric table (Ctrl-n)** can be used to show or hide the spur chart for the selected plot. Like the numeric charts and tables associated with other measurement types, the spur chart appears to the right of the graph area. The Ctrl-n command toggles table visibility for all measurement types, not just the currently visible one.

### Spur measurement options

The **Additional options** page in the PhaseStation 53100A’s acquisition dialog contains four controls that influence how spurs are recognized and recorded.

![Figure 29: Window and spur controls](image)

- The choice of **FFT Window** implies a compromise between the accuracy at which a given spur’s offset frequency and amplitude are reported. The default **Flat top** window excels at measuring spur amplitude levels, but the **Hann** window offers better frequency resolution, and may improve the odds of detecting a given spur as well.

- The **Spur threshold** field defaults to 6.0 dB. It defines the amplitude level, relative to the average level of nearby FFT bins, below which a given bin’s amplitude will not be considered indicative of a coherent spur.
• **Spur min offset** is normally 0.0 Hz. It can be set prior to acquisition by entering an offset frequency below which spurs will not be logged for processing. The minimum spur offset can also be adjusted in the Edit→Trace properties dialog at any time after acquisition is complete. This feature can be especially helpful when large ‘bumps’ in the flicker noise region are incorrectly classified by TimeLab as either real spurs or instrument spurs.

• When the **Attenuate instrument spurs** option is checked, the PhaseStation driver software will use the phase component of a given spur’s peak FFT bin to attempt to classify it as an instrument artifact or a genuine result of the measurement. Instrument spur discrimination is enabled by default and discussed in detail below.

Additionally, note that both spur-identification performance and acquisition time will be affected if the Edit segment table button is used to change the FFT kernel sizes used in the individual noise-trace segments. While lower-resolution segment definitions can result in faster measurements, they can also cause large elevated regions to appear where “forests” of discrete spurs are too closely-spaced to resolve.

**Is it a spur, or isn’t it?**

Identifying genuine spurs while disregarding false ones is a difficult problem in the general case, and no spur-discrimination algorithm is infallible. The 53100A’s DSP software may occasionally fail to detect spurs when they occur in clusters near the FFT segment’s resolution limits, in steeply-sloped areas of the noise trace, or in other parts of the trace where an obvious baseline is not clearly discernible.

You can lower the **Spur Threshold** for a given measurement, but the risk of misclassifying random noise spikes as coherent spurs will become greater. When you see random spurs appear and disappear from the spur chart over the course of a measurement, you can increase the **Spur Threshold**, try changing FFT window types, or simply wait for the measurement to run long enough to reduce the trace variance (“grass”).

As mentioned above, you can also tell TimeLab to ignore spurs close to the carrier with the **Min Spur Offset** field in the Edit→Trace Properties dialog. This option can also be specified at acquisition time in the PhaseStation acquisition dialog’s Additional options page.
**Understanding instrument spurs**

While TimeLab can sometimes overlook true spurs and report nonexistent ones, a third type of measurement error may need to be considered as well: the presence of spurs which originate within the instrument itself.

The spur-free dynamic range (SFDR) of the ADCs used in the 53100A is approximately 100 dB, which determines the corresponding specification limit of the instrument as a whole. In principle, your noise plots may contain fictitious spurs as high as -100 dBC, but the 53100A’s typical performance is much better than this. Any spurs with amplitudes above -120 dBC that remain visible as the measurement converges are likely to be “real” in the sense that they originate from the DUT, from the reference, or from environmental RFI.

Regardless of the equipment used, spur-free observations of AM noise and phase noise become challenging below -130 dBC. There are simply too many potential sources of coherent artifacts to rule out in most cases. Still, spurs that originate within the 53100A can sometimes be identified manually. An informal technique that may help determine whether a given spur or spur cluster originates within the 53100A hardware itself is illustrated in the side-by-side plots below.

![Image](image.png)

**Figure 30: Imaginary and real components of the cross-correlated noise spectrum**

At left, the phase noise of a crystal oscillator has been measured over the course of several hours. Most of the visible spurs are below the 53100A’s specified limits, so it isn’t clear which ones the instrument may be responsible for.

However, because complex signals are used throughout the 53100A’s DSP pipeline, we can take advantage of a mathematical observation. While the cross spectrum of a physically-realizable signal should fall on the real axis of the Argand plane, at least some instrument spurs are caused by data-conversion errors that can show up elsewhere in phase space. Like random ADC noise, the numerical distribution of these errors is not

---

11 See Rubiola and Vernotte, *The cross spectrum experimental method*, and Grove *et al.*, *Direct-digital phase noise measurement*
limited to the real axis... but unlike random noise, the real amplitude of some of these spurs may not average to zero over time. These spurs appear on the graph as instrument artifacts.

Switching to the Trace→Show imaginary part of cross spectrum display (Ctrl-F3) view at right reveals the noise and spurs that correspond to the imaginary part of the cross-spectrum average, specifically the absolute value of the Q-component at each bin. Ordinarily this data is used only to create the shaded area used by the Trace→Show estimated instrument noise (F2) feature, after undergoing heavy averaging. But Ctrl-F3 lets us view the imaginary part of the cross spectrum at full resolution. It’s readily apparent that the spur near 50 kHz has almost the same amplitude in the imaginary cross spectrum as it does in the real measurement.

This is a strong indicator that the spur is an instrument artifact. When Attenuate instrument spurs is selected in the PhaseStation acquisition dialog, spurs with high imaginary amplitude components are removed from the plot regardless of the state of all other smoothing and spur-suppression options.

There are other spurs in the imaginary cross spectrum that correspond to similar spurs in the real plot, but most appear to be AC line harmonics that both the 53100A and the sources under test are exposed to, and their amplitudes are substantially different. Although the Ctrl-F3 technique isn’t foolproof, it can offer some valuable insight when you need to account for unanticipated low-level spurs.
Using noise markers

To add up to 10 noise markers at specified offset frequencies, hold down the Shift key and left-click on the graticule area of the noise plot near the desired column. A marker will appear at the top of the graticule area. If the selected plot includes valid trace data at the specified offset frequency, a corresponding entry will appear in the noise marker table at right, displaying the offset frequency and noise power at that point in the trace.

To remove an existing noise marker, simply shift-left click near the marker’s column on the screen. All of the currently-defined markers may be cleared with Display→Clear noise markers (F3).

The visibility of the noise marker table can be toggled with Display→Show numeric tables (Ctrl-n). If the noise marker table is not visible despite being enabled, ensure that at least one marker is placed at an offset that lies within the limits of the selected trace. Markers located at offsets where no trace data exists will be shown on the graticule, but will not appear in the table. When no noise markers are eligible for display, the table itself will not be rendered.
Hints for noise measurements

• The 53100A can render an estimate of its own noise floor in AM/PM noise plots if you enable Trace→Show estimated instrument noise (F2). See page 97 for more information.

• For AM and phase noise, a good indication that the noise trace has converged on its final level is the variance of the trace, or its overall fuzziness/thickness. If you measure a conventional signal generator or noisy oscillator, you’ll notice that the trace stops falling relatively quickly after the measurement begins, and then becomes smoother over time. This 'smoothing' effect is an important cue that tells you how trustworthy your noise measurement is. With quiet sources, close-in segments can take an especially long time to converge at a final, smoothed level, since they are updated much less often.

• Crosstalk and AC power-line interference can create discrete spurs on phase noise and AM noise graphs, just as they can degrade ADEV and other statistical plots. See page 47 for a discussion of causes and cures.

• TimeLab has a graph-smoothing feature (Trace→Smooth noise traces (ctrl-w)) but it’s not always needed with a cross-correlating analyzer such as a PhaseStation, TimePod, or Microsemi 5120A/5125A. The best way to obtain a smoother trace with these instruments is often to let your measurement run longer. Low-noise plots can benefit from Trace→Smooth noise traces (ctrl-w), but many measurements don’t need additional smoothing at all.

• Another tip for smoother phase noise and AM noise traces, suitable for PhaseStation users with faster PCs: enable the Overlapped acquisition option in the Additional options page of the acquisition dialog. Overlapped acquisition provides much more efficient utilization of incoming data by the FFT routines, but requires significantly more CPU time. (Note that FFT overlapping is different from the algorithm used in overlapped Allan deviation and other stability statistics. Overlapped statistical calculations are always performed, while overlapped FFT processing in noise data acquisitions is turned off by default.)

• When overlaying several measurements on the screen, it can be helpful to run with spurs removed from the trace (Trace→Suppress spurs (Ctrl-s) enabled) and unmarked on the graph (Trace→Mark spurs (Ctrl-m) disabled). Trace→Smooth noise traces (ctrl-w) will automatically suppress spurs.
TimeLab Command Reference

Virtually all of the menu-based commands in TimeLab also have single-key shortcuts for faster, more interactive workflow. When present, the shortcut key is generally shown after the name of the menu option.
**File menu**

The File menu helps you work with data files and images. Supported actions include opening, saving, closing, and deleting plots stored in .TIM files, saving image files, printing or copying the currently displayed window contents, and importing and exporting raw measurement data. Various “user preference” toggles are also provided on this menu.

**Load .TIM file (l)**

Loads a saved .TIM file. .TIM files are ASCII text files that contain all measurement data acquired or imported by TimeLab, together with any applicable metadata. Specific fields and tables within each .TIM file may vary depending on the measurement type(s) saved in the file.

For frequency stability measurements made with counters or timing analyzers, the .TIM file contains the phase record obtained from the instrument during acquisition. The phase record may have been derived from a series of frequency readings or other raw data stream formats. It may also have been decimated to conform to a specified measurement rate or bandwidth.

For phase noise and AM noise measurements, the .TIM file contains the FFT bin contents needed to render the applicable graphs.

**Save image or .TIM file (s)**

This command can either save the selected plot as a .TIM file, or save the current contents of the TimeLab window as an image file in .PNG, .GIF, .TGA, .PCX, or .BMP format.

By default, .TIM files will be saved. To save an image file, simply add one of the suffixes above when you enter the filename. *Keep in mind that image files do not preserve your original measurement data, and cannot be reloaded into TimeLab.* If a trace caption was either provided at acquisition time or added with Edit→Trace properties (e), it will be used as the default filename.

Generally, the .PNG format is best for saving images from TimeLab for email attachment or inclusion in other documents. .GIF and .PCX files will discard some color information, while .TGA and .BMP files are unnecessarily large.

When saving an image, all visible status and error messages, notifications, prompts, and mouse-cursor query values are removed. The black-triangle cursor associated with the currently selected plot will also be omitted from saved images.
**Copy image to clipboard (Ctrl-c)**

This command offers a handy shortcut for cutting/pasting TimeLab screen images into other programs via the operating system’s clipboard, avoiding the need to save an image file.

When copying the screen image to the clipboard, all visible status and error messages, notifications, prompts, and mouse-cursor query values are removed. The black-triangle cursor associated with the currently selected plot will also be omitted from the copied image.

Use caution when pasting images from the clipboard into email messages. Some clients may encode them in uncompressed form, resulting in messages too large to email reliably. When in doubt, consider attaching a saved .PNG file instead.

**Import .RES or .PNP phase noise data (N)**

This command can be used to import a .RES file created by the HP 3048A, an industry-standard phase noise analysis system, or a .PNP file saved by PN.EXE, a popular freeware phase-noise measurement application from the KE5FX GPIB Toolkit.

The latter option supports phase noise plots from various RF spectrum analyzers not otherwise recognized by TimeLab.

**Import ASCII phase or frequency data (L)**

Reads an ASCII text file containing phase-difference, frequency, frequency-difference, or timestamp data, one entry per line. The imported data is converted to a standard TimeLab phase record, and may be rendered, manipulated, and saved as a .TIM file.

As with other acquisition dialogs, TimeLab’s data-import dialog provides detailed mouseover help text for all fields. Refer to this help text for usage information.

To “watch” a continuously updated data file, use Acquire→Acquire from live ASCII file instead.
Export ASCII phase data (x)

This command is supported only when viewing the selected plot’s phase record contents using Measurement→Phase difference (p) or Measurement→Frequency-difference (f). It will save an ASCII text file containing phase difference data in seconds, one entry per line, at 16 digits of precision to the right of the decimal point.

If a selected or zoomed area has been defined by dragging with the mouse, only that portion of the phase record will be exported.

By default, the exported phase data will be saved with the suffix .CSV for ease of reading into Excel and other spreadsheets. Exported data may be re-imported into TimeLab, if necessary, by the File→Import ASCII phase or frequency data command. Select “All files” as the file type if the data was not exported with the suffixes .TXT or .DAT, then select Phase difference (sec) as the file data type.

Optionally, each sample in the ASCII phase data file can be timestamped with its absolute MJD or the number of elapsed seconds since the beginning of the phase record.

Export ASCII frequency data (X)

This command is supported only when viewing the selected plot’s phase record contents using Measurement→Phase difference (p) or Measurement→Frequency-difference (f). It will save an ASCII text file containing absolute frequency readings in hertz, one entry per line, at 16 digits of precision to the right of the decimal point.

If a selected or zoomed area has been defined by dragging with the mouse, only that portion of the phase record will be exported.

By default, the exported frequency readings will be saved with the suffix .CSV for ease of reading into Excel and other spreadsheets. Exported data may be re-imported into TimeLab, if necessary, by the File→Import ASCII phase or frequency data command. Select “All files” as the file type if the data was not exported with the suffixes .TXT or .DAT, then select Frequency (Hz) as the file data type.

Optionally, each sample in the ASCII phase data file can be timestamped with its absolute MJD or the number of elapsed seconds since the beginning of the phase record.
Export binary phase data

This command is supported only when viewing the selected plot’s phase record contents using Measurement→Phase difference (\(p\)) or Measurement→Frequency-difference (\(f\)). It will save a binary file containing phase difference data in seconds, represented as a block of double-precision IEEE 754 values in little-endian (Intel) format.

If a selected or zoomed area has been defined by dragging with the mouse, only that portion of the phase record will be exported.

As with File→Export ASCII phase data (\(x\)), the default file suffix is .CSV. This is usually inappropriate for binary data; you should specify a suffix appropriate to your application. Exported binary phase data may not be re-imported into TimeLab.

Export phase data to Stable32 (Ctrl-x)

This command is useful for transferring data from the selected plot’s phase record directly into a third-party analysis application such as Stable32 from Hamilton Technical Services. Stable32 is a popular application for offline data analysis. It supports many statistical features and display options beyond the limited set implemented by TimeLab.

This command works by exporting the selected plot’s phase record to a temporary file using the same functionality as the File→Export ASCII phase data (\(x\)) command. If a selected or zoomed area has been defined by dragging with the mouse, only that portion of the phase record will be exported.

When the command is issued, a dialog box allows you to specify the location of the Stable32 executable or other third-party program, as well as the command line to be passed to it. The command line may contain various predefined variables described in the dialog box’s help text, including placeholders for the name of the temporary file and the data rate (tau zero) in samples per second. Upon pressing the Launch Stable32 button, the temporary file will be generated and the specified program launched. TimeLab will then continue to run normally.

Temporary files created by TimeLab are cleaned up when TimeLab exits, so it’s advisable to leave TimeLab running until after the third-party analysis application has exited.
Export ASCII xDEV trace

Available in the Measurement→Allan Deviation (a), Measurement→Modified Allan Deviation (m), Measurement→Hadamard Deviation (h), or Measurement→Time Deviation (t) views, this command creates an ASCII text file containing a \( \tau, \sigma(\tau) \) value pair for each visible xDEV bin in the selected plot. One value pair is written per line; each value is rendered with 16 digits of precision to the right of the decimal point.

The number and distribution of xDEV bins may be specified prior to acquisition with the Bin Density field in the Frequency Stability tab of the acquisition dialog. Additionally, the selected plot’s bin density may be adjusted after acquisition through the Edit→Trace properties dialog. See the help fields in these dialogs for details.

By default, the exported \( \tau, \sigma(\tau) \) pairs will be saved with the suffix .CSV for ease of reading into Excel and other spreadsheets.

Export ASCII AM/PM noise trace

Available in the Measurement→Phase noise (P) and Measurement→AM Noise (A) views, this command creates an ASCII text file containing \( \text{offset, } dBC/\text{Hz} \) values corresponding to the visible noise trace for the selected plot. One value pair is written per line; each value is rendered with 16 digits of precision to the right of the decimal point.

One \( \text{offset, } dBC/\text{Hz} \) pair is written for each pixel column in the displayed graph. This means that if you zoom in on a portion of the phase noise or AM noise graph, only the trace data corresponding to the visible area of the selected plot will be exported. Conversely, if the graticule’s X-axis boundaries extend beyond the minimum or maximum offset for the selected plot, no \( \text{offset, } dBC/\text{Hz} \) pairs outside the valid range will appear in the exported file.

By default, the exported \( \text{offset, } dBC/\text{Hz} \) pairs will be saved with the suffix .CSV for ease of reading into Excel and other spreadsheets.

Note that when Show imaginary part of cross spectrum (Ctrl-F3) is active, the File→Export AM/PM noise trace command will export the imaginary cross spectrum trace data rather than the normal AM noise or phase noise trace.

Export AM/PM spur table

Available in the Measurement→Phase noise (P) and Measurement→AM Noise (A) views, this command creates an ASCII text file containing \( \text{offset, } dBc \) values corresponding to entries in the spur table for the selected plot. One value pair is written per line; each value is rendered with 16 digits of precision to the right of the decimal point.

See “Spurs” on page 70 for more about spur detection and measurement.
By default, the exported offset, \( dBC \) pairs will be saved with the suffix .CSV for ease of reading into Excel and other spreadsheets.

**Exported ASCII files include headers for Microsemi TimeMonitor**

When enabled, this option causes text files written by Export ASCII xDEV trace, Export ASCII AM/PM noise trace, Export ASCII frequency data, and Export ASCII phase data to be prefixed with a comment header that will be recognized by the Microsemi TimeMonitor application.

The default filename suffix for exported ASCII files will be .TXT when this option is active, rather than .CSV. By default, this option is turned off.

**Print image**

After displaying a standard dialog box for printer selection and configuration, this command prints the current contents of the TimeLab window.

The printed image will not contain any visible status or error messages, notifications, prompts, or mouse-cursor query values. The black-triangle cursor associated with the currently selected plot will also be omitted.

**Scale file dialogs by window size**

When this option is enabled, common file dialogs in Windows XP will be centered in the TimeLab window and resized proportionally. In later Windows versions, the option has no effect. (Default: disabled)

**Confirmation prompts default to Yes**

When this option is enabled, the default button in most confirmation prompt dialog boxes will be ‘Yes’ rather than ‘No.’ (Default: disabled)

**Warn before exiting with unsaved plots**

If enabled, this option causes TimeLab to prompt for confirmation before exiting if any plots have been acquired or edited but not saved. (Default: enabled)

**Warn before retriggering measurement in progress**

If enabled, this option causes TimeLab to prompt for confirmation before acting on the Acquire→Keep and retrigger selected acquisition (Ctrl-k) or Acquire→Abort and retrigger selected acquisition (Ctrl-a) commands. (Default: enabled)

**Reset all parameters, options, and settings at next startup**

This option causes a dialog box to appear when you exit from TimeLab, confirming that you would like to reset all options, settings, colors, and dialog fields to their default values the next time the program is launched. If confirmation is given, the .INI files associated with TimeLab and all of its instrument drivers will be deleted, forcing them to be recreated with default values when the program is relaunched. (Default: disabled)
If desired, the .INI files used by TimeLab and its instrument drivers may be copied, backed up, or edited manually. The location of the directory where TimeLab stores its .INI files varies depending on the operating system version. In Windows 7, these files are normally located at `c:\Users\<user name>\AppData\Local\Miles Design\TimeLab`, also accessible at `%LOCALAPPDATA%\Miles Design\TimeLab`. In Windows XP, the .INI files are normally located in the hidden directory `c:\Documents and Settings\<user name>\Local Settings\Application Data\Miles Design\TimeLab`.

Note that TimeLab does not generally store configuration data in the Windows registry or anywhere else besides its .INI files; only installation-related data is stored in the registry.

**Close selected plot (Del)**

Closing the selected plot frees the memory it occupies and removes it from the graph and legend table. If the plot is associated with a saved .TIM file, the file is not deleted.

After closing a plot, the next plot in the legend table, if any, becomes the selected plot. Up to 9 plots may be loaded into memory at once; to acquire, load, or import additional plots, you must close at least one.

**Close all visible plots (Home)**

Closes all loaded plots at once, removing them from the graph and legend table.

**Delete selected plot’s .TIM file (Ctrl-Del)**

After prompting for confirmation, this command unloads the selected plot’s data from memory and also deletes its associated .TIM file, if any.

After closing a plot, the next plot in the legend table, if any, becomes the selected plot. Up to 9 plots may be loaded into memory at once; to acquire, load, or import additional plots, you must close at least one.

**Quit (q or Esc)**

Exits from TimeLab. Depending on the setting of File→Warn before exiting with unsaved plots, a confirmation prompt may be issued.

Unless you hold the Shift key as the program exits, TimeLab will write all of its global settings and dialog fields (as well as a list of known Legend menu entries and currently loaded plots) to a file called `TIMELAB.INI`. These properties will be restored when the program is next launched. The “Shift-exit” feature can be handy if you have opened or closed various plots or changed any options or colors, but don’t wish to retain the changes or otherwise lose your previous startup defaults.

Note that acquisition and file-import dialog field contents are not backed up in `TIMELAB.INI`. The most recently used dialog entries associated with these operations
are stored in instrument-specific .INI files. The instrument driver updates its .INI file as soon as you select Start Measurement or otherwise initiate an acquisition or import operation, not when the program exits.

If desired, the .INI files used by TimeLab and its instrument drivers may be copied, backed up, or edited manually. The location of the directory where TimeLab stores its .INI files varies depending on the operating system version. In Windows 7, these files are normally located at c:\Users\<user name>\AppData\Local\Miles Design\TimeLab, also accessible at %LOCALAPPDATA%\Miles Design\TimeLab. In Windows XP, the .INI files are normally located in the hidden directory c:\Documents and Settings\<user name>\Local Settings\Application Data\Miles Design\TimeLab. TimeLab does not generally store configuration data in the Windows registry or anywhere else besides its .INI files; only installation-related data is stored in the registry.

After updating TIMELAB.INI at program termination, any temporary files that may have been created by instrument drivers or the File→Export phase data to Stable32 (Ctrl-x) command are deleted. For debugging purposes, temporary-file cleanup is also inhibited if you hold down the Shift key while the program terminates.
**Edit Menu**

Plots that have been loaded or acquired in TimeLab may be displayed with a variety of options and transforms. However, any global changes to the measurement data or display parameters associated with a specific plot must be made through the commands in the Edit menu.

**Trace properties (e)**

As seen above, the *Edit → Trace properties (e)* dialog lets you change various properties associated with the selected plot that determine how its measurement data is presented. These properties were assigned their initial values in the acquisition dialog before the measurement began. Like the various instrument-specific dialogs on the Acquire menu, the trace-properties dialog may vary from the image shown above.

The dialog has extensive “mouseover help” text that is maintained alongside TimeLab itself, so the individual fields will not be described here at length. Simply position your cursor over each field to learn more about it.

Some areas of the dialog may be disabled depending on the data type(s) available in the selected plot. Also, certain properties – notably those in the Frequency Stability area that determine the bin configuration for Allan deviation and other statistical
measurements -- cannot be edited while acquisition is in progress. If you didn’t enter the desired values in the acquisition dialog before data collection began, you’ll need to wait for the measurement to finish before you can change them.
Flatten selected or zoomed phase data (Ctrl-f)

Above, the Flatten selected or zoomed phase data (Ctrl-f) command has been used to replace the selected region of the phase record with a straight line. The result appears as a flat spot in the frequency difference view.

This command is supported only when viewing the selected plot’s phase-record contents using Measurement→Phase difference (p) or Measurement→Frequency difference (f). In addition, a region within the plot must first be specified. You can specify a region with a Shift-Left drag operation that leaves the region boundaries visible within the existing graph, as in the images above, or you can simply drag with the left mouse button to zoom in on the desired region. In either case, the command will replace the data within the specified region of the selected plot’s phase record with a straight line segment that connects the data points at the region boundaries. As seen in the figures above, a straight line in the phase record corresponds to a flat region in the Measurement→Frequency difference (f) view.

You can use Edit→Flatten selected or zoomed phase data (Ctrl-f) to remove glitches and outliers from an acquisition. Subsequently, Edit→Undo last flatten or subtract operation (Ctrl-z) can be used to restore the flattened data. Unless you absolutely must preserve the original length of the phase record, though, it’s better to use Edit→Remove selected or zoomed phase data (F4) in most cases.

No active background tasks may be under way for the selected plot at the time this command is issued. Active background tasks are those in which the plot’s memory-resident phase record is being written, such as during initial acquisition and when reloading a saved .TIM file. If the phase record has finished loading but the xDEV statistical traces are still being refreshed, the refresh operation will be cancelled, then restarted after the command finishes.
**Remove selected or zoomed phase data (F4)**

Like Edit→**flatten selected or zoomed phase data** (Ctrl-f), this command is useful for removing glitches and outliers from the selected plot’s phase record. Instead of replacing the affected region with a straight line, however, Edit→**Remove selected or zoomed phase data** (F4) shortens the phase record by removing the data altogether.

This command has the same requirements and constraints as Edit→**Flatten selected or zoomed phase data** (Ctrl-f), except that it cannot be undone with Edit→**Undo last flatten or subtract operation** (Ctrl-z). Consider saving your original data to a .TIM file first so that it can be recovered if necessary.

When removing data from the middle of the phase record, you’ll be asked if you want to maintain phase continuity. In virtually all circumstances you should respond “Yes” to this prompt. TimeLab will then ensure a seamless transition between the two remaining regions by applying a constant offset to the phase data following the removed region. Otherwise, an abrupt phase change due to lost continuity may appear as a glitch in the data.

No active background tasks may be under way for the selected plot at the time this command is issued. Active background tasks are those in which the plot’s memory-resident phase record is being written, such as during initial acquisition and when reloading a saved .TIM file. If the phase record has finished loading but the xDEV statistical traces are still being refreshed, the refresh operation will be cancelled, then restarted after the command finishes.
Subtract global linear phase trend (frequency offset) (Ctrl-o)

Subtract global linear frequency trend (drift line) (Ctrl-l)

Subtract quadratic linear frequency trend (drift curve) (Ctrl-q)

These related commands are used to remove global offsets and trends from the selected plot’s phase record. This is typically done to improve visibility of local trends and features whose magnitude is small compared to the Y-axis range. For detailed usage information and examples, as well as some alternative viewing methods that don’t alter the phase record contents, see page 56.

Two commands on the Trace menu, Phase/frequency traces begin at zero (z) and Show linear phase/frequency residual (r), provide non-destructive functionality similar to the Edit→Subtract global linear phase trend (frequency offset) (Ctrl-o) command. See page 89 for more information.

If the selected plot has any background tasks in progress when any of these commands are issued, an error message will be displayed. Background tasks are those in which the plot’s memory-resident phase record is being accessed by a background thread during initial acquisition, when reloading a saved .TIM file, and when reconstructing the xDEV statistical traces after a previous modification to the phase record.

Note that subtracting trends from data records that exhibit a large amount of variance relative to their overall slope – such as might be obtained from comparisons of GPSDO or atomic standards -- can result in numerically unstable outcomes that vary randomly based on the number of points in the data record. You may wish to toggle the subtraction operation with Edit→Undo last flatten or subtract operation (Ctrl-z) to verify that the command performed as expected.
Apply notch filter to phase data (Ctrl-n)

This command applies a biquad notch filter with the specified center frequency and Q parameters to the phase data record. It is typically used to attenuate unwanted tonal artifacts such as crosstalk and AC line interference. The filter has no effect on phase noise or AM noise data.

<table>
<thead>
<tr>
<th>Apply notch filter to phase record</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Center frequency</strong></td>
</tr>
<tr>
<td><strong>Notch Q</strong></td>
</tr>
<tr>
<td>Spur Identification</td>
</tr>
<tr>
<td><strong>From</strong></td>
</tr>
<tr>
<td><strong>To</strong></td>
</tr>
<tr>
<td><strong>Search</strong></td>
</tr>
</tbody>
</table>

Center frequency
Enter the center frequency in Hz of the tone to remove from the selected plot’s phase record, or press 'Search' to measure the dominant tone automatically.

The notch frequency must lie between DC (0 Hz) and the phase record’s Nyquist frequency, defined as half of its sample interval.

It may be necessary to specify aliased frequencies to remove artifacts beyond the phase record’s Nyquist rate. For example, to remove 60 Hz ripple from a 100-sample-per-second ADEV plot, you will need to specify a 40 Hz center frequency.

Figure 34: Notch filter properties

In the dialog box above, the desired center frequency and Q should be entered in the fields indicated.

The Search button can optionally be used to identify the dominant tone within the specified frequency limits and copy it to the Center frequency field. When the notch filter dialog is created, the Spur Identification frequency range controls are prefilled with values based on the DC and Nyquist band limits for the selected plot’s phase record, leaving 2% margins at either endpoint. Tone frequencies lying outside this range can be entered manually into the Center frequency field. Alternatively, the From / To fields can be adjusted manually to constrain the spur search within the desired limits.

When working with direct-digital test sets such as the PhaseStation 53100A and TimePod 5330A, line-frequency ripple can be particularly troublesome in ADEV plots captured at these instruments’ default measurement bandwidth of 50 Hz. Since decimation to the specified ENBW occurs prior to phase detection at twice the final sample rate, or 200 Hz, any content at 60 Hz will appear as an alias at 40 Hz in the final 100 Hz phase data record. This frequency, rather than 60 Hz, should be entered in the Center Frequency field in order to suppress
fundamental interference from ground loops in countries that utilize North American power distribution standards.

**If AC line-frequency interference in 50 Hz environments is suspected, consider using the 5 Hz or 500 Hz measurement bandwidths instead.** The former setting will eliminate most AC line interference adequately, while the latter setting will allow it to be removed with the notch filter.

The effect of the notch filter can be reverted with the **Undo last flatten or subtract operation (Ctrl-z)** command.

**Undo last flatten or subtract operation (Ctrl-z)**

This command rolls back the most recent change to the selected plot’s phase record performed by any of the following other commands:

- **Edit→Flatten selected or zoomed phase data (Ctrl-f)**
- **Edit→Subtract global linear phase trend (frequency offset) (Ctrl-o)**
- **Edit→Subtract global linear frequency trend (drift line) (Ctrl-l)**
- **Edit→Subtract quadratic linear frequency trend (drift curve) (Ctrl-q)**
- **Edit→Trace properties (e) (applies to Rescale Phase only)**
- **Edit→Apply notch filter to phase record (Ctrl-n)**

A second “undo” command will redo the last-reverted action.

If the selected plot has any background tasks in progress when this command is issued, an error message will be displayed. Background tasks are those in which the plot’s memory-resident phase record is being accessed by a background thread during initial acquisition, when reloading a saved .TIM file, and when reconstructing the xDEV statistical traces after a previous modification to the phase record.
Trace Menu

The Trace menu contains options that affect the way measurement data is processed and rendered as traces on the graph.

Unlike the Edit menu options, the Trace options apply to all visible traces, rather than only the selected plot, and they never alter the underlying measurement data. Most options on the Trace menu apply only to a given measurement family – xDEV statistics, phase/frequency differences, or phase noise/AM noise measurements. For example, Trace→Averaging window for phase/frequency traces has no effect on phase noise or Allan deviation traces.

The majority of Trace options are simple on/off toggles. In the Measurement→Phase difference (p) display, for instance, applying the Edit→Subtract global linear phase trend (frequency offset) (Ctrl-o) command to each visible trace would have the same visible effect as Trace→Show linear phase/frequency residual (r), as discussed below. But Trace→Show linear phase/frequency residual (r) does not actually subtract the trend from the phase record. Issuing the command again will restore normal trace-rendering behavior.

Phase/frequency traces begin at zero (z)

Show linear phase/frequency residual (r)

These two commands can be used individually or together to maximize visible detail in phase/frequency plots.

When enabled, Trace→Phase/frequency traces begin at zero (z) causes all phase- and frequency-difference traces to be displayed with their first data point pinned to Y=0.0. In unzoomed views – or in zoomed views with Trace→Phase/frequency Y axis unlocked in zoom mode (y) disabled to permit automatic Y-axis scaling – this will force the left end of the trace to the midpoint of the graph’s Y axis. Since autoscaled Y axes in TimeLab are symmetrical about zero, this may allow the trace to occupy more of the visible graph area:

Figure 35: Toggling the zero-baseline view (z)
When used in the **Measurement→Frequency difference (f)** view, the effect of **Trace→Phase/frequency traces begin at zero (z)** is somewhat similar to applying **Edit→Subtract global linear phase trend (frequency offset) (Ctrl-o)** to each visible plot. It’s not *quite* the same, though, because a trace’s first data point is not necessarily anywhere near its trend line. Subtracting the trend will often do a better job at centering individual traces symmetrically about the Y axis, as seen below.

![Figure 36: Linear trend subtracted from the phase data](image1)

Of course, **Edit→Subtract global linear phase trend (frequency offset) (Ctrl-o)** has the drawback of altering the selected plot’s phase data record and removing potentially useful information (namely the phase trendline). Fortunately, there’s also a non-destructive global option that has the same visual effect, **Trace→Show linear phase/frequency residual (r)**:

![Figure 37: Viewing the removed trend without altering the data](image2)

These two commands, **Show linear phase/frequency residual (r)** and **Phase/frequency traces begin at zero (z)**, are among the most commonly-used options on the **Trace** menu. If you spend much time working with phase- and frequency-difference traces, their **r** and **z** keyboard shortcuts will quickly become familiar. **z** can increase visible detail while preserving the graph’s original shape, while **r** is better at revealing short-term noise and other effects that become harder to spot as the graph expands to
accommodate a larger overall trend. Some additional usage examples can be found on page 56.

Note that although only one Phase/frequency traces begin at zero \((z)\) option appears on the Trace menu, Timelab maintains separate copies of the associated preference variable that retain the last change made in each of the respective views.

**Show linear phase/frequency trend (Ctrl-t)**

When enabled, this option causes TimeLab to display a dashed line on unzoomed phase- and frequency-difference traces to indicate the data’s linear trend.

![Figure 38: Viewing the trend line](image)

The trend line is not displayed in magnified views, or when Trace→Show linear phase/frequency residual \((r)\) is enabled.

**Use caution when interpreting drift figures derived from linear or quadratic trends.**

Measurement traces that exhibit a large amount of variance relative to their overall slope – such as might be obtained from comparisons of GPSDO or atomic standards -- can result in numerically unstable solutions that vary randomly based on the number of points in the data record.

**Phase/frequency Y axis unlocked in zoom mode (y)**

By default, the Y axis in phase- and frequency-difference measurement graphs is automatically scaled to accommodate the largest absolute value in all visible traces. The peak magnitude is rounded up to the next decade, half decade, or quarter decade, then mirrored to place zero at center scale. This approach allows the 10-division Y axis to be labeled in “nice” multiples of 1, 2, or 5.

When zooming in with the mouse to magnify a portion of the visible trace(s), it’s sometimes helpful to toggle the Y-autoscaling algorithm off by selecting **Phase/frequency Y axis unlocked in zoom mode (y)**. This will have no effect on an
unzoomed display, but when dragging with the left mouse button to magnify a desired area of the graph, you’ll be able to move in the both X and Y directions, instead of only being able to drag a pair of vertical cursors. When you release the button, the resulting zoomed view will conform to the specified extents in both directions.

With the Y axis unlocked, the `Display→Y zoom in ( )` and `Display→Y zoom out ( )` commands will be usable, and the scroll wheel will expand or contract the magnified region in both directions at once. Dragging with the middle mouse button will scrub the zoomed region in both the X and Y directions.

You can enable Y-axis autoscaling in zoom mode at any time. A quick way to “zoom out” in Y while maintaining the current X position and magnification factor is to tap the \text{y} key twice in succession – once to temporarily re-enable autoscaling, and again to restore 2D navigation with the middle button, scroll wheel, or `{ }` shortcuts.

**Averaging window for phase/frequency traces (g)**

**Increase averaging window (Ctrl +)**

**Decrease averaging window (Ctrl -)**

These commands allow you to specify the length of an *averaging window* up to 10000 seconds in length that will be applied to phase- and frequency-difference traces. The averaging process makes it easier to spot trends and patterns that may be obscured by short-term noise. Setting the window length to its default value of zero selects a hybrid “per-pixel” peak/average detection algorithm (discussed below.)

![Figure 39: Per-pixel and time-based averaging](image)

**Warning:** Averaging introduces time lag which may cause unexpected results with some commands and display options. It’s recommend that averaging be disabled before selecting regions of the phase record for any operations, or when evaluating absolute phase differences or frequency differences. At long averaging times, a substantial baseline offset can exist between the beginning and end of the trace, since there’s less historical data to contribute to the average near the beginning of the record. The trace may appear to “fall off a cliff,” where noisy initial data gives way to a relatively-featureless trace as the averaging process takes effect. This effect is just beginning to appear in the 0.6s-averaged plot above.
As a reminder that averaging is in effect, nonzero averaging times will be displayed in red above phase- and frequency-difference graphs. You can quickly disable averaging with the keyboard sequence g 0 <Enter>.

Averaging also determines how phase records are decimated for display in the phase- and frequency difference views. When rendering a trace whose phase record length in samples exceeds the graph width in pixels, the samples that fall within each graph column must either be peak-detected or combined by averaging. When the averaging window is set to zero seconds, TimeLab effectively does both, using a “per-pixel” algorithm to provide as much information about the skipped phase-record samples as possible. As shown in the first plot above, a shaded vertical line is drawn in each pixel column that connects the minimum and maximum data values that fall within that column. The darker portion of the trace in the middle of the shaded area represents the average of all data points covered by each individual pixel column. Consequently the effective averaging time is not fixed, but is equal to the duration of the visible portion of the trace divided by the width of the graph in pixels.

This algorithm is simple, fast, and effective, but since the peak-detected line segments are drawn in a lighter shade of the trace color, it’s easy to overlook brief glitches that fit within a single pixel column. Consider enabling Trace→Tick marks (k) when looking for outliers in per-pixel mode.

**Draw xDEV traces with spline interpolation (i)**

By default, screenspace points corresponding to the tau bins in Allan deviation and related statistical views are connected with a cubic spline. Spline interpolation results in a smooth, visually-appealing curve, but it can shift data points subtly, distort or exaggerate ringing artifacts, and cause other abrupt transitions in the graph. When Trace→Draw xDEV traces with spline interpolation (i) is toggled off, straight lines are used to connect the xDEV bins (above left).

![Figure 40: Spline interpolation](image-url)
Show xDEV error bars (Ctrl-e)

When enabled, this option draws “error bars” at each tau bin in Allan deviation and other statistical plots. These bars approximate the ± one-sigma (68%) confidence interval at ± σ/√(N/M), where N is the number of phase-record samples that contribute to each bin and M is the bin’s τ₀ multiple.

This calculation does not take either the deviation type or the noise slope into account, so it should be considered a rough estimate of the actual confidence interval obtainable through more sophisticated offline analysis. Consider exporting your phase data to Stable32 (page 76) if your application requires better confidence-interval estimates.

Clip xDEV traces by noise bandwidth (Ctrl-b)

This display option is used to suppress artifacts near the tau-zero points in Allan deviation and other statistical plots that can appear when incoming data is oversampled for lowpass filtering. xDEV values at tau intervals close to the sample rate may appear to “droop” in such cases, since the data has been band-limited at a cutoff frequency below its Nyquist rate.

A discussion of this effect appears on page 46.

Clip xDEV traces by confidence (Ctrl-v)

This display option is used to avoid rendering Allan deviation and other xDEV traces beyond the point where insufficient data is available for good statistical confidence. It is enabled by default.

Specifically, when this option is enabled, the only xDEV bins that are drawn are those whose phase data sample count (N) is ≥ 2x their τ₀ multiple (M).
Show separated xDEV variances (N-cornered hat) (Ctrl-h)

This display option provides an alternative way to view Allan deviation and other statistical traces. Under appropriate conditions, it can reveal aspects of oscillator performance that would otherwise be inaccessible in a conventional measurement with a single reference source.

When the N-cornered hat view is enabled in the N=3 case as shown above, TimeLab will attempt to isolate and display the individual contribution of each of three devices to a set of three stability measurements. Although an in-depth discussion of this technique is outside the scope of this document, Application Note 53100A-2 (Dual-Reference Noise and Stability Measurements with the PhaseStation 53100A) presents a detailed “case study” in which the three-cornered hat methodology is used to provide mutual assessments of high-performance crystal oscillators. Please refer to this application note for more information.

Currently, N values other than 3 are considered investigational, and are not supported. **When viewing three-cornered hat traces, it is strongly recommended that only the three participating measurements are enabled for display.** All other plots should either be cleared with File→Close selected plot (Del) or marked invisible with Display→Toggle visibility of selected plot (v).

To configure the PhaseStation 53100A for three-cornered hat measurements, see the description of the Measure three independent DUTs (three-cornered hat) measurement role on page 128.
Show original traces in N-cornered hat display (F6)
This option can be used to show or hide the original xDEV traces that contribute to an N-cornered hat display, as seen in the example above.

Show correlation gain for selected noise trace (Ctrl-g)
Intended primarily as a diagnostic aid, this option is supported when viewing phase noise or AM noise plots from instruments such as the PhaseStation 53100A that support real-time cross correlation. When enabled, the FFT segments in the selected phase noise or AM noise plot will be color-coded for identification. A table will appear as an overlay in the graph area that displays the number of cross-spectrum averages performed so far in each color-coded segment, along with the theoretical improvement in ADC noise expressed in dB.

The estimated improvement in each segment’s effective noise floor is calculated as $10 \times \log_{10}(\sqrt{N})$ dB, where N is the segment’s number of averages.

Trace smoothing is not performed on the selected noise plot when this option is enabled.

Show FFT segment filter slopes (Ctrl-i)
This option is a diagnostic aid intended for use when editing FFT segment table files for phase noise and AM noise acquisition with the PhaseStation 53100A or TimePod 5330A.

When acquiring noise plots on the PhaseStation 53100A, data for each visible FFT segment undergoes highpass and/or lowpass filtering based on the declarations in the segment table, accessible via the Additional options page in the PhaseStation acquisition dialog. By rendering the entire extent of each segment record, Trace→Show FFT segment filter slopes (Ctrl-i) provides a visual display of the filter skirts for each segment, as well as the overlap between them. In this mode, you can temporarily hide the skirts by holding the Shift key.

For detailed information about the segment table’s format and contents, refer to the comments within the default segment table file. This file can be accessed by pressing the Additional options button in the PhaseStation acquisition dialog, followed by Edit segments.

Most users will not need to edit the segment table.
Show imaginary part of cross spectrum (Ctrl-F3)

Show estimated instrument noise (F2)

Phase noise and AM noise plots acquired with the PhaseStation 53100A, TimePod 5330A, and Symmetricom 512X analyzers can be displayed with a shaded area that provides an estimate of the instrument noise floor, if you enable Trace → Show estimated instrument noise (F2).

In the 53100A’s case, the floor estimate is simply a heavily-smoothed rendition of the imaginary portion of the cross-spectrum average shown by the Show imaginary part of cross spectrum (Ctrl-F3) command. For more information about the imaginary cross spectrum and the Ctrl-F3 command in particular, see “Understanding instrument spurs” on page 67.

Use caution when relying on the noise-floor estimate. While reasonably accurate, it may appear artificially high in the vicinity of instrument spurs. Conversely, certain effects can raise the real measurement floor slightly above the shaded floor estimate. As with ADEV measurements, the best way to obtain “proof of performance” for analyzers in this class is to run residual tests at similar frequencies and signal levels.

Particularly when viewing multiple traces in Display → Overlay (o) mode, it may be preferable to leave the floor display turned off in order to reduce display clutter.

Note that when Show imaginary part of cross spectrum (Ctrl-F3) is active, the File → Export ASCII AM/PM noise trace command will export the imaginary cross spectrum trace data rather than the normal AM noise or phase noise trace.
Mark spurs in noise traces (Ctrl-m)

Suppress spurs in noise traces (Ctrl-s)
For a detailed discussion of these commands and other aspects of spur detection and rendering in phase noise and AM noise plots, see page 64.

Smooth noise traces (Ctrl-w)

![Figure 44: Trace smoothing](image)
This command applies some light exponential smoothing to traces in the phase noise and AM noise measurement views. Detected spurs are always removed from smoothed traces. If enabled, smoothing is turned off automatically when the Trace→Suppress spurs in noise traces (Ctrl-s) command is used to toggle spur attenuation.

To obtain a smoother trace with cross-correlating analyzers such as the PhaseStation 53100A, TimePod 5330A and Symmetricom 512x models, it’s often better to let the measurement run longer. As the trace converges on the true noise level its variance will diminish, resulting in a more accurate measurement with less visible “grass.”

Show raw noise trace(s) (Ctrl-r)
This command displays the raw phase noise or AM noise spectrum from the ADCs in both measurement channels of the PhaseStation 53100A and TimePod 5330A.

![Figure 45: Viewing the raw ADC noise traces](image)
Note that while the **Trace** menu option shows the raw ADC data traces alongside the actual measurement traces, the **Ctrl-r** keyboard shortcut cycles between measurement-only, measurement+raw, and raw-only displays.

Although intended primarily for instrument diagnostic purposes, the appearance of the raw trace can sometimes be helpful in tracking down intermittent problems in the DUT or reference source associated with one of the two channel pairs. The darker trace corresponds to the first DUT/noise reference channel pair, while the lighter trace corresponds to the second pair of inputs.

**Show AM noise in PN view (F8)**

![Figure 46: Overlaying the AM and PM noise traces](image)

When enabled, this command renders a copy of the AM noise trace in the **Measurement→Phase noise (P)** view, using a lighter color or trace weight. Both PM and AM spur tables are displayed, space permitting.
**Tick marks (k)**

This command toggles tick marks on and off, as shown below.

![Fig 47: Tick marks](image)

Tick marks are supported in most trace types and display modes. They can be especially handy when examining phase/frequency difference plots. In cases where many data points contribute to a single pixel column in the graph and no explicit averaging time has been specified, TimeLab’s “per-pixel” renderer displays the average of all of each pixel column’s contributing points, while the maximum and minimum points that fall within each pixel column are rendered in a lighter shade of the same color. The k command can help you spot brief glitches and frequency jumps in these plots that would otherwise go unnoticed.

**Toggle trace thickness for current measurement (T)**

![Fig 48: Trace thickness options](image)

This command switches between heavy and light traces in the currently-active measurement view. TimeLab keeps track of the requested trace thickness for each Measurement menu entry.

In N-cornered hat displays, the trace thickness property controls the appearance of the original xDEV traces that contribute to the solution. Heavy traces are rendered with thin lines in this case, while light traces are rendered with broken lines.
Display Menu

Display-related options that aren’t measurement-specific appear on the Display menu. Controls on this menu determine the visibility and selection status of loaded plots, the order in which plots appear in the legend table below the graph, and the choice of Display→Overlay (o) or Display→Browse (b) mode that determines whether all loaded plots are displayed or only the selected plot.

Color, contrast, font size, and graph-magnification options also appear on the Display menu, along with a choice of formats for the “mouseover” information at the upper left corner of the graticule.

Edit colors

This command leads to a second-level menu offering a choice of various graphical elements in the TimeLab window, from font and trace colors to table borders and backgrounds. Once an element is chosen, a standard Windows color palette dialog appears. As you click on the palette areas to change the selected color, the TimeLab window is updated in real time, making the color-selection process interactive and easy to use.

Restore default colors

This command restores the default color palette without resetting any other preferences or control states.

High contrast (C)

This command toggles the display between normal and high-contrast rendering. The latter option may be desirable when saving screenshots for publications or Web pages whose color fidelity may not be sufficient to reveal details in the plot such as minor graticule lines.
**Numeric table (Ctrl-n)**

The *numeric table* appears to the right of the graph area in each measurement view, unless toggled off with this command. The format of the table is different for each measurement type. In the Allan deviation and other statistical views, a chart displays the sigma(tau) values at assorted tau intervals. In the Measurement→Frequency difference (*f*) view, both drift/trend statistics and a high-precision frequency-count chart are displayed, while only the former is available in the Measurement→Phase difference (*p*) view. Finally, tables of user-defined noise markers and detected spurs are displayed in the phase noise and AM noise views.

**Clear noise markers (F3)**

This command clears the list of user-defined noise markers, removing it from phase noise and AM noise plots. To add a new noise marker, simply Shift-left click near the desired column on either the phase noise or AM noise plot.

**Show cursor time (Ss)**

**Show cursor time (Hh:Mm:Ss)**

**Show cursor time/datestamp**

**Do not show cursor values**

These options determine the content of the “mouseover” cursor readout display in the Measurement→Phase difference (*p*) and Measurement→Frequency difference (*f*) views. When the mouse cursor is within the graph area in these views, the readout at upper left displays the time and Y-axis value corresponding to its position. You can choose to display the number of seconds relative to the beginning of the phase record (*Ss*), the same elapsed time value in *Hh:Mm:Ss* format, or the absolute *time/datestamp* when the data at the mouse cursor location was logged.

Note that Display→Do not show cursor values turns off the cursor readout in *all* views. To re-enable the cursor readout in the xDEV and noise displays, select any of the other three options.

The mouse cursor readout is not rendered when saving image files or capturing images with File→Copy image to clipboard (Ctrl-c).
Browse plots one at a time (b)

Overlay all loaded plots (o)

Toggle visibility of selected plot (v)

Since TimeLab allows up to nine plots to be loaded and displayed at once, these three commands are needed to maintain a legible display. They are often used together in rapid succession, so they will be described together and referenced in abbreviated form.

Simply stated, in browse mode only the selected plot is rendered. In overlay mode, all loaded plots that haven’t had their visibility toggled off are rendered, with the graph scale adjusted as necessary to accommodate them.

It’s common to switch between browse and overlay mode when inspecting and comparing several plots, as the display can become rather crowded. At the same time, the visibility command is often needed when you want to view a subset of plots in overlay mode. browse mode will exclude all but the selected plot from the display, while the visibility toggle gives you the control needed to display some, all, or none of the loaded plots in overlay mode. If you want to look at several overlaid plots while temporarily hiding one or two of them, the visibility toggle is the answer.

Select next plot in chart (+ or down arrow)

Select previous plot in chart (- or up arrow)

Move selected plot up (Ctrl-up arrow)

Move selected plot down (Ctrl-down arrow)

For an introduction to the “selected plot” concept and its related commands, refer to “Making your first measurements” on page 29.

The Ctrl-up/down arrow commands can be very helpful for organizing displays with multiple plots. Holding down the Ctrl key when you press an arrow key will not change the currently selected plot, but will instead move the selected plot up and down in the legend table. Since the trace colors in TimeLab are assigned based on each plot’s position in the legend table, this feature can be useful if you don’t like the color of a particular plot, or if a plot farther down the table is obscuring data in an earlier plot. (The Ctrl-up/down arrow commands are frequently handy when using Trace→Show estimated instrument noise (F2), for instance.)
X zoom in ( )

X zoom out ( ]

Y zoom in ( )

Y zoom out ( ]

The bracket and shift-bracket keys are useful for navigating zoomed phase- and frequency-difference traces on a laptop or other PC without a three-button scrolling mouse. These menu options can be thought of as placeholders for their respective keyboard shortcuts. Specifically, after a zoomed region has been selected by dragging with the left mouse button, these commands allow you to increase and decrease the “magnification factor” without returning to the unzoomed display.

On a desktop PC, a combination of scroll-wheel and middle-button input is normally the best way to navigate within phase/frequency traces. The scroll wheel expands and shrinks the magnification factor, while the middle mouse button allows you to “scrub” the zoomed trace data left and right.

These commands have no effect in zoomed phase noise or AM noise measurement views, or in Allan deviation or other statistical views. For more about TimeLab’s zoom functionality, refer to “Navigating zoomed graphs” on page 57.

Decrease font size ( ( or Ctrl-mouse wheel )

Increase font size ( ) or Ctrl-mouse wheel )

Like the X zoom/Y zoom commands, the font-size control options are primarily meant as placeholders for their respective “hotkeys,” the left and right parentheses. They provide easy access to a choice of several discrete font sizes. Also, as with most Web browsers and other newer Windows applications, scrolling with the mouse wheel while holding down the Ctrl key will expand or shrink the text within TimeLab’s display window.

Refresh deviation traces ( F5 )

This command triggers a recalculation of the bin contents and graph extents for Allan deviation and related log-log statistical plots.

If a trace-refresh or data acquisition operation is already in progress at the time the command is issued, only the graph extents are recomputed.
Legend Menu

The Legend menu contains only one command, Legend→Select (d). This command opens a dialog box in which you can choose which attributes are displayed for each visible plot in the legend table beneath the main graph. Some properties are flagged for display in the legend table by default, while others will not be displayed until you select them explicitly.

Each TimeLab acquisition driver can contribute its own entries to the Legend→Select dialog based on the property values in the plots that it generates. When a plot is acquired or loaded from a .TIM file, TimeLab checks for the presence of any displayable properties that it hasn’t yet encountered. Any unfamiliar properties are logged in TIMELAB.INI and added to the selection menu.

As a result, the content of the Legend→Select menu may vary from one TimeLab installation to the next. (Note that after you select a property for display in the legend table, its value will be blank for all plots that don’t include that particular property.)

As with other data stored in TIMELAB.INI, reinstalling TimeLab does not erase the list of known Legend→Select menu entries. These entries can be cleared only by manually editing or deleting TIMELAB.INI, or by using File→Reset all parameters, options, and settings at next startup. Refer to the latter command for more information about TIMELAB.INI.

The list of currently-defined .TIM file properties appears below. Many of these options are ‘private’ to a specific hardware driver and are not eligible for display on the legend table. They are listed here for reference only. A few of the properties are defined by TimeLab itself and will appear on the Legend→Select menu by default in all installations.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acquired</td>
<td>Number of acquired phase data points used for stability and deviation plots</td>
</tr>
<tr>
<td>Act as Server</td>
<td>True if TimeLab has been configured to repeat incoming data via TCP/IP</td>
</tr>
<tr>
<td>ADC Clock</td>
<td>Specified, estimated, or measured acquisition clock rate in Hz</td>
</tr>
<tr>
<td>ADC Format</td>
<td>Data format used by ADCs</td>
</tr>
<tr>
<td>ADC Temperatures</td>
<td>Average ADC temperature with individual deviations</td>
</tr>
<tr>
<td>ADC Time</td>
<td>Optional user-specified gain value added to AM noise traces</td>
</tr>
<tr>
<td>Address</td>
<td>Optional user-specified gain value added to phase noise traces</td>
</tr>
<tr>
<td>Add'l AM Gain</td>
<td>Address of instrument used to acquire data</td>
</tr>
<tr>
<td>Add'l PN Gain</td>
<td>True if instrument spurs are suppressed automatically</td>
</tr>
<tr>
<td>Address</td>
<td>True if the clock frequency was determined automatically</td>
</tr>
<tr>
<td>Act as Server</td>
<td>True if the DUT frequency matches the frequency at the instrument input jack</td>
</tr>
<tr>
<td>Attenuate Instrument Spurs</td>
<td>True if the DUT frequency was measured automatically</td>
</tr>
<tr>
<td>Address</td>
<td>True if the reference frequency was measured automatically</td>
</tr>
<tr>
<td>Auto Clock</td>
<td>True if the TimeLab driver should infer various measurement parameters based on the incoming data</td>
</tr>
<tr>
<td>Auto Ref</td>
<td>True if the TimeLab driver should automatically measure the sample interval</td>
</tr>
<tr>
<td>Auto Input</td>
<td>Amplitude in dBm of calibration beatnote</td>
</tr>
<tr>
<td>Auto Input</td>
<td>Determines the number and distribution of tau intervals in statistical deviation measurements</td>
</tr>
<tr>
<td>Bin Threshold</td>
<td>Minimum number of data points required to display the statistical deviation at a given tau</td>
</tr>
<tr>
<td>Bin Index</td>
<td>Index or other identifier for a given measurement bandwidth</td>
</tr>
<tr>
<td>Cancel CM Drift</td>
<td>True if common-mode drift (e.g., due to ADC clock warmup) is corrected in software</td>
</tr>
<tr>
<td>Ch 0 Auto</td>
<td>Specified input frequency for channel 0</td>
</tr>
<tr>
<td>Ch 0 Freq</td>
<td>True if Ch 0 frequency should be measured automatically</td>
</tr>
<tr>
<td>Ch 0 Freq Mode</td>
<td>Specified input frequency for channel 0</td>
</tr>
<tr>
<td>Ch 0 Label</td>
<td>True if Ch 0 frequency should be measured automatically</td>
</tr>
<tr>
<td>Ch 0 Enabled</td>
<td>User-assignable label for source connected to instrument channel 0</td>
</tr>
<tr>
<td>Ch 1 Auto</td>
<td>Enabled/disabled status for channel 1</td>
</tr>
<tr>
<td>Ch 1 Enabled</td>
<td>True if Ch 1 frequency should be measured automatically</td>
</tr>
<tr>
<td>Ch 1 Freq</td>
<td>User-assignable label for source connected to instrument channel 1</td>
</tr>
<tr>
<td>Ch 1 Freq Mode</td>
<td>Specified input frequency for channel 1</td>
</tr>
<tr>
<td>Ch 1 Label</td>
<td>User-assignable label for source connected to instrument channel 1</td>
</tr>
<tr>
<td>Ch 1 Noise Ref</td>
<td>True if Ch 1 frequency should be measured automatically</td>
</tr>
<tr>
<td>Ch 1 Rounding</td>
<td>Reference for DUT channel 1 (Noise)</td>
</tr>
<tr>
<td>Ch 1 Specified Frequency</td>
<td>Reference for DUT channel 1 (Stability)</td>
</tr>
<tr>
<td>Ch 1 Stability Ref</td>
<td>Input frequency specification parameter for channel 1</td>
</tr>
<tr>
<td>Ch 1 Type</td>
<td>Input type for channel 1</td>
</tr>
<tr>
<td>Ch 2 Auto</td>
<td>True if Ch 2 frequency should be measured automatically</td>
</tr>
<tr>
<td>Ch 2 Enabled</td>
<td>Enabled/disabled status for channel 2</td>
</tr>
<tr>
<td>Ch 2 Freq</td>
<td>Specified input frequency for channel 2</td>
</tr>
</tbody>
</table>
Measures FM Noise

Measure Stability

Multi-channel Input dBm

Multi-channel Input Estimation

Multi-channel Input Hz

Multi-channel Input Precision

Multi-channel Ref dBm

Multi-channel Ref Estimation

Multi-channel Ref Hz

Multi-channel Ref Precision

Narrow Band Mode

New T0

New Data

Optional Filters

Options

Output Declination

Output Sample Rate

Overlap %

Overlapped

Pathname

Phase

Phase Record

Phase PN to DUT

Phase Jitter to DUT

Precision

Prologix Compatibility Mode

Property Page

Query Instrument ID

Read Existing Data

Ref Amplitude

Ref Ch

Ref Estimated

Ref Freq

Ref Precision

Remaining

Rescale Factor

Residual FM

Rev

RMS Integrated Noise (Degr)

RMS Integrated Noise (Rads)

RMS Time Jitter

Role

Sample Interval

Sample Rate

Scale Factor

Scale Jitter to DUT

Scale FN to DUT

Segment Table

Setup String

Source A

Source B

Specified Input Frequency

Specified Reference Frequency

Spot Cursor

Spur Min Hz

Spur Threshold

SSB Carrier/Noise

Stability Ch

Stability Channel Count

Stability Channel ID

Stop Condition

Syx Estimator

Syx Estimator #

Time/Date

True if measurement contains phase noise data

True if measurement contains phase/frequency stability data

Modified Julian date when the measurement was triggered

Approximate input amplitude in dBm for each channel in a multichannel measurement

True for input channels whose frequencies are low-precision estimates that should be rounded for display purposes

DUT input frequency in Hz for each channel in a multichannel measurement

Round input frequencies in each measurement channel to the specified # of digits to the right of the decimal point

Approximate reference amplitude in dBm for each channel in a multichannel measurement

True for reference channels whose frequencies are low-precision estimates that should be rounded for display purposes

Reference frequency in Hz for each channel in a multichannel measurement

Round reference input frequencies in each measurement channel to the specified # of digits to the right of the decimal point

Narrow acquisition bandwidth option

Most recent tau-zero interval specified for reassembled phase data

Additional notes that apply to a measurement, as specified at acquisition time or edited with Edit->Trace Properties

Frequency readings to Hz

Numeric scale factor used to convert acquired data, e.g., TI readings to seconds or display purposes

Maximum offset for SSB noise graph (which will be rounded up to the nearest decade)

Minimum offset for SSB noise graph (which will be rounded down to the nearest decade)

IP port of instrument used to acquire data

Configuration string for RS-232 COM port or other interface, if required

Precision of incoming floating-point data (e.g., , double)

True if serial ports with FTDI D2XX drivers should be treated as Prologix GPIB-USB adapters

Selected property page number

True if TimeLab should request the instrument's ID string

Index or other identifier for a given sample interval (device-specific)

True if any existing text from the file or device should be skipped prior to acquiring new data

Approximate reference amplitude in dBm

Physical channel(s) acting as reference

True if the reference frequency is a low-precision estimate that should be rounded for display purposes

Frequency of signal applied to primary reference input jack, often rounded for display purposes

Round reference input frequencies to the specified # of digits to the right of the decimal point

Remaining time in the current measurement or measurement stage

Most recent user-supplied rescale factor for phase data

Detailed information available for plots acquired with certain instruments, including firmware version and/or options

Displays blue vertical cursors in the phase noise graph which can be moved by left/right-clicking with Control held down. The residual FM between these limits of integration will be displayed in units of Hz.

Displays blue vertical cursors in the phase noise graph which can be moved by left/right-clicking with Control held down. RMS jitter between these limits of integration will be displayed in degrees.

Displays blue vertical cursors in the phase noise graph which can be moved by left/right-clicking with Control held down. RMS jitter between these limits of integration will be displayed in radians.

Displays blue vertical cursors in the phase noise graph which can be moved by left/right-clicking with Control held down. RMS jitter between these limits of integration will be displayed in units of seconds.

Selected instrument configuration for a given measurement role

Time in seconds between successive data points

Incoming raw data rate from instrument in samples per second, where applicable

Numeric scale factor used to convert acquired data, e.g., TI readings to seconds or frequency readings to Hz

True if jitter and carrier/noise values should be based on the DUT frequency rather than the input frequency

True if phase noise values should be increased by 20 * log10 (DUT frequency / input frequency)

User-specified tag field from segment table used for noise acquisition

ASCII text string(s) transmitted to device prior to acquisition

User-assignable label for first variance source in stability measurement

User-assignable label for second variance source in stability measurement

Exact input frequency in Hz provided by user

Exact reference frequency in Hz provided by user

Displays a red vertical cursor in the graph window which can be moved by left-clicking.

The value at the selected column will be displayed in the legend table.

Minimum offset frequency at which spurs will be marked for reporting or removal

Minimum amplitude relative to average nearby trace amplitude at which a discrete spectral line will be recognized as a spur

Number of concurrent stability measurements associated with acquisition

Field # or name used to identify channel in incoming data

Estimator function used to render cross-spectrum FFT bins on log plots

Index or other identifier for cross-spectrum estimator function

Time and date when the acquisition was initiated
| Parameter                  | Description
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Timestamp</td>
<td>Incoming data consists of absolute timestamps in seconds</td>
</tr>
<tr>
<td>Trace</td>
<td>Trace caption text, as specified at acquisition time or edited with Edit-&gt;Trace Properties</td>
</tr>
<tr>
<td>Trace History</td>
<td>Number of historical deviation traces displayed. More recent traces appear darker.</td>
</tr>
<tr>
<td>Trace Window</td>
<td>Number of phase data points per historical deviation trace. This will equal the phase record size when Trace History is set to 1.</td>
</tr>
<tr>
<td>TSC Phase Data Rate</td>
<td>Phase data rate from TSC 512X-compatible timing analyzer</td>
</tr>
<tr>
<td>Unwrapped</td>
<td>True if phase data has been unwrapped by the instrument driver</td>
</tr>
<tr>
<td>Unwrapped Phase</td>
<td>Incoming data consists of monotonic phase-difference values that do not contain phase wraps</td>
</tr>
<tr>
<td>USB Version</td>
<td>USB firmware version</td>
</tr>
<tr>
<td>Use Input Rate</td>
<td>True if driver's data rate matches the incoming data rate from the instrument</td>
</tr>
<tr>
<td>Use Internal Clock Generator</td>
<td>True if internal clock generator should be enabled</td>
</tr>
<tr>
<td>User-Assigned Command</td>
<td>User-assignable command string</td>
</tr>
<tr>
<td>Warnings Treated as Errors</td>
<td>True if warnings during data acquisition should terminate the measurement</td>
</tr>
<tr>
<td>Wrap Period</td>
<td>Wraparound period in seconds for incoming timestamps</td>
</tr>
</tbody>
</table>
**Measurement Menu**

The **Measurement** menu selection determines how TimeLab displays the data in any plots that have been acquired or loaded. One measurement type may be selected at a time.

As discussed on page 34, TimeLab plots (and their associated .TIM files) use independent data records for different measurement classes. Some instruments like the TimePod 5330A and PhaseStation 53100A can acquire data for all measurements supported by TimeLab, but most are limited to specific measurement types. For instance, acquisitions made with a frequency counter or TIC may be viewed with the Allan deviation (a), Modified Allan deviation (m), Hadamard deviation (h), Time deviation (t), Phase difference (p), or Frequency difference (f) selections on the menu, but not Phase noise (P) or AM noise (A).

Regardless of the instrument used, all supported measurement records are acquired and processed simultaneously by TimeLab. After launching a PhaseStation 53100A acquisition with all of the available measurements selected in the acquisition dialog, for example, you can switch between all of the entries in the **Measurements** menu to view your data as it arrives.

Plots that don’t include the necessary data for the selected measurement type will not be rendered. When the TimeLab window is empty despite the presence of one or more loaded or acquired plots, a brief explanatory message will be displayed in the color associated with each plot to indicate why nothing is being drawn.

See “Making Measurements” on page 39 for more information on the measurement types supported by TimeLab.
Masks Menu

The Masks menu is almost entirely user-configurable. It consists of a list of mask definitions for optional use in TimeLab. Masks are useful in production test applications where fast, reliable, and repeatable pass/fail judgments are required. You can also use mask testing for proof-of-performance verification of the PhaseStation and other instruments supported by TimeLab.

At startup, Timelab constructs the Masks menu based on the contents of the user-editable file masks.txt. The folder’s location will vary from one Windows version to the next. For example, in a typical Windows 7 installation on drive C: it can be found at C:\Users\Public\Documents\TimeLab\Masks at the command prompt, or Libraries→Public Documents→TimeLab→Masks in Explorer.

Generally, the easiest way to read and modify masks.txt is by selecting the last entry on the Masks menu, Mask→Edit mask definitions. This option will open masks.txt in Windows Notepad. You can then create your own mask definitions, edit existing masks, remove masks from the menu, or simply review the mask-testing features and capabilities in the current version of TimeLab.

**Important**: To preserve any user-created mask definitions, your existing masks.txt file will not be overwritten when a new copy of TimeLab is installed. The only exceptions to this rule occur when new features are introduced that render the mask file format incompatible with newer versions of TimeLab. In such cases, the TimeLab setup program will make a backup copy of masks.txt in the same directory, under the name masks_backup.txt. Keep in mind that you will then need to transfer any user-created mask definitions from masks_backup.txt to the new masks.txt file.

This also means that updated or newly-defined masks included with later versions of TimeLab will not automatically appear in the Masks menu. Consequently, you’ll need to open the default_masks.txt file in the same directory and copy/paste any desired entries into masks.txt to take advantage of new default mask definitions.

Clear mask selection

The first command on the Masks menu simply deselects any currently-selected mask, removing its limit line(s) from the applicable measurement views.

User-defined mask entries

Menu entries appearing between Mask→Edit mask definitions and Mask→Edit mask definitions are defined in masks.txt. Only one mask may be selected at a time. Once selected, the mask’s title and limit line will be visible only in measurement views corresponding to valid limit lines in the mask definition.
To see the results of the selected mask test, you’ll need to select one of these views from the **Measurement** menu *and* enable **Legend→Mask Result, Legend→Mask Margin**, or both. Pass/fail results and margins will then appear in the legend table below the graph, updated in real time as the measurement progresses.

For detailed instructions and hints, carefully review the comments in **masks.txt**. The latest usage guidelines for the current TimeLab release will appear as comments in this file.

**Edit mask definitions . . .**

As noted above, the last command on the **Masks** menu opens **masks.txt** in Notepad for editing and review.

---

**Figure 52: Mask test with automatic pass/fail evaluation**
**Scripts Menu**

TimeLab includes an embedded JavaScript engine\(^\text{12}\) that can run automated test scripts using the PhaseStation 53100A and TimePod 5330A. (Script-based access to other instruments such as time-interval counters is not currently supported.) Numerous API functions are provided to support a variety of applications, ranging from performance verification procedures included with TimeLab to user-developed test scripts. The **Scripts** menu helps you edit, run, and otherwise manage your collection of test scripts.

**Creating a new test script**

The easiest way to create a new test script is to set up your measurement in the PhaseStation acquisition dialog just as you normally would. Then, rather than selecting **Start measurement**, click the **Save script** button. The Windows file dialog that appears will prompt you to save the current set of measurement parameters to a JavaScript (.js) file. When executed later with **Scripts→Run script**, the script will launch a measurement with the same acquisition parameters and options.

As an alternative, you can use **Scripts→Edit script** to create modified copies of the scripts that are included with TimeLab, such as **53100A_performance_test.js** and **5330A_ADC_test.js**. These programs are more elaborate than the elementary scripts created by **Save script**, but they were all originally created through that function. They exercise virtually all of the capabilities of the TimeLab script API as well as those of the instrument itself.

The script folder’s location will vary from one Windows version to the next. For example, in a typical Windows 7 installation on drive C: it can be found at **C:\Users\Public\Documents\TimeLab\Scripts** at the command prompt, or **Libraries→Public Documents→TimeLab→Scripts** in Explorer.

For a detailed listing of script API functions, refer to the JavaScript API Function Reference section on page 135.

---

\(^{12}\) [https://v8.dev](https://v8.dev)
Run script ...
To launch a test script, select Scripts→Run script . . . and choose the desired script’s JavaScript file (.js) in the file dialog that appears. TimeLab will load the script into memory and execute its “global scope” to initialize any variables declared outside of functions or event handlers. Control then passes to the script’s mandatory EventRunScript() function.

Once launched, the script will continue to run until one of the following conditions is true:

- A script exception or other fatal error occurs
- The ScriptEnd() API function is called by the script prior to returning from an event handler
- The script returns from an event handler function such as EventRunScript() or EventAcqDone() with no plots associated with it, either because the user closed the plot(s) manually or because the event handler did not launch any acquisitions. (However, if the script has requested timer service with TimeSetTimer(), it will be allowed to continue running.)
- The Scripts→Stop all running scripts (F12) command is issued by the user
- The user exits from TimeLab

Any errors encountered during either loading or execution will be reported in the status line at the bottom of the TimeLab window.

Edit script ...
This command simply launches an instance of Notepad on the specified .js file, allowing you to read, modify, and/or copy the script.

Delete script ...
To delete a test script, select Scripts→Delete script . . . and specify the .js file to delete. The .js file will be deleted without further prompting.

Run last-executed script (Shift-Space)
Using Shift-Space to re-run the most recently executed script is analogous to pressing the Space bar by itself to bring up the most recently-used acquisition dialog. The script will be relaunched without further prompting from TimeLab.
**Toggle script console for selected plot (F11)**

When a measurement is started under script control, TimeLab will display an overlay containing any error or status messages issued by the script. This console overlay is shown by default whenever the measurement is otherwise visible on the graph.

As the script console overlay tends to obscure the data being plotted, the F11 key provides a convenient way to hide or show the overlay for the currently-selected plot.

**Stop all running scripts (F12)**

Stops any scripts that are currently running, as well as any measurements associated with those script(s).
Acquire Menu

TimeLab’s principal mission is to serve as the user interface for the PhaseStation™ 53100A Phase Noise Test Set from Jackson Labs Technologies, but support for many other instruments is also provided. The Acquire menu includes a list of all instruments currently recognized by TimeLab, followed by a small number of commands that manage acquisition operations.

When selected, each entry on the Acquire menu that corresponds to a given instrument will bring up an acquisition dialog. Acquisition dialogs are used to configure the instrument and initiate data collection. Every acquisition in TimeLab runs in its own thread, so you can load or acquire other plots while data collection is in progress. Acquired data can be saved at any time, even during the measurement; likewise, all options on the Trace and Display menus apply equally to existing plots and those that are currently being acquired.

While acquisition dialogs are straightforward to work with, their layout and functionality varies greatly from one instrument to the next. Each dialog displays extensive help text that’s refreshed as the mouse pointer enters each field. This “mouseover” text is the principal source of hardware-specific documentation in TimeLab, since it’s always up to date with the latest changes made to each hardware driver. It should be read carefully when using a given instrument or dialog option for the first time.

Jackson Labs PhaseStation

The PhaseStation 53100A uses real-time direct sampling techniques from the Software-Defined Radio (SDR) field to measure frequency stability, phase noise, and AM noise at levels substantially beyond the reach of traditional counters and timing analyzers. Depending on the measurement options selected in the PhaseStation acquisition dialog, the 53100A can perform any (or all) measurements supported by TimeLab.

The dialog fields used to select and configure the PhaseStation’s supported measurement roles are discussed separately in their own appendix on page 125, PhaseStation 53100A Measurement Roles.

Miles Design TimePod

The TimePod 5330A has been replaced by the PhaseStation 53100A, but continues to be fully supported by TimeLab. It offers similar performance capabilities at a limited range of carrier and offset frequencies, and provides a subset of the PhaseStation’s connectivity and configuration options.

Acquire from counter in Talk-Only mode

This option allows you to acquire frequency, phase/TI, or timestamp readings from almost any GPIB- or RS232-connected counter that supports a “Talk Only” mode, in which ASCII readings are emitted autonomously with no interaction from a host controller. RS232-based timing analyzers such as the picPET are also supported by the Talk-Only option.
TimeLab supports GPIB connectivity through adapters from National Instruments or Prologix, including Agilent/Keysight GPIB adapters with NI488.2 compatibility enabled.

**Acquire from live ASCII file**
Similar to the Talk-Only acquisition option described above, this option allows you to specify the location of a text file containing frequency, phase/TI, or timestamp data that’s being written by another process. TimeLab will open the file in read-only mode, process all existing data in the file if requested, and then continue to fetch data until the acquisition terminates. Only one reading per line is processed, but any numeric field within the line can be specified for processing.

**HP 53131A/53132A/53181A and 53220A/53230A**

**HP 5335A and 5370A/B**

**HP 5371A/5372A**

**Philips/Fluke PM6680**

**Picotest/Array U6200A series**

**Stanford Research SR620**

**Wavecrest DTS-2050/2070 series**
These instruments are high-performance counters and timing analyzers whose acquisition capabilities are very similar from TimeLab's perspective. Frequency and phase-difference (TI) readings are supported by each. Depending on the instrument’s I/O capabilities, available connectivity options may include the following:

- National Instruments NI488.2-compatible GPIB adapters
- Serial (COM) ports connected directly to the instrument
- Serial (COM) ports associated with Prologix GPIB-USB adapters
- IP addresses supported with Prologix GPIB-ETHERNET adapters
- Direct connections to TCP/IP-based instruments at the specified address

HP counters with serial interfaces connected via null-modem cables should use **Acquire→Acquire from counter in Talk-Only mode** instead.
Symmetricom 5115A / 5120A / 5125A (Frequency stability)

Symmetricom 5115A / 5120A / 5125A (Phase noise)

These digital phase noise analyzers provide advanced features and specifications similar to the TimePod and PhaseStation instruments. However, separate options in the Acquisition menu must be used to obtain data for xDEV and phase/frequency-difference plots and the Fourier spectrum used for phase noise plots. Phase/frequency data will be acquired continuously for the duration of the measurement, while phase noise acquisition will retrieve a snapshot of the analyzer’s current phase noise trace, noise-floor estimate, and spur table.

As with other TimeLab acquisition processes, these acquisitions may be launched concurrently.

Note that the earliest versions of these test sets were developed and marketed by Timing Solutions Corporation, so they are often referred to as the “TSC 512x” family of instruments.” Later instruments were produced with Symmetricom and Microsemi branding. The TimeLab drivers support all of these variations under the Symmetricom nomenclature.

Stop/repeat acquisition (Space)

This context-sensitive command associates the most common acquisition “verbs” with a single easy-to-remember keyboard shortcut.

- If deferred-acquisition mode is active and at least one acquisition is pending, the Space bar terminates all active acquisitions (after prompting).
- Otherwise, if the selected plot is associated with an acquisition in progress, the Space bar will terminate that acquisition (after prompting).
- If one or more acquisitions is running but the selected plot is not among them, the Space bar will offer to terminate the acquisition that was most recently started.
- If no acquisitions were running, the Space bar will bring up the most-recently-used acquisition dialog.

Because TimeLab measurement sessions often involve repeated acquisitions with the same instrument, the Space bar shortcut will usually “do what you mean.” It will either stop collecting data if an acquisition is in progress, or start a new acquisition if data is not currently being acquired.
Abort and retrigger selected acquisition (Ctrl-a)

Keep and retrigger selected acquisition (Ctrl-k)

Like Acquire→Stop/repeat acquisition (Space), these commands are normally accessed via their respective keyboard shortcuts. Often used when you accidentally disturb the equipment or remember an omitted step in the measurement procedure, Ctrl-a will restart the selected plot’s measurement immediately with no further interaction. Ctrl-k behaves similarly, but it will not discard the acquired data before relaunching the acquisition.

These commands operate as follows:

- If no plots are loaded, either command will bring back the most-recently-used acquisition dialog, as if the Space bar shortcut were used.

- Otherwise, if the selected plot is associated with an acquisition in progress, that acquisition will be terminated. (Any other acquisitions in progress will not be affected.)

- If the Abort (Ctrl-a) command was issued, the selected plot will be closed and its data discarded. A new acquisition will be started in its place, using the driver associated with the now-deleted plot. The new plot will retain the same position in the legend table.

- If the Keep (Ctrl-k) command was issued, the selected plot will not be closed. A new acquisition will be launched with its instrument driver. The resulting plot will appear in the next available slot in the legend table.

When applied to an acquisition in progress, both commands work immediately without prompting for confirmation if File→Warn before retriggering measurement in progress is unchecked. They're assigned to control keys to make them harder to press accidentally.
**Enable deferred acquisition** (Ctrl-d)

**Trigger deferred acquisition(s) (Enter)**

Deferred acquisition mode is toggled with the *Enable deferred acquisition (Ctrl-d)* command. In this mode, TimeLab will allow acquisitions to be launched as usual. However, each new measurement’s incoming data will be discarded until all pending measurements are triggered. In deferred-acquisition mode, triggering occurs at the expiration of a specified time interval, when the *Trigger deferred acquisition(s) (Enter)* command is issued, or when another *Enable deferred acquisition (Ctrl-d)* command is issued to return to immediate-acquisition mode. Data will subsequently be collected normally for the duration of the measurement(s).

Deferred-acquisition mode can be useful when you wish to launch multiple concurrent acquisitions – perhaps using different types of instruments with varying latency or setup time requirements – while synchronizing the beginning of data collection as closely as possible across all measurements. Another common application for deferred acquisition is to wait for a given stabilization period to elapse after the instrument’s attenuators and filters are configured at the beginning of the measurement process.

Load impedance will be relatively constant at all times when using the ‘N’ female REFERENCE and DUT input jacks on the PhaseStation, due to the inherent isolation characteristics of the built-in active splitters. However, multichannel measurements will expose the reference and DUT sources to varying load conditions at the SMA-F channel input jacks during the startup phase, so deferred acquisition can be a useful tool in these cases.

Note that TimeLab doesn’t specify the trigger latency associated with a group of deferred measurements. Triggered measurements made with time interval counters will normally start collecting valid data within one sample period, but this isn’t guaranteed.

**Configure deferred acquisition**

As noted above, when deferred execution is selected, data from subsequent measurements is discarded until the measurement is “triggered” manually with *Trigger deferred acquisition(s) (Enter)* or by cancelling deferred execution with a second *Enable deferred acquisition (Ctrl-d)* command. *Configure deferred acquisition* provides an additional way to trigger a deferred measurement.

With this option, the measurement triggers itself automatically once a specified number of seconds has elapsed after initiation. For example, this feature might be used to ignore the first few minutes of data when measuring oscillators with long warmup times or large startup transients. PhaseStation measurements have the option of using 5 kHz or 50 kHz measurement bandwidths for wide-range drift tracking, but other instruments may require some extra time.
Help Menu

User guide (F1)
This command launches the system’s default Web browser to display http://www.miles.io/timelab/readme.htm. Links on this page will allow you to download the latest version of TimeLab and access the latest edition of the PhaseStation 53100A User’s Manual (this file).

When you install TimeLab, a local copy of the PhaseStation 53100A manual is also installed on your hard drive.

About TimeLab
This command displays an “About” box showing the program version, compilation date, and any supported command-line parameters.

Debug mode
TimeLab contains some debugging/development-specific features that are not documented or supported for general use, and are likely to be removed or deprecated in the future. For example, Measurement→F)requency spectrum is intended for debugging, rather than as a supported feature, because the TimePod firmware isn't optimized for general spectrum-analysis work and the PhaseStation doesn’t support it at all. These debugging features will be inaccessible if Help→Debug mode is turned off.

It’s not recommended that you enable this “debug mode” under most circumstances, as it may disable important safeguards against measurement errors and cause other features to function in unexpected ways.

Check for updates (Ctrl-u)
By default, TimeLab will automatically check the Miles Design web site on a weekly basis and inform you if a newer version is available for download. Updates to TimeLab are always free of charge. You can use the Help→Check for updates (Ctrl-u) command to reschedule or disable these notifications.
PhaseStation 53100A Measurement Roles

The PhaseStation 53100A differs from earlier direct-digital instruments in that all four of its internal ADC channel inputs are user-accessible. For simplicity’s sake, the PhaseStation is typically operated in one of several predefined “measurement roles,” in which the individual channel inputs and jumper positions are assumed to be configured specifically for the selected task with their per-channel controls populated accordingly, or in a user-defined role in which the channel controls may be freely assigned. Not all of the information needed to take advantage of these capabilities can be accommodated in the acquisition dialog help text, so we’ll look at the details here.

Color-keyed diagrams for each role appear below in which red corresponds to external reference source connections, blue to connections made to the device(s) under test, and orange to the SMA jumper positions associated with the role. All of the remaining jacks that do not appear on the diagram for a given measurement role may be left unconnected.

Measure single DUT with single external reference

This is the default measurement role, which is based on the factory-default jumper positions shown above. In this configuration, a single measurement will be recorded when the Start measurement button is pressed. Depending on which measurement type(s) are selected, the measurement will include a phase data record based on the phase differences at channels 3 and 1, as well as cross-correlated phase noise and/or AM noise records based on independent acquisition of the signals present at channels 3-1 and 4-2.

The DUT and reference frequencies displayed in the legend table will be rounded to the nearest 100 kHz when this role is selected. The frequency- and phase-difference plots will represent the fractional frequency difference between the measured DUT signal and the displayed DUT frequency in the legend table. The frequency count chart will inherit the accuracy of the reference source at channel 1, given the assumption that the reference frequency is in fact an exact multiple of 100 kHz.

Application note AN 53100A-1, Oscillator Measurement and Calibration with the PhaseStation 53100A provides a practical introduction to the single DUT/single reference measurement role, based on a wide variety of real-world test scenarios.
Measure single DUT with dual internal references

PhaseStation instruments equipped with optional dual internal reference oscillators may be configured as shown above. In this role, phase noise and AM noise measurements between channels 3-1 and 4-2 will benefit from cross-spectral suppression of reference noise as well as other instrument noise contributions, while stability measurements will be made as usual based on the phase differences between channels 3 and 1.

Also as in the default measurement role, DUT and reference frequencies displayed in the legend table will be rounded to the nearest 100 kHz. The frequency-difference plot will represent the fractional frequency difference between the measured DUT signal and the displayed DUT frequency in the legend table. The frequency count chart will inherit the accuracy of the 100 MHz internal reference oscillator at channel 1.

Refer to Application Note 53100A-2 for more information about dual-reference measurements.

Measure single DUT with dual external references

All PhaseStation instruments (including those equipped with optional dual internal reference oscillators) can be configured for use with a pair of user-supplied external references by connecting the reference sources to the channel 1 and 2 inputs as indicated above. The same considerations apply, noting that the two external references do not need to operate at the same frequency.

Please refer to Application Note 53100A-2 for important additional guidelines regarding external reference selection and usage, as well as the Choosing reference sources section on page 24.
Measure two DUTs with single external reference

This measurement role will yield two separate stability plots, one based on the phase differences between channel 3 and channel 1 and the other based on the phase differences between channel 4 and channel 1. No noise measurement will be performed in this case.

For each of the two plots, the DUT and reference frequencies displayed in that plot’s legend table row will be rounded to the nearest 100 kHz. The frequency-difference traces will represent the fractional frequency differences between the measured DUT signals and the displayed DUT frequencies as usual. The frequency count charts for both plots will inherit the accuracy of the reference oscillator at channel 1, based on the assumption that the reference frequency is an exact multiple of 100 kHz.

Note that because channel 1 acts as a common reference for both stability plots, it’s not necessary for the factory default reference-channel jumper configuration to be used as shown above. The reference can be supplied directly to CH 1 IN if desired, with CH 2 IN left unconnected. (One advantage to using the N-channel splitter input, however, is that the reference will not experience significant load-pulling effects due to attenuator and filter selection as the measurement is initialized.)

Additionally, if the instrument is equipped with the internal reference option, you may connect CH 1 IN to its adjacent INT REF output jack instead of using an external reference.

Measure three DUTs with single external reference

This measurement role is identical to the previous one, except that the CH 2 reference input jack is pressed into service as a third DUT input channel. Three stability plots (and no noise plots) will be generated when the Start measurement button is pressed.

As an example, ADEV and frequency-difference plots in which three high-performance crystal oscillators were measured simultaneously against a single cesium-beam frequency standard appear below. All three plots were generated by the same measurement using the Measure three DUTs with single external reference role. The HP 5061A frequency standard was connected to the CH 1 IN jack, while the three Oscilloquartz 8607 BVA oscillators were connected to CH 2 IN, CH 3 IN, and CH 4 IN.
**Figure 55** Stability plots of three crystal oscillators measured simultaneously against a cesium-beam standard.
Measure three independent DUTs (three-cornered hat)

This measurement role is similar to Measure single DUT with dual external references, in that it is capable of performing a cross-correlated phase noise and/or AM noise measurement of a single device under test that is connected to channels 3 and 4 via an internal or external RF splitter. The phase noise and AM noise contributions from the two independent references connected to channels 1 and 2 – whether internal or external – will be averaged out of the measurement over time.

However, three stability plots are generated in this measurement role rather than only one. In these stability plots, unlike the AM and phase noise measurements, the three connected devices are treated as individual test sources. Each source is represented as a DUT in one of the plots, and each also serves as a reference in one of the plots. The resulting trio of mutually-dependent stability plots can be rendered by TimeLab in the usual fashion, appearing as three independent traces, or they can be rendered in a special display mode using the Trace→Show separated xDEV variances (N-cornered hat) (Ctrl-h) function (Page 95.) In this mode, TimeLab will attempt to display the stability characteristics of each device by itself, rather than showing traditional stability measurements based on two contributing sources.

Note that any phase noise/AM noise data obtained in this measurement role will be associated only with the first of the three stability plots. The remaining two plots will not contain any noise data.

As with the other dual-reference measurements, please refer to Application Note 53100A-2 for a discussion of three-cornered hat measurements in TimeLab with detailed examples.
Manual configuration

As shown above, selecting the **Manual configuration** measurement role will enable all of the dialog fields associated with channel assignment and frequency specification that are normally grayed out when working with predefined measurement roles. Any changes you make to these fields will be saved for recall whenever the **Manual configuration** role is selected in the future, as long as the **Restore defaults** button has not been pressed since the changes were made.

Most PhaseStation users will not need to configure these fields manually, as the predefined roles should cover the most common measurement scenarios. Cases in which manual configuration should be considered include:

- You need to connect DUT input jacks to reference sources, or vice versa
- You need to perform noise measurements with nonstandard channel input connections
- You wish to display DUT and/or reference frequencies in the legend table with more than the default 100-kHz rounding precision
- The nominal frequency of your reference source is not a multiple of 100 kHz
- You wish to specify precise DUT or reference input frequencies for any other reason

In these scenarios, the **Manual configuration** role provides the required flexibility at some cost in complexity. As with other fields in the acquisition dialog, detailed online help can be obtained by hovering over any of the controls associated with manual role configuration.

![Figure 57: Manual configuration controls](image-url)
Two-Port Residual Measurements

Residual noise and stability measurements with the PhaseStation can be conveniently performed in the Measure single DUT with single external reference role. Typically a two-way RF splitter is used to feed a signal from a common reference source to both the REFERENCE jack and the input of the device under test. The device’s output, in turn, is connected to the PhaseStation’s DUT input jack. To the extent the device contributes its own phase drift, phase noise, or AM noise to the stimulus signal passing through it, the impact will be evident on the respective measurement traces.

Residual measurements are an integral part of the PhaseStation production and maintenance processes. Each PhaseStation ships with a test report showing the result of a two-hour residual measurement with 5 MHz and +15 dBm applied to the DUT and REFERENCE input ports via a Mini-Circuits ZFSC-2-1 splitter. The following observations don’t necessarily reflect the specification limits, but they will give you an idea of what to expect when conducting your own proof-of-performance measurements.

- At 50 Hz ENBW, residual ADEV at 5 MHz should be in the high E-14s at t=1s. Thermal effects may push the slope out somewhat, especially in an unstable environment or when warmup time has been insufficient. A look at the phase difference graph will often show a consistent phase slope for the first 30-60 minutes of a measurement made after a cold start.

- Residual PN at 5 MHz should be below 145 dBc/Hz at 10 Hz after a few minutes.

- With a strong, clean input signal at 5 to 10 MHz, the residual PN floor in the 10 kHz – 1 MHz decades will usually end up below -175 dBc/Hz after less than two hours. Expect lower performance near either end of the supported frequency range. When possible, both proof-of-performance tests and actual two-port device measurements should be made in the 5-10 MHz range where the PhaseStation’s own residual performance is optimal.

- If the PC can support overlapped FFT processing, consider enabling this option by checking the Additional options→Overlapped acquisition box in the PhaseStation acquisition dialog. Very low close-in noise levels will require much less measurement time when overlapping is enabled.

- Phase hits and large outliers in the frequency-difference trace are never normal in a residual test with a clean source signal. They should be investigated if they recur with no obvious explanation. Spurs in phase noise plots should not exceed -100 dBc in a 5 MHz residual measurement, and will normally be much lower.

Some typical residual performance test results are reproduced below.
Figure 58: 5 MHz residual ADEV and phase drift
Figure 59: 5 MHz residual phase noise and AM noise
JavaScript API Function Reference

TimeLab includes an embedded JavaScript engine\(^\text{13}\) that can run automated test scripts using the TimePod 5330A and PhaseStation 53100A. The API functions listed below are useful in a variety of applications ranging from performance verification procedures to user-developed test scripts.

Usage examples for many of these API functions can be found in the 53100A_performance_test.js script included with TimeLab, as well as 5330A_performance_test.js and 5330A_ADC_test.js.

For more information on creating, editing, and running test scripts, refer to the Scripts menu description on page 113.

AcqChannel([Number user_value, ] Number channel)

Returns the position in the legend table beneath the graph, from 0 to 8, of the plot associated with the script instance’s specified acquisition channel. Since plots being acquired under script control may be moved up and down in the legend table by the user like any other loaded plots, AcqChannel() is needed to obtain the value needed when calling ScriptBindToPlot() in multichannel acquisitions.

The channel parameter should range from 0 to one less than the value returned by AcqNumChannels(). If two parameters are passed, the first is the user_value that was originally passed to AcqStartAcquisition() when the plot at the desired index was created.

Scripts that perform only standard single-channel acquisitions will not need to use this function.

AcqCheckOptions(String option_name [{, String option_name}])

This function is reserved for compatibility with Symmetricom 3120A test scripts. It always returns TRUE in scripts associated with TimePod 5330A and PhaseStation 53100A measurements.

AcqClearParams()

Each script instance maintains a dictionary of acquisition parameters that can be used to override any or all of the acquisition dialog parameters when AcqStartAcquisition() is called. AcqClearParams() clears this dictionary. It is normally called before issuing the AcqSetParam() call(s) needed to configure the measurement.

Acquisition parameters that the script does not explicitly set with AcqSetParam() will assume their default values when the measurement begins.

\(^{13}\) [https://v8.dev](https://v8.dev)
See `AcqNumParam()`, `AcqStrParam()` and `AcqSetParam()` for more information.

`AcqGetAMSpurTable(Array offset_array, Array amplitude_array)`

Populates `offset_array` and `amplitude_array` with a list of all detected AM spurs in the current measurement, returning the total number of AM spurs.

`AcqGetPMSpurTable(Array offset_array, Array amplitude_array)`

Populates `offset_array` and `amplitude_array` with a list of all detected PM spurs in the current measurement, returning the total number of PM spurs.

`AcqGetXDEVBins(String selection, Array tau_array, Array sigma_array)`

`AcqGetXDEVChart(Array tau_array, Array sigma_array)`

Populates `tau_array` and `sigma_array` with a list of sigma(tau) values from all valid bins in the specified statistical measurement, or from the most recently rendered sigma(tau) chart, depending on which function is called. The selection parameter passed to `AcqGetXDEVBins()` should be a string beginning with ‘a’, ‘h’, ‘m’, or ‘t’, corresponding to Allan deviation, Hadamard deviation, modified Allan deviation, or time deviation, respectively.

`AcqGetXDEVBins()` differs from `AcqGetXDEVChart()` in that `AcqGetXDEVChart()` returns results only for the 1, 3, 10 tau multiples beginning at t=1s that were displayed in the most-recently-visible numeric table for the measurement. Before calling `AcqGetXDEVChart()`, you should use `MeasurementSelectView()` or `MeasurementDeferSelectView()` to display the statistical measurement for which the chart contents should be returned. Additionally, `TraceShowNumTab(true)` should be called to ensure that the numeric table is visible, and the script must allow time for at least one frame to be rendered. `AcqGetXDEVBins()` does not have any of these constraints.

`AcqNumAcquiredPoints()`

Returns the number of acquired points in the phase data record.

`AcqNumChannels()`

Returns the number of acquisition channels in the measurement associated with the script instance.

In scripts that perform only standard single-channel acquisitions, this function always returns 1.

`AcqParam(String key)`

`AcqStrParam(String key)`

`AcqNumParam(String key)`
Each script instance maintains a dictionary of acquisition parameters that can be used to override any or all of the default acquisition dialog parameters when `AcqStartAcquisition()` is called. `AcqStrParam()` and `AcqNumParam()` return string or numeric values, respectively, for the specified acquisition parameter.

If an existing plot is associated with the script instance, these functions will return the specific value associated with the plot. Otherwise, if the script has not yet started a measurement, `AcqStrParam()` and `AcqNumParam()` will return the value from the dictionary of initial parameters that will be passed to `AcqStartAcquisition()`. In either case, an attempt to look up an unrecognized parameter value will return an empty string.

`AcqParam()` is equivalent to `AcqStrParam()`, and is deprecated as a function name. New scripts should use `AcqStrParam()` or `AcqNumParam()` instead, depending on whether the parameter should be evaluated as a numeric value or as an arbitrary string.

See `AcqSetParam()` and `AcqClearParams()` for more information.

`AcqReadAMNoiseTrace(Number offset_Hz)`

`AcqReadPMNoiseTrace(Number offset_Hz)`

These functions return the current AM noise or phase noise level in dBc/Hz at the specified offset from the carrier. A value greater than 0 indicates that data is unavailable, either because the AM noise or phase noise trace has not yet been displayed or because noise data from the FFT segment containing the specified offset frequency is not yet available.

Values returned by these functions are based on the most recent AM noise or phase noise trace rendered. Scripts should use `MeasurementSelectView()` or `MeasurementDeferSelectView()` to select the appropriate measurement view prior to attempting to read noise trace values. Typically this is done from within an `EventTimer()` event handler, in order to ensure that valid data is available during a subsequent timer event.

`AcqSetParam(String key, String value)`

Each script instance maintains a dictionary of acquisition parameters that can be used to override any or all of the acquisition dialog parameters when `AcqStartAcquisition()` is called. `AcqSetParam()` updates the stored value for the specified acquisition parameter.

The best way to obtain a list of measurement parameter names and values for a given instrument is to use the Save Measurement Script button in the Utility tab of the acquisition dialog to create a script that will contain explicit `AcqSetParam()` statements for each supported parameter. Almost all parameters will have obvious counterparts in the instrument’s acquisition dialog; you can also refer to the Legend menu section on page 105 for individual descriptions.
See `AcqStrParam()`, `AcqNumParam()` and `AcqClearParams()` for more information.

**AcqStartAcquisition(String menu_entry, Boolean skip_dialog [, Number user_value])**

Starts a new measurement based on the script instance’s current set of acquisition parameters.

*menu_entry* should correspond *exactly* to the name of the instrument as it appears on the *Acquire* menu, including any ellipsis (...) that follows it. Currently the only officially-supported instrument names for scripted measurements are the *Miles Design TimePod* ... and *Jackson Labs PhaseStation* ... entries, so one of these strings must be supplied as the *menu_entry* value.

With a script-initiated measurement, the initial acquisition parameters are the same as the default values in a fresh TimeLab installation. These default parameters are then overwritten with any entries that appear in the script instance’s acquisition-parameter dictionary, as described in `AcqNumParam()`, `AcqStrParam()`, and `AcqSetParam()`. Unlike a manual measurement, script-based measurements do not write their parameters back to the driver’s .INI file. As a result, the dialog defaults that will appear in the next user-initiated acquisition will not reflect the parameters used for the last scripted acquisition.

Next, if `skip_dialog` is false, TimeLab will present the acquisition dialog to the user, allowing any parameters to be changed before the measurement begins. In most cases, `skip_dialog` should be set to true to allow the script to run without further user intervention. This will be the case for measurement scripts created with the *Save script* button in the acquisition dialog.

`AcqStartAcquisition()` will return true if the acquisition is initiated successfully, or false if an error occurred. Reasons for failure might include the lack of an available slot in the legend table for the plot(s) created by the acquisition, the use of an unrecognized *menu_entry* name, the specification of an invalid acquisition parameter value with `AcqSetParam()`, or (if `skip_dialog` is false) the user’s selection of the *Cancel* button.

Once the measurement begins collecting data, the script’s `EventAcqTriggered()` event handler (if any) will be called. Prior to this stage, the script’s `EventAcqSetup()` handler will be called if one is defined. Because `AcqStartAcquisition()` returns immediately after launching the acquisition thread, measurement-specific parameters such as *Input Freq* will not be available to the script until `EventAcqTriggered()` is called.

Optionally, a third parameter may be passed, consisting of an arbitrary numeric *user_value* which will be made available to subsequent event handlers.
**AcqStopAcquisition()**

Immediately stops any acquisition associated with the running script instance and calls the script’s `EventAcqDone()` handler (if any). Unless a fatal error occurs, the plot(s) will not be closed and the script will continue to run until `ScriptEnd()` is called.

**AcqSetupEnd()**

Applications that include `EventAcqSetup()` handlers must call `AcqSetupEnd()` when their setup phase is complete. Until `AcqSetupEnd()` is called, the PhaseStation driver will remain in an endless loop awaiting further setup commands from the script.

**DisplayOverlayMode([Boolean overlay_mode])**

Equivalent to the `Display→Browse plots one at a time (b)` or `Display→Overlay all loaded plots (o)` command, depending on the `overlay_mode` parameter.

`overlay_mode` is optional; if it is not provided by the script, the function simply returns true in Overlay mode or false in Browse mode. If a new `overlay_mode` value is specified, the function returns the previous display mode.

**DisplayShowNumTab([Boolean status])**

Sets and/or retrieves the `status` of the flag controlled by `Display→Numeric table (Ctrl-n.)`. Refer to this command for more information.

To return the current flag value, call `DisplayShowNumTab()` with no argument.

**DisplayRefresh([Number mask])**

Forces an immediate display refresh that includes the elements specified by `mask`. If no parameter is passed, all display elements are refreshed.

Currently-defined display elements include the following:

```c
const U32 RCP_STATUS = 0x0001;  // Status line
const U32 RCP_SELECTION = 0x0002;  // Triangle cursor for selected plot in table
const U32 RCP_BANNERS = 0x0004;  // Colored status tags
const U32 RCP_CURSORS = 0x0008;  // Dragged selection cursors
const U32 RCP_MOUSEOVER = 0x0010;  // Mouseover information display
const U32 RCP_TIP = 0x0020;  // Script TIP window
const U32 RCP_ALL = 0x003F;  // All elements above
```

**DisplayFontSize([Number points])**

Sets or returns the size of the main display font size used in the TimeLab window. This is the same value that is adjusted by the commands on the Display menu.

If no parameter is specified, the current font size is returned without alteration.
**EventRunScript()**

This is a mandatory user-supplied function that must appear in every TimeLab script. It is called when the user issues Scripts→Run script or a similar command, and serves as the entry point for script execution.

Typically, EventRunScript() does little more than set up the appropriate acquisition parameters and call AcqStartAcquisition(), returning immediately afterwards. Subsequently, the script’s EventAcqTriggered() handler is called by TimeLab when the acquisition begins collecting data after the optional EventAcqSetup() phase. EventAcqTriggered(), in turn, may use TimeSetTimer() to arrange for periodic callback service to EventTimer(). Scripts that need to perform extensive measurement supervision and control operations normally do so within their EventTimer() handlers, while final result evaluation and report generation is done within EventAcqDone().

For a detailed look at the operation and overall life cycle of test scripts, refer to the 53100A_performance_test.js script provided with TimeLab, as well as the other API function descriptions in this section.

**EventAcqTriggered([user])**

This is an optional user-supplied function. EventAcqTriggered() is called when a measurement initiated by AcqStartAcquisition() begins collecting data. Typically this happens a few seconds after AcqStartAcquisition() is called by the user-provided EventRunScript() function, unless the deferred acquisition options on the Acquire menu have been used to postpone data collection. The optional user parameter receives the optional user variable passed to AcqStartAcquisition().

Any errors that occur between EventRunScript() and EventAcqTriggered() automatically terminate script execution.

See EventRunScript() for further information.
**EventAcqDone**([success],[user])

This is an optional user-supplied function. **EventAcqDone()** is called when an acquisition ends, either because the requested measurement duration expired, because an error occurred, or because it was stopped manually by the user. The optional **success** parameter is a Boolean value that indicates whether the hardware driver reported any errors during the measurement. The optional **user** parameter receives the optional user variable passed to **AcqStartAcquisition()**.

See **EventRunScript()** for further information.

**EventTimer()**

This is an optional user-supplied function. **EventTimer()** is called periodically at a rate determined by the parameter passed to **TimeSetTimer()**.

Because TimeLab's scripting system relies on cooperative multitasking, most non-trivial scripts should carry out the majority of their processing work in their **EventTimer()** handler while their measurement(s) are in progress. For detailed examples of timer usage, refer to **53100A_performance_test.js** and **5330A_ADC_test.js**. Also see **EventRunScript()** for further information.

**EventAcqSetup**([user])

This is an optional user-supplied function. **EventAcqSetup()** is called after a measurement running on a PhaseStation 53100A has connected to the target instrument, but before it enters the pretrigger state in preparation for data acquisition. The optional **user** parameter receives the optional user variable passed to **AcqStartAcquisition()**.

During the setup phase, a number of additional setup-related API functions are available. The user setup handler typically uses these functions to communicate with the PhaseStation to query operational parameters, validate correct operation, and identify signal frequencies and amplitudes at the input jacks. The setup handler may also need to communicate with other equipment in certain applications.

In order to proceed to the pretrigger phase, the setup handler must exit by calling **AcqSetupEnd()**. Most scripts other than diagnostic applications will not need to implement a setup handler.
PhaseStation 53100A User’s Manual V1.00   1-Oct-2019   142

SetupDetectSignals
SetupDetectedValid
SetupDetectedAmpldBfs
SetupDetectedFreqHz
SetupMeasureSignals
SetupMeasuredAmpldBm
SetupMeasuredFreqHz
SetupSetDefaultAttenuation
SetupStrQuery
SetupNumQuery

These setup API functions are supported only by the PhaseStation 53100A, and only when called from within an EventAcqSetup handler. They are currently reserved for internal use.

FileCloseAllChannels()

Closes all plot(s) acquired in the most recent measurement executed by the script, stopping any acquisition(s) that may still be in progress. For conventional single-channel measurements, FileCloseAllChannels() is equivalent to calling FileClosePlot() with no argument.

As an example, 53100A_performance_test.js uses FileCloseAllChannels() in its EventAcqDone() handler to discard the two plots generated during the preliminary warmup acquisition that the script performs before running the actual test. (Because the warmup acquisition has already terminated at this point, EventAcqDone() is not reissuued.) Simply calling FileClosePlot() here would have closed only the first of the two plots.

FileCloseAllPlots()

Equivalent to calling FileClosePlot() on all loaded plots. For example, 5330A_ADC_test.js uses FileCloseAllPlots() to ensure that enough slots are available in the legend table to hold the four plots that it acquires for various ADC combinations.

FileClosePlot([Number selection])

If the optional selection parameter is specified, FileClosePlot() closes the plot at the specified position in the legend table, from 0 to 8. Since plots being acquired under script control may be moved up and down in the legend table by the user like any other loaded plots, AcqChannel() is needed to obtain the value passed to this function if the
The intent is to close any of the plot(s) that are associated with a measurement launched by the script.

Alternatively, selection may be omitted. In this case, the function closes the plot associated with the first channel of the most recent measurement executed by the script.

In both cases, calling FileClosePlot() on a plot associated with a given measurement will stop any acquisition(s) in progress that were initiated by that measurement. The script’s EventAcqDone() handler, if any, will be called for any acquisitions that were terminated by FileClosePlot().

FileExecute(Wait)(String path_to_file [, String params])

FileExecute() attempts to execute or otherwise open the specified file using the “open” verb with the Win32 ShellExecute() API function. If ShellExecute() returns successfully, FileExecute() returns true; otherwise, if an error occurred, it returns false.

An alternative version of this function, FileExecuteWait(), pauses execution of TimeLab until the spawned process exits. FileExecuteWait() uses the Win32 CreateProcess and WaitForSingleObject() APIs rather than ShellExecute(), but otherwise behaves similarly.

path_to_file should be a fully-qualified pathname. Optionally, a string consisting of one or more parameters may be passed to ShellExecute() via the params argument.

As an example, FileExecute() is used by 53100A_performance_test.js to view the generated HTML report page on the system’s Web browser.

FileImageURI()

Returns a .GIF image of the current TimeLab display in the form of an HTML data URI.

FileNumLoadedPlots()

Returns the number of currently-loaded plots, from 0 to 9.

FileNumUnsavedPlots()

Returns the number of currently-loaded plots, from 0 to 9, that have not been saved since being acquired or modified.

FileSave(String path, [String subdir,] String filename)

Based on the (case-insensitive) suffix of filename, FileSave() saves either a screen image in .TGA, .GIF, .BMP, .PCX, or .PNG format, or a .TIM file representing the measurement currently associated with the script.
By default, if \texttt{path} is empty, the user’s Documents folder is treated as the destination path. This path must already exist. The \texttt{subdir} parameter is optional; it represents a subdirectory relative to \texttt{path} in which the destination file will be saved. Unlike \texttt{path}, the \texttt{subdir} folder will be created automatically if it does not already exist.

\texttt{FileSave()} returns a string containing the saved file’s fully-qualified pathname. Any errors that occur will not be reported to the script. They will result in a JavaScript exception which will terminate the script with an appropriate error message.

To save .TIM data from multiple plots in a multichannel measurement, you must use \texttt{ScriptBindToPlot()} to associate the script with channels other than the first one. See \texttt{53100A_performance_test.js} for an example.

\texttt{FileSaveText(String path, [String subdir,] String filename, String contents)}

\texttt{FileSaveText()} saves the ASCII \texttt{contents} string to \texttt{filename}. As with \texttt{FileSave()} above, the user’s Documents folder is treated as the destination folder if \texttt{path} is empty. Any explicitly-specified \texttt{path} must already exist. The \texttt{subdir} parameter is optional; it represents a subdirectory relative to \texttt{path} in which the destination file will be saved. Unlike \texttt{path}, the \texttt{subdir} folder will be created automatically if it does not already exist.

\texttt{FileSaveText()} returns a string containing the saved file’s fully-qualified pathname. Any errors that occur will not be reported to the script. They will result in a JavaScript exception which will terminate the script with an appropriate error message.

As an example, \texttt{53100A_performance_test.js} uses \texttt{FileSaveText()} to save its HTML report.

\texttt{LegendSelect([String field_name] [, ] [Boolean status])}

Controls and/or reports the visibility of a given parameter (\texttt{field_name}) in the legend table beneath the graph.

This function’s arguments may consist of a single Boolean value, in which case it will select or deselect \texttt{all} legend fields in a manner similar to the \texttt{Legend→All} or \texttt{Legend→None} menu commands; a single String value, which will simply return the visibility state of the specified \texttt{field_name} without changing it; or both String and Boolean parameters, which will show (\texttt{status==true}) or hide (\texttt{status==false}) the specified \texttt{field_name} in the table and return its previous state.

\texttt{MaskResultMargin()}

Returns a Number value representing the margin by which the measurement associated with the script is passing (if positive) or failing (if negative) the mask test selected by \texttt{MaskSelect()}. The returned value is based on the most recently rendered frame, so it is dependent on both the current measurement view \textit{and} the currently selected mask.
Refer to the **Masks** menu description on page 111 for more information about TimeLab’s mask-test functionality.

**Important**: Keep in mind that JavaScript execution does not disable or inhibit the rest of the TimeLab user interface. While test masks are easy to create and use in TimeLab, script-based mask evaluation is complicated by the need to establish the correct measurement view, allow enough time for the display to update, and wait for valid results to become available for the X-axis range covered by the mask, all while allowing for the user’s ability to switch measurement views, move plots up and down in the legend table, or alter other settings manually at any time.

Typically the best way to coordinate the necessary script actions while allowing for manual user intervention is to use an `EventTimer()` handler to check the mask results and the current measurement view selection at the same time, then make any changes (such as selecting the next measurement view for evaluation) at the very end of the timer handler. Script authors are strongly encouraged to use the `EventTimer()` handler in `53100A_performance_test.js` as a model for their own mask-test procedures.

**MaskResultValid()**

Returns true if valid data is available from `MaskResultMargin()`, or false if the mask test was not ready for evaluation for any reason. For example, ADEV mask results will not be available if the measurement has not yet run long enough to return valid data at the tau corresponding to the left endpoint of the mask limit line, or if the user has turned visibility off for the plot associated with the script. Always check `MaskResultValid()` prior to calling `MaskResultMargin()`.

See `MaskResultMargin()` for other notes on scripted mask tests.

**MaskSelect([[String mask_name]])**

This function selects a mask for use with `MaskResultMargin()` and `MaskResultValid()`, returning the previously-selected mask if any. If `mask_name` is omitted, the function returns the currently-selected mask name. In both cases, the function will return an empty string if no mask was selected.

Mask names should be specified exactly as they appear in the `masks.txt` file accessed via **Masks→Edit mask definitions** (which also determines the names under which they are added to the **Masks** menu). See `MaskResultMargin()` for other notes on scripted mask tests.
MeasurementSelectView(String hotkey)

MeasurementDeferSelectView(String hotkey)

These functions accept a **hotkey** parameter that consists of the (case-sensitive) shortcut key for the desired measurement view as it appears in the **Measurement** menu. For example, `MeasurementSelectView("P")` will emulate the ‘P’ keyboard shortcut (**Measurement→Phase noise (P)**).

If your script is performing mask tests with multiple measurement types, it’s a good idea to call `MeasurementDeferSelectView()` as the last action taken before returning from `EventTimer()`. Upon the next invocation of `EventTimer()`, your script should call `MeasurementView()` and evaluate the masks or other test parameters for that view, regardless of any changes to the measurement view that may have taken place between timer ticks. Script authors are encouraged to use the `EventTimer()` handler in **53100A_performance_test.js** as a model for test procedures that use multiple measurement types.

The difference between `MeasurementSelectView()` and `MeasurementDeferSelectView()` is that the latter will not take effect until after the event handler returns. This distinction is important when multiple instances of the same script may be executed at once. Essentially, deferring the view selection until after all script instances with the same `EventTimer()` interval have been serviced leaves a single script instance “in charge” of the view, reducing opportunities for confusion.

MeasurementView()

Returns the current measurement view as a String containing the hotkey for the view as it appears in the **Measurement** menu. For example, when viewing a phase noise plot, `MeasurementView()` will return “P”, the shortcut key for **Measurement→Phase noise**.

See `MeasurementSelectView()` for additional notes on measurement view selection.

Print(…)

Displays one or more user-specified values in the script console window associated with the currently-bound plot. Multiple arguments may be separated by commas; a line feed will be inserted after each argument. (To avoid this, you can use string concatenation rather than multiple `Print()` arguments.)

Numerous usage examples for the `Print()` function appear in **53100_performance_test.js** and **5330A_ADC_test.js**.
ScriptBindToPlot(Number selection)

Associates the script instance with the plot at the specified position in the legend table, from 0 to 8.

Most script authors will not need to use `ScriptBindToPlot()`. It is required only in scripts that support multichannel plots, such as `53100A_performance_test.js` and `5330A_ADC_test.js`. A script can be associated ("bound") to only one plot at a time, and most operations performed by a script implicitly involve the currently bound plot. When a measurement initiated by a script specifies multiple stability channels, as in the TimePod and PhaseStation validation scripts mentioned, it’s necessary to use `ScriptBindToPlot()` to access the plots that represent all channels of the measurement.

By default, scripts are bound to channel 0 of a multichannel acquisition. It’s a good idea to restore the default channel-0 binding with `ScriptBindToPlot(AcqChannel(0))` before returning from any function or event handler that uses `ScriptBindToPlot()`.

Since plots in multichannel measurements may be moved up and down in the legend table by the user, `ScriptBindToPlot()` is normally used together with the `AcqChannel()` function. See the two performance test scripts mentioned above for further comments and usage examples.

ScriptUnbind()

Removes the association between the script instance and any plot to which it is bound.

ScriptBoundToPlot()

Returns the position in the legend table beneath the graph, from 0 to 8, of the plot to which the script is currently bound.

Most script authors will not need to use `ScriptBoundToPlot()`. It is required only in scripts that support multichannel plots, such as `53100A_performance_test.js` and `5330A_ADC_test.js`. 
ScriptEnd()

Marks the script for cleanup by the TimeLab runtime JavaScript engine. Scripts which are associated with loaded plots must be terminated with a call to ScriptEnd() when finished. Otherwise, they will continue to run (and consume resources) until one of the following conditions is true:

- A script exception or other fatal error occurs
- The Scripts→Stop all running scripts (F12) command is issued by the user
- The user exits from TimeLab

ScriptFilename(Boolean full_path)

If full_path is true, ScriptFilename() returns a String containing the fully-qualified path to the script’s JavaScript (.js) source file. Otherwise, it returns only the filename itself.
ScriptGetString(String heading, String message, Object user_text, String b1_text [, String b2_text [, String b3_text]])

Presents a modal dialog box to the user that accepts freeform text entry. An example appears below.

```javascript
var trace_caption = { value:"(Some default text could go here)" };
if (ScriptGetString("OCXO Stability Test", "Enter trace caption above, then click 'OK' to continue.", trace_caption, "OK", "Cancel") != 0)
{
  ScriptEnd();
  return;
}
```

When executed, the result is a dialog box of the form

![ScriptGetString() dialog](image)

Text for one, two, or three buttons can be specified as the b1_text, b2_text, and/or b3_text argument(s) to ScriptGetString(). The returned value will equal the numeric index of the button selected by the user, beginning with 0 for the b1_text button.

All text fields accept up to 1024 bytes. Note that the user_text argument is an Object containing a String property called value, not a String in itself. The value property is used both as the default text used to initialize the edit control and for reception of the returned text. (This is necessary because Strings are always passed by copy in JavaScript, while Objects are passed by reference and may be modified by the called function.)
ScriptHostFilename(bool full_path)

Returns a String containing the TimeLab executable filename and version information. Either the full pathname or only the filename portion may be requested, depending in the value of the optional full_path parameter.

ScriptLastStatusMessage()

Returns a String containing the most recent status message displayed by TimeLab. This function may be useful for logging and report generation.

ScriptMessageBox(String heading, String message, String b1_text [, String b2_text [, String b3_txt]])

Presents a modal dialog box to the user that accepts button presses. An example appears below.

```java
if (ScriptMessageBox( "Manufacturing Test",
"Connect input signals and click 'OK' to continue.",
"OK",
"Cancel") != 0)
{
    ScriptEnd();
    return;
}
```

When executed, the result is a dialog box of the form

![Figure 61: ScriptMessageBox() dialog](image)

Text for one, two, or three buttons can be specified as the b1_text, b2_text, and/or b3_text argument(s) to ScriptMessageBox(). The returned value will equal the numeric index of the button selected by the user, beginning with 0 for the b1_text button.
ScriptMinsToHMS(Number minutes)

Returns a String representing the minutes argument as hours, minutes, and seconds.

Example: The following statement

    Print(ScriptMinsToHMS(10.5));

will display:

    10m 30s

ScriptNumVal(String format_string, Number value)

Returns a String consisting of the specified format_string with an embedded numeric value.

In operation, ScriptNumVal() passes its format_string and floating-point value arguments to the standard C sprintf() function, returning the resulting formatted string.

Example: The following statement

    Print(ScriptNumVal("Pi = %.2lf", 3.1415926535));

will display:

    Pi = 3.14

Additional usage examples appear in both 53100A_performance_test.js and 5330A_ADC_test.js. Refer to the sprintf() documentation in the C runtime library reference for a detailed discussion of the format and precision specifiers supported for floating-point values.

ScriptPlaySound(String filename)

Plays the specified sound file. Sound files for use with this function are typically stored in the .wav format.

If filename contains a backslash character, TimeLab assumes it consists of a fully-qualified path name and plays the sound from the filename exactly as specified. Otherwise, filenames without backslash characters are played from the TimeLab installation directory.
**ScriptSetTTYHeader(Number linenum [, String text])**

Sets and/or retrieves the text displayed at the top of the script TTY window that is associated with the plot(s) bound to the script instance.

The `linenum` argument specifies which of the first two TTY lines will be retrieved or updated; it must equal 0 or 1. The `text` argument is optional. If present, it will replace the existing text for the specified TTY line. Regardless, the function will return the contents of the specified line at the time it was called.

Note that the script TTY is associated with the most recent plot that has been acquired by the script or otherwise bound to it. (All channels in a multichannel acquisition share the same TTY.) The `Print` function will write its output to the TimeLab status line if no TTY is associated with the script, but `ScriptTTYHeader()` will fail with an exception. In most cases, you should not attempt to write to the TTY before `AcqStartAcquisition()` has been called.

**ScriptShowTTY([Boolean show])**

Shows or hides the script TTY window that is associated with the plot(s) bound to the script instance, returning the previous visibility state. If the `show` argument is omitted, the function will return the current visibility state without changing it.

The script TTY window becomes visible by default upon successful execution of `AcqStartAcquisition()`. However, because the TTY can obscure a large portion of the TimeLab graph display area, simple scripts that report little or no status information may wish to hide the TTY window. The user will still have the option to select `Scripts→Toggle script console for selected plot (F11)` to show the TTY manually.

Unlike the other TTY functions, `ScriptShowTTY()` may be called at any time. The visibility state that it establishes will be inherited by any subsequent plots that the script acquires.

**TimeHoursSinceTrigger()**

**TimeMinsSinceTrigger()**

**TimeSecsSinceTrigger()**

These three functions return the elapsed time since the measurement currently associated with the script was triggered, if the measurement is still in progress. Otherwise, if the measurement is no longer in progress, the overall duration of the acquisition is returned.

The values returned are floating-point Numbers that equivalently represent the elapsed time in terms of hours, minutes or seconds.
TimeSetTimer(Number msec)

This function arranges for TimeLab to call the script’s `EventTimer()` handler at regular intervals of `msec` milliseconds. Timer callbacks are made `msec` milliseconds after the previous call to the timer handler returned – meaning that if a timer handler runs for more than one service interval, missed intervals will not be made up.

Because TimeLab’s scripting system relies on cooperative multitasking, most non-trivial scripts should carry out the majority of their processing work in their `EventTimer()` handler while their measurement(s) are in progress. For detailed examples of timer usage, refer to `53100A_performance_test.js` and `5330A_ADC_test.js`.

Prior to termination, a script that uses timer service should call `TimeSetTimer(0)` to discontinue further callbacks.

TraceAvgWindow([Number seconds])

Sets and/or retrieves the duration in `seconds`, from 0.01 to 10000.0, of the averaging window used for phase- and frequency-difference plots. An argument of 0 `seconds` disables averaging entirely.

The function returns the previous window duration. It may be called with no argument to return the current value without altering it.

See the `Trace→Averaging window for phase/frequency traces (g)` command for important information on trace averaging.

TraceFreqZero([Boolean status])

Sets and/or retrieves the `status` of the flag used by `Trace→Phase/frequency traces begin at zero (z)` when frequency-difference measurements are selected for viewing. Refer to this command for more information.

To return the current flag value for the frequency-difference view, call `TraceFreqZero()` with no argument.

TraceMarkSpurs([Boolean status])

Sets and/or retrieves the `status` of the spur-visibility flag controlled by `Trace→Mark spurs in noise traces (Ctrl-m)`. Refer to this command for more information.

To return the current spur-visibility flag value, call `TraceMarkSpurs()` with no argument.
TraceOverlayAMPM([Boolean status])
Sets and/or retrieves the status of the flag controlled by Trace→Show AM noise in PN view (F8). Refer to this command for more information.

To return the current flag value, call TraceOverlayAMPM() with no argument.

TracePhaseFreqAutoY([Boolean status])
Sets and/or retrieves the status of the flag controlled by Trace→Phase/frequency Y axis unlocked in zoom mode (y). Refer to this command for more information.

To return the current flag value, call TracePhaseFreqAutoY() with no argument.

TracePhaseFreqResid([Boolean status])
Sets and/or retrieves the status of the flag controlled by Trace→Show linear phase/frequency residual (r). Refer to this command for more information.

To return the current flag value, call TracePhaseFreqResid() with no argument.

TracePhaseFreqTrend([Boolean status])
Sets and/or retrieves the status of the flag controlled by Trace→Show linear phase/frequency trend (Ctrl-t). Refer to this command for more information.

To return the current flag value, call TracePhaseFreqTrend() with no argument.

TracePhaseFreqZero([Boolean status])
Sets and/or retrieves the status of the flag controlled by Trace→Phase/frequency traces begin at zero (z). Refer to this command for more information.

To return the current flag value for the phase- or frequency-difference view, call TracePhaseFreqZero() with no argument.

TracePhaseZero([Boolean status])
Sets and/or retrieves the status of the flag used by Trace→Phase/frequency traces begin at zero (z) when phase-difference measurements are selected for viewing. Refer to this command for more information.

To return the current flag value for the phase-difference view, call TracePhaseZero() with no argument.
TraceShowCorrGain([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Show correlation gain for selected noise trace (Ctrl-g). Refer to this command for more information.

To return the current flag value, call TraceShowCorrGain() with no argument.

TraceShowImag([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Show imaginary part of cross spectrum (Ctrl-F3). Refer to this command for more information.

To return the current flag value, call TraceShowImag() with no argument.

TraceShowNoiseFloor([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Show estimated instrument noise (F2). Refer to this command for more information.

To return the current flag value, call TraceShowNoiseFloor() with no argument.

TraceShowRaw([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Show raw PN channel trace(s) (Ctrl-r). Refer to this command for more information.

To return the current flag value, call TraceShowRaw() with no argument.

TraceShowSlopes([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Show FFT segment filter slope(s) (Ctrl-i). Refer to this command for more information.

To return the current flag value, call TraceShowSlopes() with no argument.

TraceSmoothNoise([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Smooth noise traces (Ctrl-w). Refer to this command for more information.

To return the current flag value, call TraceSmoothNoise() with no argument.

TraceThickness([Number status])

Sets and/or retrieves the status of the flag controlled by Trace→Toggle trace thickness for current measurement (T). Refer to this command for more information.

If a value other than 1 or 0 is passed, all traces will be rendered with heavy lines. (Boolean true and false values may also be used.) To return the current flag value, call TraceThickness() with no argument.
TraceTickMarks([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Tick marks (k). Refer to this command for more information.

To return the current flag value, call TraceTickMarks() with no argument.

TraceNCorneredHat([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Show separated xDEV variances (N-cornered hat) (Ctrl-h). Refer to this command for more information.

To return the current flag value, call TraceNCorneredHat() with no argument.

TraceXDEVBars([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Show xDEV error bars (Ctrl-e). Refer to this command for more information.

To return the current flag value, call TraceXDEVBars() with no argument.

TraceXDEVClipBW([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Clip xDEV traces by noise bandwidth (Ctrl-b). Refer to this command for more information.

To return the current flag value, call TraceXDEVClipBW() with no argument.

TraceXDEVClipConfidence([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Clip xDEV traces by confidence (Ctrl-v). Refer to this command for more information.

To return the current flag value, call TraceXDEVClipConfidence() with no argument.

TraceXDEVSpline([Boolean status])

Sets and/or retrieves the status of the flag controlled by Trace→Draw xDEV traces with spline interpolation (i). Refer to this command for more information.

To return the current flag value, call TraceXDEVSpline() with no argument.
The STREAM.EXE Phase/Frequency Data Server

TimeLab includes a Windows console application, STREAM.EXE, which can be used to provide remote access to measurement data acquired by a PhaseStation 53100A or TimePod 5330A. Continuous streams of phase-difference or frequency measurements acquired by STREAM.EXE can be written to a shared file or streamed continuously via TCP/IP over a local- or wide-area network.
Launching STREAM.EXE

STREAM.EXE uses relatively little CPU time or RAM compared to the full-fledged TimeLab application. As a console application, it displays no graphics at all. Consequently it can run on almost any Windows PC, including energy-efficient servers or netbooks.

You can launch STREAM.EXE from a Windows desktop shortcut, but it’s preferable to run it from a command prompt (“DOS box”) instead. Because the program’s user interface is based on command-line parameters rather than GUI controls, you’ll find it easier to work at the command prompt during the familiarization process. After you’ve determined what options and parameters are needed in your application, you can create a batch file or shortcut to launch STREAM.EXE with the same parameters.

STREAM.EXE is installed in the same directory as the rest of the TimeLab package. Unless you specified a different location during installation, you can find it by opening a DOS session and changing the current directory to `C:\Program Files\Miles Design\TimeLab`. To do this, select `Start → Run…` in Windows and enter `cmd` as the name of the program to run. Once the DOS box appears, drag its lower edge to expand the window to a more comfortable size. Then, enter the commands

```
cd "\program files\miles design\timelab"
stream /?
```

As shown below, the `/?` option causes STREAM.EXE to display a brief list of the command-line options available in the current release. (Black on white text indicates typed commands.)

![Figure 62: Running STREAM.EXE from the MS-DOS command line prompt](image-url)
Using STREAM.EXE

Because **STREAM.EXE** performs only phase/frequency stability measurements, its command-line options are relatively limited. Only one parameter is mandatory: you must specify the hardware driver’s filename as the first parameter on the command line. Currently, only the TimePod and PhaseStation drivers are supported, so all **STREAM.EXE** command lines must begin as follows:

```
stream timepod.tll
stream phasestation.tll
```

Additional options, described below, may be specified as needed.

`/serial:<sernum>`

When more than one TimePod or PhaseStation is connected to the server PC, you may need to use the `/serial` option to associate a given **STREAM.EXE** instance with a specific instrument. Each instance of **STREAM.EXE** supports only one acquisition at a time, but you can launch as many instances as desired.

**Example:** `stream timepod.tll /serial:55908.304876`

The command above will launch an instance of **STREAM.EXE** for use with the TimePod whose serial number is 55908.304876. All other parameters will assume their default values, configuring the server to provide phase-difference data on TCP/IP port 9192 at a rate of 10 readings per second.

`/file:<filename>`

Specifies the name of a file to which the phase-difference or frequency readings will be written. If the specified file already exists, it will be overwritten. Typically the file is shared with other applications that can access it in read-only mode while it’s being written by **STREAM.EXE**.

The data written to the file may be ‘followed’ from within TimeLab by selecting **Acquire→Acquire from live ASCII file**. You can also monitor the data written to the file with a command such as `tail -f <filename>` from Cygwin. Finally, pressing the Scroll Lock key will cause **STREAM.EXE** to print a copy of all lines written to the file to the stdout device (i.e., the DOS console itself).

**Example:** `stream timepod.tll /notcp /file:%HOMEPATH%\Documents\mydata.txt`

The command above writes a continuous stream of phase-difference readings to the file mydata.txt in the current user’s Documents folder. You can then use TimeLab or another application to ‘follow’ the file. Even if the acquisition fails or otherwise encounters problems, you can use the appropriate **File→Import** option to bring the data into TimeLab at any time.
Additionally, the /notcp option is used in this example to keep STREAM.EXE from attempting to open a network port.

/logfile:<filename>
Specifies the pathname for a logfile which will record status, warning, and error messages. If the /logfile parameter contains an absolute path specification, the log file is placed at that location. Otherwise, if /logfile specifies a filename by itself, the log file is placed in the folder indicated by the first status message written to the Windows console after startup, typically the user’s Documents directory.

The default logfile name used when no /logfile parameter is provided is server.log.

/port:<portnum>
Specifies the TCP/IP port on which STREAM.EXE will broadcast incoming phase-difference or frequency readings. By default, STREAM.EXE transmits data on port 9192.

To allow remote clients to access STREAM.EXE, you may need to configure your firewall or NAT gateway to open this port. Instructions for doing so can be obtained from the equipment manufacturer.

When using software written to capture phase data from the Symmetricom/TSC 5115A/5120A/5125A and compatible instruments, you should specify /port:1298 as well as /format:TSC on the STREAM.EXE command line. With TimeLab’s Acquire→Acquire from TCP/IP streaming server option, only the default phase-difference data format (/format:P) is supported. You can specify any desired port number as long as you also enter it in the acquisition dialog as shown below.

Example: stream timepod.tll /port:1234 /rate:100

This command will broadcast phase-difference data on port 1234 at a rate of 100 readings per second. You can receive the data on any machine on your LAN that can access the server, including the server PC itself. In TimeLab, the Acquire→Acquire from TCP/IP streaming server option could be used as shown in figure 62 below.
/msglvl:<0-5>
Specifies the “verbosity” of informational, warning, and error messages that STREAM.EXE will display on the server console. /msglvl:0 will display all available status messages and notices, including internal driver diagnostic messages, while /msglvl:5 will display only fatal error messages. The default message level is 3.

Messages displayed at the server console are also written to the logfile. See the /logfile option for more information.

/format:<P, F, TSC>
Specifies the type of measurement data that will be broadcast via TCP/IP or logged to the specified file.

STREAM.EXE writes phase-difference data by default (/format:P), but you can also record absolute frequency readings with /format:F or TSC 51xx-style phase values with /format:TSC. The latter option emits phase-difference data that has been inverted and scaled by the input frequency.

From TimeLab’s perspective, one reason to use Acquire→Acquire from TCP/IP streaming server with STREAM.EXE instead of the legacy TSC acquisition driver (Acquire→Symmetricom 5115A / 5120 A / 5125A (Frequency stability)) is that any warning or error messages from the TimePod or PhaseStation driver will be forwarded to the TimeLab client(s) by STREAM.EXE for display in their status lines. In /format:TSC mode only the numeric phase data is transmitted, for compatibility reasons.

See the /input and /ref descriptions below for important additional notes.
When the /format:F option is used to acquire a stream of absolute frequency measurements, each frequency reading is normally derived by subtracting the previous phase-difference reading from each incoming one and dividing the result by the reciprocal of the sampling interval. The resulting frequency difference is applied to the input frequency that was provided explicitly with the /input option or estimated when the measurement began, yielding an absolute frequency in hertz. This value, in turn, is logged to the specified file, sent to network clients via TCP/IP, and/or written to the local console window for diagnostic purposes if the Scroll Lock light is on.

It's possible to achieve much more accurate frequency readings if the frequency-difference value is computed over longer periods of time. The default /window:1 value causes frequency readings to be derived from adjacent pairs of phase-difference readings, as described above. If you specify a larger value with /window:n, the frequency differences are computed from phase readings separated by n sample intervals (or the number of intervals since the acquisition began, whichever is less.)

In the example below, an attempt was made to measure the actual output frequency from a DDS whose nominal frequency was set to 10 MHz. The use of /rate:1 yielded one reading per second at the minimum supported measurement bandwidth of 0.5 Hz. The DDS clock was derived from the same 10 MHz reference that was supplied to the TimePod, making this a true “residual frequency” measurement.

Here, the frequency readings in green were displayed by turning Scroll Lock on to view the data in real time as it was acquired. After only 24 seconds, the results have converged to within about 3 parts in 10^{-15} of the expected value of 9999999.962747097 MHz. Real-world results will vary, but in any similar test you can expect a trend towards increased accuracy as the frequency-measurement interval grows towards its requested maximum.

See the /input and /ref option descriptions below for additional notes.
/rate:<1, 10, 100, 1000>

By default, **STREAM.EXE** configures the instrument driver to make 10 measurements per second. The baseband measurement bandwidth is half of this interval, or 5 Hz by default. The PhaseStation drivers limits the minimum bandwidth to 5 Hz, even when /rate:1 is used.

You can use the /rate option to select 1 reading per second to minimize network bandwidth and/or disk space for use with extremely stable sources. Conversely, measurements of drift-prone sources may require /rate:100 or /rate:1000 to avoid acquisition failures.

Note that TimePod measurements made at 1 reading per second (0.5 Hz BW) are likely to fail if insufficient warmup time is allowed for the DUT, the reference source, or the instrument itself.

/timestamp:<s, MJD>

/sep:<character>

These related options cause **STREAM.EXE** to timestamp each phase-difference or frequency reading sent to files or network clients.

By default, no timestamps are emitted. When /timestamp:MJD is specified, the Modified Julian Date (MJD) associated with each phase-difference or frequency value will be written as the first numeric field on each line, followed by a space character (ASCII 32), then the measurement value itself. MJD timestamps are generated with six digits of decimal precision, resulting in roughly 10 unique MJD values per second.

You can also use /timestamp:s to emit a simple numeric timestamp at one-microsecond precision. These timestamps begin at 0.000000 for the first reading acquired.

In either case, the difference between successive timestamps will always be equal to the reciprocal of the /rate parameter, whose default is 10 readings per second.

The /sep option may be used to specify an additional separator character that will appear before the space between the timestamp and measurement value. If the client requires comma-separated values, for example, /sep:, would be useful. Any numeric value used as the /sep: argument is treated as an ASCII code; e.g. /sep:9 generates a tab character.

**Example:** stream timepod.tll /rate:1 /format:F /timestamp:MJD /sep;
When acquiring data directly from a PhaseStation in most of the predefined measurement roles, TimeLab rounds the reference and input frequencies to the nearest 100 kHz. If you wish to obtain accurate frequency counts in TimeLab’s Measurement→Frequency difference (f) view in measurements where one or both of these frequencies is not a multiple of 100 kHz, you can use the /ref and /input options to specify the nominal reference and/or input frequencies explicitly.

See the preceding demonstration of the /window option for an example.
The /autoupdate function is useful in scenarios where STREAM.EXE may need to be recompiled, upgraded, or otherwise replaced over a network without manual intervention at the server console. When /autoupdate is present on the command line, STREAM.EXE will periodically check for the presence of a file called STREAM.EX1 in the same directory as the executable. If STREAM.EX1 is ever found, STREAM.EXE will terminate with exit(2), reporting the message “Server terminated due to release of new version.”

This feature depends on the use of a batch file or script to launch STREAM.EXE. Upon detecting exit code 2 when STREAM.EXE terminates, the batch file or script should overwrite STREAM.EXE with a copy of STREAM.EX1, delete STREAM.EX1, and then relaunch the new STREAM.EXE process with the same set of command-line parameters. When any other exit code is returned by STREAM.EXE, the batch file or script can exit normally or take other actions.

Two examples of /autoupdate batch files are included in the TimeLab directory. SERVE.BAT is a generic launcher for STREAM.EXE that specifies the phasestation.tll and /autoupdate options on behalf of the user, passing along any other command-line options as well. TSC.BAT demonstrates the use of the /format:TSC and /port:1298 options along with /autoupdate.

SERVE.BAT appears below in its entirety.

```plaintext
@echo off
rem Batch file to launch TCP streaming data server with PhaseStation driver
rem and automatic restart capability
rem
:start
rem
rem If stream.ex1 exists in the directory, rename it to stream.exe and run it
rem (passing any command-line arguments that were originally used with
rem serve.bat)
rem
if not exist stream.ex1 goto serve
copy stream.ex1 stream.exe >nul
del stream.ex1
:serve
if not exist stream.exe goto bail
stream phasestation.tll /autoupdate %*
rem
rem If stream server exits with code 2, it means that the /autoupdate option
rem detected a new copy of stream.ex1 in the directory. Go back and launch
rem the new version without any manual intervention
rem
if errorlevel 2 goto start
:bail
```
/noexit

By default, STREAM.EXE will disconnect any attached clients, close its destination file (if any), and terminate with exit(1) under a variety of abnormal conditions, including loss of input or reference signals, out-of-range signal frequencies or amplitude levels, or other acquisition errors. To force the server to restart itself instead of terminating after errors that may be transient or otherwise nonfatal in nature, use the /noexit option.

Attached clients will still be disconnected when the server restarts, but they may reconnect if desired, assuming the server is able to start a new acquisition. If a destination file was specified with the /file option, it will remain open and the new acquisition process will continue to update it.

Note that certain conditions such as memory allocation failures and loss of the USB connection are still considered fatal even with /noexit, and will cause STREAM.EXE to terminate.

/notcp

You can use /notcp to keep STREAM.EXE from opening any network ports or otherwise attempting to act as a TCP/IP server. See the description of the /file option for an example.

/nowarnings

When /nowarnings is used, certain conditions such as excessive reference/input frequency and amplitude drift that would normally result in warning messages will generate error messages instead. Subsequently, STREAM.EXE will disconnect any attached clients, close its destination file (if any), and terminate with exit(1).

If /noexit is used in conjunction with /nowarnings, the server will attempt to restart itself under these circumstances rather than terminating. See the /noexit option description for further details.
Appendix: Legal and regulatory notices
Federal Communications Commission Statement

This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant to part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful interference in a residential installation. This equipment generates, uses and can radiate radio frequency energy and, if not installed and used in accordance with the instructions, may cause harmful interference to radio communications. However, there is no guarantee that interference will not occur in a particular installation. If this equipment does cause harmful interference to radio or television reception, which can be determined by turning the equipment off and on, the user is encouraged to try to correct the interference by one or more of the following measures:

- Reorient or relocate the receiving antenna
- Increase the separation between the equipment and receiver
- Connect the equipment into an outlet on a circuit different from that to which the receiver is connected
- Consult the dealer or an experienced radio/TV technician for help

Changes or modifications not expressly approved by the party responsible for compliance may void the user's authority to operate the equipment.

EC Declaration of Conformity

Manufacturer: Jackson Labs Technologies, Inc., 10080 Alta Drive, Suite 110, Las Vegas, NV 89145, USA

Product: PhaseStation 53100A Phase Noise Test Set

Description: Small/portable electronic instrument for laboratory use by qualified personnel, powered by external DC supply with UL/CUL/TUV/CB/CE approvals

Directives: 2006/95/EC The Low Voltage Directive and its amending directives
2002/95/EC Restrictions on Hazardous Substances and its amending directives

EN 61326-1:2001 Electrical Requirements for Electrical Equipment for Measurement, Control and Laboratory Use – Part 1: General Requirements

Signature: I hereby certify that this equipment has been designed and manufactured in accordance with the above referenced Standards, and complies with all essential requirements of the Directives.

John Miles
Engineer, Jackson Labs Technologies, Inc.
July 11, 2019
Performance Certification and Validation

Jackson Labs Technologies, Inc. certifies that this product met its published specifications at time of delivery. Because measurements made by the PhaseStation 53100A Phase Noise Test Set are based on differences between the external signals applied to the DUT and REFERENCE ports, no specific periodic calibration procedures are required. Furthermore, in the absence of errors reported by the measurement software, no specific maintenance procedures are necessary, including preventative or periodic maintenance.

The procedures outlined in the default mask definition file (default_masks.txt) will permit customer verification of all specifications using commonly available test signals. Users requiring annual performance certification should contact http://www.jackson-labs.com/index.php/support for factory-certified performance verification options.

Warranty

This Jackson Labs Technologies, Inc. hardware product is warranted against defects in material and workmanship for a period of 1 (one) year from date of delivery. During the warranty period Jackson Labs Technologies, Inc. will, at its discretion, either repair or replace products that prove to be defective. Jackson Labs Technologies, Inc. does not warrant that the operation for the software, firmware, or hardware shall be uninterrupted or error free even if the product is operated within its specifications.

For warranty service, this product must be returned to Jackson Labs Technologies, Inc. or a service facility designated by Jackson Labs Technologies, Inc. Customer shall prepay shipping charges (and shall pay all duties and taxes) for products returned to Jackson Labs Technologies, Inc. for warranty service. Except for products returned to Customer from another country, Jackson Labs Technologies, Inc. shall pay for return of products to Customer. If Jackson Labs Technologies, Inc. is unable, within a reasonable time, to repair or replace any product to condition as warranted, the Customer shall be entitled to a refund of the purchase price upon return of the product to Jackson Labs Technologies, Inc.

Limitation of Warranty

The foregoing warranty shall not apply to defects resulting from improper or inadequate maintenance by the Customer, Customer-supplied software or interfacing, unauthorized modification or misuse, opening of the instruments enclosure or removal of the instruments panels, operation outside of the environmental or electrical specifications for the product, or improper site preparation and maintenance. JACKSON LABS TECHNOLOGIES, INC. SPECIFICALLY DISCLAIMS THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. No license, express or implied, by estoppel or otherwise, to any intellectual property rights is granted by this document. Jackson Labs Technologies, Inc. products are not intended for use in medical, life saving, or life sustaining applications.

Exclusive Remedies

THE REMEDIES PROVIDED HEREIN ARE THE CUSTOMER’S SOLE AND EXCLUSIVE REMEDIES. JACKSON LABS TECHNOLOGIES, INC. SHALL NOT BE LIABLE FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, WHETHER BASED ON CONTRACT, TORT, OR ANY OTHER LEGAL THEORY.
Software License: TimeLab

http://www.miles.io/timelab/readme.htm

Copyright (c) 2011-2019 Miles Design LLC and Jackson Labs Technologies, Inc. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted, provided that the following conditions are met:

1. For all components that include source code provided by Miles Design LLC or Jackson Labs Technologies, Inc., redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Names and trademarks associated with Miles Design LLC or Jackson Labs Technologies, Inc. may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY MILES DESIGN LLC AND JACKSON LABS TECHNOLOGIES, INC. "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL MILES DESIGN LLC OR JACKSON LABS TECHNOLOGIES, INC. BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Software License: FFTSS

http://www.ssisc.org/fftss/index.html.en

Copyright 2002-2007 Akira Nukada. All rights reserved.
Copyright 2002-2007 The SSI Project. All rights reserved.
The Scalable Infrastructure Project, supported by "Development of Software Infrastructure for Large Scale Scientific Simulation" Team, CREST, JST.
Akira Nishida, Department of Computer Science, The University of Tokyo, 7-3-1 Hongo, Bunkyo-ku, Tokyo 113-8656, Japan.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE SCALABLE SOFTWARE INFRASTRUCTURE PROJECT "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE SCALABLE SOFTWARE INFRASTRUCTURE PROJECT BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Software License: FIDLIB

http://uazu.net

GNU LESSER GENERAL PUBLIC LICENSE

Version 2.1, February 1999

Copyright (C) 1991, 1999 Free Software Foundation, Inc.

51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

[This is the first released version of the Lesser GPL. It also counts as the successor of the GNU Library Public License, version 2, hence the version number 2.1.]

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public Licenses are intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users.

This license, the Lesser General Public License, applies to some specially designated software packages--typically libraries--of the Free Software Foundation and other authors who decide to use it. You can use it too, but we suggest you first think carefully about whether this license or the ordinary General Public License is the better strategy to use in any particular case, based on the explanations below.

When we speak of free software, we are referring to freedom of use, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish); that you receive source code or can get it if you want it; that you can change the software and use pieces of it in new free programs; and that you are informed that you can do these things.

To protect your rights, we need to make restrictions that forbid distributors to deny you these rights or to ask you to surrender these rights. These restrictions translate to certain responsibilities for you if you distribute copies of the library or if you modify it.

For example, if you distribute copies of the library, whether gratis or for a fee, you must give the recipients all the rights that we gave you. You must make sure that they, too, receive or can get the source code. If you link other code with the library, you must provide complete object files to the recipients, so that they can relink them with the library after making changes to the library and recompiling it. And you must show them these terms so they know their rights.

We protect your rights with a two-step method: (1) we copyright the library, and (2) we offer you this license, which gives you legal permission to copy, distribute and/or modify the library.

To protect each distributor, we want to make it very clear that there is no warranty for the free library. Also, if the library is modified by someone else and passed on, the recipients should know that what they have is not the original version, so that the original author's reputation will not be affected by problems that might be introduced by others.

Finally, software patents pose a constant threat to the existence of any free program. We wish to make sure that a company cannot effectively restrict the users of a free program by obtaining a restrictive license from a patent holder. Therefore, we insist that any patent license obtained for a version of the library must be consistent with the full freedom of use specified in this license.

Most GNU software, including some libraries, is covered by the ordinary GNU General Public License. This license, the GNU Lesser General Public License, applies to certain designated libraries, and is quite different from the ordinary General Public License. We use this license for certain libraries in order to permit linking those libraries into non-free programs.

When a program is linked with a library, whether statically or using a shared library, the combination of the two is legally speaking a combined work, a derivative of the original library. The ordinary General Public License therefore permits such linking only if the entire combination fits its criteria of freedom. The Lesser General Public License permits more lax criteria for linking other code with the library.
We call this license the "Lesser" General Public License because it does Less to protect the user's freedom than the ordinary General Public License. It also provides other free software developers Less of an advantage over competing non-free programs. These disadvantages are the reason we use the ordinary General Public License for many libraries. However, the Lesser license provides advantages in certain special circumstances.

For example, on rare occasions, there may be a special need to encourage the widest possible use of a certain library, so that it becomes a de-facto standard. To achieve this, non-free programs must be allowed to use the library. A more frequent case is that a free library does the same job as widely used non-free libraries. In this case, there is little to gain by limiting the free library to free software only, so we use the Lesser General Public License.

In other cases, permission to use a particular library in non-free programs enables a greater number of people to use a large body of free software. For example, permission to use the GNU C Library in non-free programs enables many more people to use the whole GNU operating system, as well as its variant, the GNU/Linux operating system.

Although the Lesser General Public License is Less protective of the users' freedom, it does ensure that the user of a program that is linked with the Library has the freedom and the wherewithal to run that program using a modified version of the Library.

The precise terms and conditions for copying, distribution and modification follow. Pay close attention to the difference between a "work based on the library" and a "work that uses the library". The former contains code derived from the library, whereas the latter must be combined with the library in order to run.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License Agreement applies to any software library or other program which contains a notice placed by the copyright holder or other authorized party saying it may be distributed under the terms of this Lesser General Public License (also called "this License"). Each licensee is addressed as "you".

A "library" means a collection of software functions and/or data prepared so as to be conveniently linked with application programs (which use some of those functions and data) to form executables.

The "Library", below, refers to any such software library or work which has been distributed under these terms. A "work based on the Library" means either the Library or any derivative work under copyright law: that is to say, a work containing the Library or a portion of it, either verbatim or with modifications and/or translated straightforwardly into another language. (Hereinafter, translation is included without limitation in the term "modification".)

"Source code" for a work means the preferred form of the work for making modifications to it. For a library, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the library.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running a program using the Library is not restricted, and output from such a program is covered only if its contents constitute a work based on the Library (independent of the use of the Library in a tool for writing it). Whether that is true depends on what the Library does and what the program that uses the Library does.

1. You may copy and distribute verbatim copies of the Library's complete source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and distribute a copy of this License along with the Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Library or any portion of it, thus forming a work based on the Library, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) The modified work must itself be a software library.

b) You must cause the files modified to carry prominent notices stating that you changed the files and the date of any change.

c) You must cause the whole of the work to be licensed at no charge to all third parties under the terms of this License.

d) If a facility in the modified Library refers to a function or a table of data to be supplied by an application program that uses the facility, other than as an argument passed when the facility is invoked, then you must make a good faith effort to ensure
that, in the event an application does not supply such function or table, the facility still operates, and performs whatever part of its purpose remains meaningful.

(For example, a function in a library to compute square roots has a purpose that is entirely well-defined independent of the application. Therefore, Subsection 2d requires that any application-supplied function or table used by this function must be optional: if the application does not supply it, the square root function must still compute square roots.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Library, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Library, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Library.

In addition, mere aggregation of another work not based on the Library with the Library (or with a work based on the Library) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this License to a given copy of the Library. To do this, you must alter all the notices that refer to this License, so that they refer to the ordinary GNU General Public License, version 2, instead of to this License. (If a newer version than version 2 of the ordinary GNU General Public License has appeared, then you can specify that version instead if you wish.) Do not make any other change in these notices.

Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General Public License applies to all subsequent copies and derivative works made from that copy.

This option is useful when you wish to copy part of the code of the Library into a program that is not a library.

4. You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange.

If distribution of object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place satisfies the requirement to distribute the source code, even though third parties are not compelled to copy the source along with the object code.

5. A program that contains no derivative of any portion of the Library, but is designed to work with the Library by being compiled or linked with it, is called a "work that uses the Library". Such a work, in isolation, is not a derivative work of the Library, and therefore falls outside the scope of this License.

However, linking a "work that uses the Library" with the Library creates an executable that is a derivative of the Library (because it contains portions of the Library), rather than a "work that uses the library". The executable is therefore covered by this License. Section 6 states terms for distribution of such executables.

When a "work that uses the Library" uses material from a header file that is part of the Library, the object code for the work may be a derivative work of the Library even though the source code is not. Whether this is true is especially significant if the work can be linked without the Library, or if the work is itself a library. The threshold for this to be true is not precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small macros and small inline functions (ten lines or less in length), then the use of the object file is unrestricted, regardless of whether it is legally a derivative work. (Executables containing this object code plus portions of the Library will still fall under Section 6.)

Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work under the terms of Section 6. Any executables containing that work also fall under Section 6, whether or not they are linked directly with the Library itself.

6. As an exception to the Sections above, you may also combine or link a "work that uses the Library" with the Library to produce a work containing portions of the Library, and distribute that work under terms of your choice, provided that the terms permit modification of the work for the customer's own use and reverse engineering for debugging such modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the Library and its use are covered by this License. You must supply a copy of this License. If the work during execution displays copyright notices, you
must include the copyright notice for the Library among them, as well as a reference directing the user to the copy of this License. Also, you must do one of these things:

a) Accompany the work with the complete corresponding machine-readable source code for the Library including whatever changes were used in the work (which must be distributed under Sections 1 and 2 above); and, if the work is an executable linked with the Library, with the complete machine-readable “work that uses the Library”, as object code and/or source code, so that the user can modify the Library and then relink to produce a modified executable containing the modified Library. (It is understood that the user who changes the contents of definitions files in the Library will not necessarily be able to recompile the application to use the modified definitions.)

b) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that (1) uses at run time a copy of the library already present on the user's computer system, rather than copying library functions into the executable, and (2) will operate properly with a modified version of the library, if the user installs one, as long as the modified version is interface-compatible with the version that the work was made with.

c) Accompany the work with a written offer, valid for at least three years, to give the same user the materials specified in Subsection 6a, above, for a charge no more than the cost of performing this distribution.

d) If distribution of the work is made by offering access to copy from a designated place, offer equivalent access to copy the above specified materials from the same place.

e) Verify that the user has already received a copy of these materials or that you have already sent this user a copy.

For an executable, the required form of the “work that uses the Library” must include any data and utility programs needed for reproducing the executable from it. However, as a special exception, the materials to be distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary libraries that do not normally accompany the operating system. Such a contradiction means you cannot use both them and the Library together in an executable that you distribute.

7. You may place library facilities that are a work based on the Library side-by-side in a single library together with other library facilities not covered by this License, and distribute such a combined library, provided that the separate distribution of the work based on the Library and of the other library facilities is otherwise permitted, and provided that you do these two things:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library facilities. This must be distributed under the terms of the Sections above.

b) Give prominent notice with the combined library of the fact that part of it is a work based on the Library, and explaining where to find the accompanying uncombined form of the same work.

8. You may not copy, modify, sublicense, link with, or distribute the Library except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense, link with, or distribute the Library is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

9. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Library or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Library (or any work based on the Library), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Library or works based on it.

10. Each time you redistribute the Library (or any work based on the Library), the recipient automatically receives a license from the original licensor to copy, distribute, link with or modify the Library subject to these terms and conditions. You may not impose any further restrictions on the recipients’ exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties with this License.

11. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Library at all. For example, if a patent license would not permit royalty-free redistribution of the Library by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Library.
If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply, and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

12. If the distribution and/or use of the Library is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Library under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

13. The Free Software Foundation may publish revised and/or new versions of the Lesser General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Library specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Library does not specify a license version number, you may choose any version ever published by the Free Software Foundation.

14. If you wish to incorporate parts of the Library into other free programs whose distribution conditions are incompatible with these, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

16. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS
Software License: V8 JavaScript Engine

https://v8.dev

Copyright 2006-2012, the V8 project authors. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

* Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

* Neither the name of Google Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.